-->Donations via PayPal [External Link Removed for Guests] :guitar
-->Installation/Post Installation Tutorial [Local Link Removed for Guests]
-->Useful Links [Local Link Removed for Guests]
-->Olarila Images - Updated images [Local Link Removed for Guests]
-->Guides and Tutorials [Local Link Removed for Guests]
-->Clover Folder for All Chipsets [Local Link Removed for Guests]
-->DSDT Patch Requests [Local Link Removed for Guests]

Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

jbuttonfan
Posts: 19
Joined: 16 Dec 2018, 18:08
CPU: i7 8750H
Motherboard: Dell G7 7588
GPU: Intel UHD630

Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by jbuttonfan » 02 Jan 2019, 22:19

vinhtq115, no luck with the color banding issue?

As of now I have only two issues, the color banding and the hibernation. When the computer sleeps while I am away from the keyboard, It’s pretty difficult to come back, I had a 1TB external hd plugged in and it was inaccessible even after coming back. I could read the data from other computer, but never from the G7. It was a ext4 formatted hd just so I could read/write from both OS (win/mac). Now I have formatted the drive as NTFS, I can r/w as long as I have Tuxera NTFS installed on mac. But the hibernation is quite scary.
vinhtq115
Posts: 18
Joined: 30 Oct 2018, 12:53
CPU: Intel Core i7-8750H
Motherboard: Dell G7 7588
GPU: NVidia Geforce GTX 1060 Max-Q

Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by vinhtq115 » 06 Jan 2019, 11:37

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
02 Jan 2019, 22:19
vinhtq115, no luck with the color banding issue?

As of now I have only two issues, the color banding and the hibernation. When the computer sleeps while I am away from the keyboard, It’s pretty difficult to come back, I had a 1TB external hd plugged in and it was inaccessible even after coming back. I could read the data from other computer, but never from the G7. It was a ext4 formatted hd just so I could read/write from both OS (win/mac). Now I have formatted the drive as NTFS, I can r/w as long as I have Tuxera NTFS installed on mac. But the hibernation is quite scary.
I'm stuck with color banding issue. Tried patching EDID and still not fixed. I think I will ask everyone who owns a laptop (other than Dell G7) with Coffee Lake UHD 630 and see if they have it too.
About hibernation, I never tried it on macOS before and will not try before I replace the SSD that comes with my G7 (only 120TBW). Have you tried HibernationFixup kext?
vinhtq115
Posts: 18
Joined: 30 Oct 2018, 12:53
CPU: Intel Core i7-8750H
Motherboard: Dell G7 7588
GPU: NVidia Geforce GTX 1060 Max-Q

Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by vinhtq115 » 20 Jan 2019, 14:08

Download ResXtreme, choose color mode with 8 bits/sample. While this doesn't fix the issue, it will make the color banding less noticeable.
jbuttonfan
Posts: 19
Joined: 16 Dec 2018, 18:08
CPU: i7 8750H
Motherboard: Dell G7 7588
GPU: Intel UHD630

Re: Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by jbuttonfan » 09 Feb 2019, 02:35

I haven't found a fix for the color banding issue yet. For hibernation, I simply turned it off for now. It corrupted once one of my external drives (it was formatted as exFAT).

Currently I have one BIG issue. I can only boot to macOS when my G7 is plugged in to the wall charger. When I am on battery, it never ends booting or, doesn't boot at all. I have to plug in the power and then it magically boots normally. I have no idea of what it could be.
vinhtq115
Posts: 18
Joined: 30 Oct 2018, 12:53
CPU: Intel Core i7-8750H
Motherboard: Dell G7 7588
GPU: NVidia Geforce GTX 1060 Max-Q

Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by vinhtq115 » 13 Feb 2019, 06:41

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
09 Feb 2019, 02:35
I haven't found a fix for the color banding issue yet. For hibernation, I simply turned it off for now. It corrupted once one of my external drives (it was formatted as exFAT).

Currently I have one BIG issue. I can only boot to macOS when my G7 is plugged in to the wall charger. When I am on battery, it never ends booting or, doesn't boot at all. I have to plug in the power and then it magically boots normally. I have no idea of what it could be.
Does it stuck at Apple logo with full loading bar? Install FakePCIID.kext + FakePCIID_HDMI_Audio.kext.
Color banding may need panel upgrading to fix.
User avatar
Kanta
Posts: 15
Joined: 07 Jul 2011, 15:33
CPU: Intel Core i5-3330
Motherboard: Asus H61M-A/BR
GPU: GeForce® GTX 750 TI

Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by Kanta » 15 Feb 2019, 20:50

I have a GeForce GTX 750 Ti and managed to install the Web Driver on 17G2208 build using this script: [External Link Removed for Guests] works 100%.
vinhtq115
Posts: 18
Joined: 30 Oct 2018, 12:53
CPU: Intel Core i7-8750H
Motherboard: Dell G7 7588
GPU: NVidia Geforce GTX 1060 Max-Q

Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by vinhtq115 » 19 Feb 2019, 14:21

@jbuttonfan are you dual booting with Windows 10? If so, does DW1560 play well with Windows (BT and Wifi)?
jbuttonfan
Posts: 19
Joined: 16 Dec 2018, 18:08
CPU: i7 8750H
Motherboard: Dell G7 7588
GPU: Intel UHD630

Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by jbuttonfan » 23 Feb 2019, 18:53

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
13 Feb 2019, 06:41

Does it stuck at Apple logo with full loading bar? Install FakePCIID.kext + FakePCIID_HDMI_Audio.kext.
Color banding may need panel upgrading to fix.
For some reason it started to work again without these kexts.

color banding is still there though.

Added in 1 minute 57 seconds:
[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
15 Feb 2019, 20:50
[External Link Removed for Guests]
This is unrelated to this topic - the script is only for eGPU.

Added in 6 minutes 2 seconds:
[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
19 Feb 2019, 14:21
@jbuttonfan are you dual booting with Windows 10? If so, does DW1560 play well with Windows (BT and Wifi)?
Yes, it does work very well. You have to follow a guide so you won't be pairing your apple trackpad and apple keyboards every time you boot in one of them. Unfortunately I can't find the guide on the web, but I found something similar to what I remember to have done here:
[External Link Removed for Guests]

Added in 4 minutes 17 seconds:
For external 4K display and HDPI mode enabled, I can only get it to 30hz. I need 60hz or else I might have some problems with my external display (I have seen some glitches while using before). I tried latest LILU + WEG and bootflag -cdfon enabled (enablehdmi20 property is already on my config). No luck.

I don't want to try Floris's Mac pixel clock patcher because it hasn't been updated for 10.14.3, and anyway, WEG is supposed to do the same for me.

I think that the problem might be the HDMI Cable, it isn't a hdmi 2.0 cable so I need to buy one and verify.
vinhtq115
Posts: 18
Joined: 30 Oct 2018, 12:53
CPU: Intel Core i7-8750H
Motherboard: Dell G7 7588
GPU: NVidia Geforce GTX 1060 Max-Q

Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by vinhtq115 » 25 Feb 2019, 08:31

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
23 Feb 2019, 19:05
color banding is still there though.
What panel did you replace with?
Hyprnx
Posts: 1
Joined: 28 Dec 2018, 02:05
CPU: Intel i7-8750H
Motherboard: H370M
GPU: nVidia 1060 Max-Q

Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by Hyprnx » 25 Feb 2019, 17:02

Follow your tutorial, iMessage, FaceTime, iCloud work right out of the box, no need to modify anything, but im stuck at step where you copy your EFI file from USB installer stick, then shutdown then boot it again, it should boot but mine keep saying that there is no bootable drive, even Windows partition is now undetectable, any suggestions?
Thank you, im newbie,sorry if i say something wrong

Edit: my device is also Dell G7 i7-8750H 8GB of RAM,1060 Max-Q and single 512GB Intel 760p, no HDD
User avatar
erroruser
Olarila Staff
Olarila Staff
Posts: 511
Joined: 24 Apr 2018, 21:12
CPU: AMD Ryzen 7 3700X
Motherboard: MSI MPG X570 Gaming Plus
GPU: Sapphire rx 5700 XT

Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by erroruser » 25 Feb 2019, 17:14

Hyprnx, have you check in the bios for boot priorities an have the 1st boot as (if using uefi) uefi main drive
AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36
:superman :superman
HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB
Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler
jbuttonfan
Posts: 19
Joined: 16 Dec 2018, 18:08
CPU: i7 8750H
Motherboard: Dell G7 7588
GPU: Intel UHD630

Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by jbuttonfan » 03 Mar 2019, 22:48

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
25 Feb 2019, 08:31
What panel did you replace with?
I did not replace any panel.

Btw are you sure the nvidia gtx 1060 max-q does not work with Mojave? I am still getting only 4k @ 30hz and having screen blackouts/artifacts, using only the Intel UHD630.
User avatar
erroruser
Olarila Staff
Olarila Staff
Posts: 511
Joined: 24 Apr 2018, 21:12
CPU: AMD Ryzen 7 3700X
Motherboard: MSI MPG X570 Gaming Plus
GPU: Sapphire rx 5700 XT

Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by erroruser » 03 Mar 2019, 22:50

NO NVIDIA will work with mojave there are no web drivers only older cards like fermi or kepler
AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36
:superman :superman
HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB
Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler
vinhtq115
Posts: 18
Joined: 30 Oct 2018, 12:53
CPU: Intel Core i7-8750H
Motherboard: Dell G7 7588
GPU: NVidia Geforce GTX 1060 Max-Q

Re: Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by vinhtq115 » 05 Mar 2019, 14:43

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
03 Mar 2019, 22:48
Btw are you sure the nvidia gtx 1060 max-q does not work with Mojave? I am still getting only 4k @ 30hz and having screen blackouts/artifacts, using only the Intel UHD630.
I'm pretty sure. Nvidia haven't release drivers for Mojave yet. Also, the ACPI patch disabled the dGPU so macOS won't be able to use it anyway. You may want to try IntelFBPatcher to fix 4k issues (iirc, you need to increase VRAM to 2048MB).
Last edited by vinhtq115 on 07 Mar 2019, 10:47, edited 2 times in total.
User avatar
Allan
Olarila Staff
Olarila Staff
Posts: 958
Joined: 07 May 2012, 03:55
CPU: i5-3210M
Motherboard: InsydeH20
GPU: IntelHD 4000
Location: São Paulo
Contact:

Re: Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by Allan » 05 Mar 2019, 16:17

Use the Hackintool.app: [External Link Removed for Guests]

And read the instructions about how to fix 4k issues as well: [External Link Removed for Guests]
Lenovo G480 [Local Link Removed for Guests]

[External Link Removed for Guests]
vinhtq115
Posts: 18
Joined: 30 Oct 2018, 12:53
CPU: Intel Core i7-8750H
Motherboard: Dell G7 7588
GPU: NVidia Geforce GTX 1060 Max-Q

Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by vinhtq115 » 19 Mar 2019, 12:51

Did anyone manage to play iTunes DRM Movies/TV Shows without getting HDCP error "This movie can be played only on displays that support HDCP (High-bandwidth Digital Content Protection)"? Everything works fine on Windows 10 but not on macOS.
murko
Posts: 6
Joined: 19 Mar 2019, 17:38
CPU: i7-8750H
Motherboard: Dell G7 7588
GPU: GTX 1050 ti

Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by murko » 27 Mar 2019, 01:59

I'm a little bit lost in here... I'm new to hackintoshing, so bare with me
on step 4, does it mean I need a working mac os in order to do these steps?
User avatar
erroruser
Olarila Staff
Olarila Staff
Posts: 511
Joined: 24 Apr 2018, 21:12
CPU: AMD Ryzen 7 3700X
Motherboard: MSI MPG X570 Gaming Plus
GPU: Sapphire rx 5700 XT

Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by erroruser » 27 Mar 2019, 02:11

step 4 is booting on from the usb
to make the usb you do not need a mac as in part 3b
AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36
:superman :superman
HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB
Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler
murko
Posts: 6
Joined: 19 Mar 2019, 17:38
CPU: i7-8750H
Motherboard: Dell G7 7588
GPU: GTX 1050 ti

Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by murko » 27 Mar 2019, 11:21

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
27 Mar 2019, 02:11
step 4 is booting on from the usb
to make the usb you do not need a mac as in part 3b
Thanks for the response!
Well so here I am:


4. Run Clover_v2.4k_r4658.pkg on USB drive (this means booting to clover interface, ok)
- if using GPT, select the target of the install to USB installer via "Change Install Location" (this is where I get lost... Ok, I'm on clover boot interface and there is no such options... And If I go ahead and try booting the mac os installer, I'll just end up with a back screen and nothing else)

:oops:
User avatar
erroruser
Olarila Staff
Olarila Staff
Posts: 511
Joined: 24 Apr 2018, 21:12
CPU: AMD Ryzen 7 3700X
Motherboard: MSI MPG X570 Gaming Plus
GPU: Sapphire rx 5700 XT

Dell G7 7588 (i7-8750H Coffee Lake) High Sierra Working

Post by erroruser » 27 Mar 2019, 15:29

just make usb no need to use clover till install is completed then when you on desktop run clover package an select main drive to install then go get the correct efi folder for your chipset
AMD Ryzen 7 3700X, MSI MPG X570 Gaming Plus, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, Sapphire rx 5700 XT, fractal celcius s36
:superman :superman
HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB
Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler
Post Reply

Return to “Guides and tutorials”