-->Donations via PayPal [External Link Removed for Guests] :guitar
-->Installation/Post Installation Tutorial [Local Link Removed for Guests]
-->Useful Links [Local Link Removed for Guests]
-->Olarila Images - Updated images [Local Link Removed for Guests]
-->Guides and Tutorials [Local Link Removed for Guests]
-->Clover Folder for All Chipsets [Local Link Removed for Guests]
-->DSDT Patch Requests [Local Link Removed for Guests]

DELL XPS 8700 com XEON

Post Reply
User avatar
Bauer
Veteran
Veteran
Posts: 557
Joined: 01 Feb 2012, 16:22
CPU: i7-740QM Quad Core 6mb
Motherboard: Toshiba Satellite P500
GPU: GT330M GDDR3 1024GB 128bit
Location: S.P Brazil

DELL XPS 8700 com XEON

Post by Bauer » 28 Jan 2017, 18:52

Fala galera. Faz um tempo que nao mexo com hacks,meu note ainda esta no Yosemite...

Nao sei se usar boot via Enoch é a melhor opcao nesse caso, o fato é que nunca precisei usar Clover pois minhas boards sempre foram bios comum entao nao me acostumei ainda com a opçcao de boot via UEFI. Mas queria testar usar em modo UEFI nesse projeto.

Recentemente tive a oportunidade de montar um setup interessante, de momento conta com uma GT520 Nvidia + Xeon E3-1220 V3 (Haswell 1150) e uma board do XPS 8700 que possui chipset z87 + duas memórias de 8gb (16gb)

Quando faço boot usando o Sierra do forum via clover, tanto via UEFI quanto legacy, o sistema reinicia. Ele identifica a maquina como Imac 14.2 no smbios. Nao sei se aí pode ser o problema em relaçao ao processador que nao possui video onboard por se tratar de um Xeon...

Image
Image
Image
Image
Image

Alguma observação a fazer?
ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE
X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 16343
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Re: DELL XPS 8700 com XEON

Post by MaLd0n » 28 Jan 2017, 20:14

usa npci=0x2000, mas usa clover, depois me envia os arquivos, dsdt, ioreg pra eu editar
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
User avatar
Bauer
Veteran
Veteran
Posts: 557
Joined: 01 Feb 2012, 16:22
CPU: i7-740QM Quad Core 6mb
Motherboard: Toshiba Satellite P500
GPU: GT330M GDDR3 1024GB 128bit
Location: S.P Brazil

Re: DELL XPS 8700 com XEON

Post by Bauer » 28 Jan 2017, 23:48

Nao rolou. Eu fiz a instalacao no modo legacy usando outra board, mesmo assim nao consegui. Setei o processador para 1 core, tambem nao mudou nada.

Consegui por enquanto extrair a DSDT via Linux
You do not have the required permissions to view the files attached to this post.
ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE
X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 16343
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Re: DELL XPS 8700 com XEON

Post by MaLd0n » 29 Jan 2017, 02:05

veja se tem essa opção Execute Disable Bit e muda pra Enable
DSDT.Bauer.zip
You do not have the required permissions to view the files attached to this post.
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
User avatar
Bauer
Veteran
Veteran
Posts: 557
Joined: 01 Feb 2012, 16:22
CPU: i7-740QM Quad Core 6mb
Motherboard: Toshiba Satellite P500
GPU: GT330M GDDR3 1024GB 128bit
Location: S.P Brazil

Re: DELL XPS 8700 com XEON

Post by Bauer » 29 Jan 2017, 04:49

Seria o mesmo que xd support?

Image
ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE
X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 16343
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Re: DELL XPS 8700 com XEON

Post by MaLd0n » 29 Jan 2017, 12:47

acho que não, vc já tentou selecionar os fixs pra kernel do clover?
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
User avatar
Bauer
Veteran
Veteran
Posts: 557
Joined: 01 Feb 2012, 16:22
CPU: i7-740QM Quad Core 6mb
Motherboard: Toshiba Satellite P500
GPU: GT330M GDDR3 1024GB 128bit
Location: S.P Brazil

Re: DELL XPS 8700 com XEON

Post by Bauer » 29 Jan 2017, 20:35

A patch para haswell eu tentei.

Vou tentar usar uma versao anterior do sistema. Dei uma pesquisada e ví que outros já conseguiram. A unica diferença no meu caso é estar usando o xeon que nao tem video
ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE
X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA
User avatar
Bauer
Veteran
Veteran
Posts: 557
Joined: 01 Feb 2012, 16:22
CPU: i7-740QM Quad Core 6mb
Motherboard: Toshiba Satellite P500
GPU: GT330M GDDR3 1024GB 128bit
Location: S.P Brazil

Re: DELL XPS 8700 com XEON

Post by Bauer » 01 Feb 2017, 23:08

Consegui uma solução parcial para instalar a versão 10.12.3 num HD como teste:

Baixei a imagem 10.12.3 na app store

Formatei um pen drive com o nome install no sistema de arquivos gpt

Montei a imagem no pen drive usando o codigo padrão de costume...

Code: [Local Link Removed for Guests]

sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --applicationpath /Applications/Install\ macOS\ Sierra.app
Após montado, instalei a versão corrente do clover R3994 [External Link Removed for Guests]

Nas configurações de instalação do Clover , marquei boot0af MBR, o resto deixei igual.

baixei a fake smc [External Link Removed for Guests]

Instalei em Drive/EFI/Clover/Kexts/10.12/ (no meu caso, usei somente ela)

Nas opções de bios ficou:

Legacy boot
Intel Virtualization (disable)
Secure Boot (off)
Boot por USB primeiro
Wake on LAN, Ethernet ROM, (off)

Ligando o PC pós aparecer a tela do clover, em Boot arguments type, coloquei: kext-dev-mode=1 -v
Na opção binaries patching marquei "Kernel PM patch"

Dessa forma, o boot ocorreu normalmente e consegui instalar o sistema na versão 10.12.3

Estou com problemas de video, a GT520 funciona parcialmente e só quando marco a opção web drivers no boot (instalei web drivers usando uma ATI 5670)

Os gráficos ficam quebrados. Ioreg e DSDT em anexo.
You do not have the required permissions to view the files attached to this post.
ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE
X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 16343
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Re: DELL XPS 8700 com XEON

Post by MaLd0n » 02 Feb 2017, 00:10

tem de ver se essa gpu funciona no sierra, a linha 5xx e linha 6xx não precisa do web driver, só usar inject nvidia
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
User avatar
Bauer
Veteran
Veteran
Posts: 557
Joined: 01 Feb 2012, 16:22
CPU: i7-740QM Quad Core 6mb
Motherboard: Toshiba Satellite P500
GPU: GT330M GDDR3 1024GB 128bit
Location: S.P Brazil

Re: DELL XPS 8700 com XEON

Post by Bauer » 11 Feb 2017, 13:51

Pelo que pesquisei não funciona nativamente.

Ví algumas soluções com injeção via NVCAP para Sierra, mas de qualquer forma essa placa seria apenas um quebra galho.

Tenho uma simples NVS 300 quadro, acho que vou usar ela por enquanto.

Meu projeto definitivo seria usar uma GTX 1050 , porem, preciso esperar o OSX ter suporte.
ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE
X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA
User avatar
Bauer
Veteran
Veteran
Posts: 557
Joined: 01 Feb 2012, 16:22
CPU: i7-740QM Quad Core 6mb
Motherboard: Toshiba Satellite P500
GPU: GT330M GDDR3 1024GB 128bit
Location: S.P Brazil

Re: DELL XPS 8700 com XEON

Post by Bauer » 17 Feb 2017, 02:43

Olá

Finalizei o projeto por enquanto usando uma NVS 300 como gráfica. Assim que a linha pascal tiver suporte, colocarei uma GTX 1050

XPS 8700 Motherboard
16GB DDR3 1600
Xeon E3-1220v3
NVIDIA QUADRO NVS 300 512MB DDR3
El Capitan 10.11.6
Clover r4003



Image
ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE
X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA
User avatar
Bauer
Veteran
Veteran
Posts: 557
Joined: 01 Feb 2012, 16:22
CPU: i7-740QM Quad Core 6mb
Motherboard: Toshiba Satellite P500
GPU: GT330M GDDR3 1024GB 128bit
Location: S.P Brazil

Re: DELL XPS 8700 com XEON

Post by Bauer » 17 Apr 2017, 02:14

Suporte para GTX 1xxx feito com sucesso.
You do not have the required permissions to view the files attached to this post.
ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE
X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA
User avatar
psycopedro
Posts: 4
Joined: 13 Jan 2019, 20:04
CPU: i7 Xeon v3 4aGen 3.6mhz
Motherboard: DELL z87 chipset
GPU: Gigabyte gtx 1060 6GB

DELL XPS 8700 com XEON

Post by psycopedro » 28 Jan 2019, 22:26

Olá Bauer, pode me dizer como fez pra rodar a 1050? eu tenho uma gigabyte 1060 (além de um xps igual o seu) e estou com o mesmo problema de boot ( sem sinal ). Se puder me ajudar aí vlw!!!
User avatar
Bauer
Veteran
Veteran
Posts: 557
Joined: 01 Feb 2012, 16:22
CPU: i7-740QM Quad Core 6mb
Motherboard: Toshiba Satellite P500
GPU: GT330M GDDR3 1024GB 128bit
Location: S.P Brazil

DELL XPS 8700 com XEON

Post by Bauer » 02 Sep 2019, 22:04

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
28 Jan 2019, 22:26
Olá Bauer, pode me dizer como fez pra rodar a 1050? eu tenho uma gigabyte 1060 (além de um xps igual o seu) e estou com o mesmo problema de boot ( sem sinal ). Se puder me ajudar aí vlw!!!
Eu dei o boot normalmente no meu usando a imagem do Forum. Essa serie de VGA funciona com webdriver para ter aceleração gráfica até o high sierrra. No Mojave não funciona a aceleração gráfica e não tem suporte com webdriver.

Esse tutorial me serviu quando fiz. [External Link Removed for Guests]
ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE
X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA
Post Reply

Return to “Sierra (10.12)”