-->Donations via PayPal [External Link Removed for Guests] :guitar
-->Installation/Post Installation Tutorial [Local Link Removed for Guests]
-->Useful Links [Local Link Removed for Guests]
-->Olarila Images - Updated images [Local Link Removed for Guests]
-->Guides and Tutorials [Local Link Removed for Guests]
-->Clover Folder for All Chipsets [Local Link Removed for Guests]
-->DSDT Patch Requests [Local Link Removed for Guests]

Sleep issue

User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13522
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Sleep issue

Post by MaLd0n » 30 Jul 2019, 14:17

sanyaaahtconex, use hackintool, Displays tab
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
User avatar
tbrautaset
Posts: 13
Joined: 06 Aug 2017, 21:50
CPU: Intel® i7-7700HQ CPU @ 2.80GHz
Motherboard: MSI GE72VR 7RF ApacheP MS-179B
GPU: Intel HD Graphics 630

Sleep issue

Post by tbrautaset » 06 Aug 2019, 10:53

Sleep doesn't work, goes in and out of hibernation all the time, nor does bluetooth because of error in config.plist, kext ?

Bluetooth works in Mojave. Incredibly slow boot during startup again error in config.plist, kext ?


Any help would be greatly appreciated. Send me with your config2.plist booted.



BIOS Version:E179BIMS.312 - 03/15/2018
Realease BIOS for WU & Update CPU microcode 0x84 for Intel-SA-00088 (Meltdown & Spectre) speculative execution side-channel vulnerabilities.

EC firmware Version:179BEMS1.108 - 11/03/2017
ME Firmware Version:11.8.50.3425

BIOS Settings : Loaded Optimized Defaults -->
- XHCI Hand-Off enabled, Attempt Secure Boot disabled, Fast Boot disabled, ERP lot 3 support enabled and Boot mode select UEFI with CSM

macOS Catalina 10.15 beta 5 (19A526h)
Clover_v2.5k_r5033


MSI details:

Intel® Core™ i7 7700HQ processor / HM175
GeForce® GTX 1060 3GB GDDR5
17.3" Full HD (1920x1080), 120 Hz Refresh Rate and 5ms response time panel
Cooler Boost 4 Technology ENHANCED COOLING DESIGN FOR HIGHER POWER
32GB Crucial DDR4 2400MHz SODIMM
NVMe M.2 SSD by PCI-E Gen 3.0 / Samsung 960 EVO 1TB M.2 NVMe SSD & WD Blue 1TB 2.5" SATA SSD
HL-DT-ST GUD0N SATA Int. DVD±RW (±R DL) / DVD-RAM
Realtek RTS5129 Card Reader (SD/SDHC/SDXC)
1x USB 3.1 SuperSpeed+ Type-C reversible plug, 2x TYPE-A USB3.0 & 1x USB2.0
SHIFT technology boosts performance under controlled noise & temperature
Nahimic 2 virtual 7.1 sound / Realtek ALC898
BisonCam, NB Pro Webcam HD type (30fps@720p)
Audio Boost 2 WITH 3 dedicated headset amplifiers,isolated audio board and gold-plated audio jacks:1x Mic-in & 1x Headphone-out (SPDIF)
Dynaudio speaker system / 4x 2W Speakers & 1x 3W Subwoofer
Keyboard by Steelseries with full color backlighting / PS/2 Keyboard / Synaptics PS/2 & SMBus Multi-Touch Touchpad
Killer Shielded E2500 Gigabit Ethernet + Broadcom BCM94352Z 802.11AC
1x HDMI (HDMI 4K@30Hz) & 1x Mini DisplayPort 1.2. = HDTV/Matrix Display supports 4K output with a resolution up to 3840 x 2160
Last edited by tbrautaset on 06 Aug 2019, 13:17, edited 1 time in total.
Laptop: #1: MSI GE72VR 7RF-272NE, i7-7700HQ/HM175, HD630 1920x1080 - macOS 10.12/13 /14 / 15
Laptop: #2: Lenovo ThinkPad T460 20FMS1A00, i5-6200U/Intel SoC, HD520 1920x1080 - macOS 10.12/13 /14
Laptop: #3: Compaq Evo Notebook N800c, P4-2400M, ATI Mobility Radeon 7500 - Mac OS X 10.4.8
sanyaaahtconex
Posts: 2
Joined: 24 Feb 2019, 10:03
CPU: i7
Motherboard: dell
GPU: hd4000

Sleep issue

Post by sanyaaahtconex » 06 Aug 2019, 12:26

MaLd0n, thx so much you are god of osx
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13522
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Sleep issue

Post by MaLd0n » 06 Aug 2019, 14:11

tbrautaset,
DSDT.aml.zip
use olarila clover folder for ur chipset
You do not have the required permissions to view the files attached to this post.
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
User avatar
tbrautaset
Posts: 13
Joined: 06 Aug 2017, 21:50
CPU: Intel® i7-7700HQ CPU @ 2.80GHz
Motherboard: MSI GE72VR 7RF ApacheP MS-179B
GPU: Intel HD Graphics 630

Sleep issue

Post by tbrautaset » 07 Aug 2019, 20:32

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
06 Aug 2019, 14:11
tbrautaset, DSDT.aml.zip
use olarila clover folder for ur chipset
Hi Daniel,

Your DSDT patches that tells the kernel to ignore my laptop BIOS-supplied table are really good!

How did you make mine without me sending you an F4 dump with native files to EFI / Clover / ACPI / origin ?

Is it enough with those who are generated by "Send me" ?


Most of my hardware works fine in Catalina now :), bluetooth too thanks to [External Link Removed for Guests]


Have 1 question about brightness control :

Installed acpi support base (0.142-8) acpid (1: 2.0.28-1 + b1) on my Debian 9 partition with apt install acpid -y

Then ran acpi_listen in terminal:

fn + down arrow key = video / brightness BRTDN 00000087 00000000 K
fn + up arrow key = video / brightness BRTUP 00000086 00000000 K


Downloaded [External Link Removed for Guests] and made a patch for DSDT :

Code: [Local Link Removed for Guests]

into method label BRTN replace_content
    begin
        // Brightness Down\n
            If ((0x87 == Arg0))
            {
                Notify (\_SB.PCI0.LPCB.PS2K, 0x0405)
            }\n
        // Brightness Up\n
            If ((0x86 == Arg0))
            {
                Notify (\_SB.PCI0.LPCB.PS2K, 0x0406)
            }
    end;


My CLOVER originated from [External Link Removed for Guests]

Code: [Local Link Removed for Guests]

> ACPI
                > patched
                                DSDT.aml
                                SSDT-PNLF.aml
                                SSDT-UIAC-ALL.aml
config.plist
> Boot
                <string>dart=0 nv_disable=1 brcmfx-country=#a</string>
 
> Audio
                                <key>Inject</key>
                                <integer>13</integer>
                                <string>0x59168086</string>
 
> Graphics
                                <key>ig-platform-id</key>
                                <string>0x591b0000</string>
 
 
 
> drivers
                > BIOS
                                ApfsDriverLoader.efi
                                FSInject.efi
                                HFSPlus.efi
                > UEFI
                                ApfsDriverLoader.efi
                                AptioMemoryFix.efi
                                FSInject.efi
                                HFSPlus.efi
> kexts
                > Other
                                ACPIBatteryManager.kext
                                AirportBrcmFixup.kext
                                AppleALC.kext
                                AppleBacklightFixup.kext
                                AtherosE2200Ethernet.kext
                                BrcmBluetoothInjector.kext
                                BrcmFirmwareData.kext
                                BrcmPatchRAM2.kext
                                CodecCommander.kext
                                FakeSMC.kext
                                Lilu.kext
                                NoTouchID.kext
                                USBInjectAll.kext
                                VoodooI2C.kext
                                VoodooI2CHID.kext
                                VoodooPS2Controller.kext
                                WhateverGreen.kext

Brightness Controll works with the arrow keys as planned, but suddenly my keyboard stops working and I have to restart to correct it.

This only happens when I adjust brightness after a while with the arrow keys, what can this be ?


Have I loaded some wrong kext's or can you see if something is obviously wrong in what I've listed above ?

Image
Laptop: #1: MSI GE72VR 7RF-272NE, i7-7700HQ/HM175, HD630 1920x1080 - macOS 10.12/13 /14 / 15
Laptop: #2: Lenovo ThinkPad T460 20FMS1A00, i5-6200U/Intel SoC, HD520 1920x1080 - macOS 10.12/13 /14
Laptop: #3: Compaq Evo Notebook N800c, P4-2400M, ATI Mobility Radeon 7500 - Mac OS X 10.4.8
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13522
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Sleep issue

Post by MaLd0n » 08 Aug 2019, 01:44

tbrautaset, brightness just use a simple pnlf patch + weg kext and apply a keys patch, don't need other injector, whatevergreen work for it now
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
bit128
Posts: 2
Joined: 17 Jun 2019, 06:07
CPU: Intel Core i5 5200U
Motherboard: Broadwell-U PCH L-P
GPU: Intel HD Graphics 5500

Sleep issue

Post by bit128 » 25 Aug 2019, 11:18

I have the same problem! My laptop is a toshiba. The model name is l50-c-137. When it is sleep the display is black, then wake after 5-10 secs, sleep again automatically and wake again but display is black. Anything solution? (mac OS Mojave 10.14.5). Please help me to solve the problem....Doante of course!!!
Post Reply

Return to “Catalina (10.15)”