-->Donations via PayPal [External Link Removed for Guests] :guitar
-->Installation/Post Installation Tutorial [Local Link Removed for Guests]
-->Useful Links [Local Link Removed for Guests]
-->Olarila Images - Updated images [Local Link Removed for Guests]
-->Guides and Tutorials [Local Link Removed for Guests]
-->Clover Folder for All Chipsets [Local Link Removed for Guests]
-->DSDT Patch Requests [Local Link Removed for Guests]

OpenCore Bootloader

User avatar
erroruser
Olarila Staff
Olarila Staff
Posts: 492
Joined: 24 Apr 2018, 21:12
CPU: i9 9900k
Motherboard: asus z390-a
GPU: rx 590

OpenCore Bootloader

Post by erroruser » 28 Apr 2019, 19:43

cyberdevs, try this edit in the config an remove dsdt
Image
Image
Asus z390-A, i9 9900k, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, sapphire rx 590, fractal celcius s36
:superman :superman
HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB
Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler
free1975yuly
Posts: 21
Joined: 22 Dec 2018, 02:40
CPU: i7 hq6700
Motherboard: Asus ROG 752
GPU: intel hd 530 and nvidia 960

OpenCore Bootloader

Post by free1975yuly » 28 Apr 2019, 20:28

I couldn't install: SandyBridge won't boot, Skylake does not recognize screen resolution at all, and won't inject any kexts. Let's wait until official release.
User avatar
cyberdevs
Developer
Developer
Posts: 50
Joined: 19 Jan 2014, 11:09
CPU: Intel Core i7 6700K
Motherboard: Gigabyte Z170X-Gaming 5
GPU: AMD RX 580

OpenCore Bootloader

Post by cyberdevs » 29 Apr 2019, 04:41

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
28 Apr 2019, 19:43
try this edit in the config an remove dsdt
I tried them already and it still won't boot. When I select the USB all I get is a black screen :(
If you find my posts or apps useful please feel free to [External Link Removed for Guests]
User avatar
erroruser
Olarila Staff
Olarila Staff
Posts: 492
Joined: 24 Apr 2018, 21:12
CPU: i9 9900k
Motherboard: asus z390-a
GPU: rx 590

OpenCore Bootloader

Post by erroruser » 29 Apr 2019, 15:08

cyberdevs, try an change in the bios for Set OS Type to windows an make sure secure Boot Mode is disabled with boot args
-v dart=0 debug=0x100 npci=0x2000
Asus z390-A, i9 9900k, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, sapphire rx 590, fractal celcius s36
:superman :superman
HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB
Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler
User avatar
cyberdevs
Developer
Developer
Posts: 50
Joined: 19 Jan 2014, 11:09
CPU: Intel Core i7 6700K
Motherboard: Gigabyte Z170X-Gaming 5
GPU: AMD RX 580

OpenCore Bootloader

Post by cyberdevs » 29 Apr 2019, 19:31

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
29 Apr 2019, 15:08
try an change in the bios for Set OS Type to windows an make sure secure Boot Mode is disabled with boot args
-v dart=0 debug=0x100 npci=0x2000
Thanks for your help but the issue is the same, no mater what I do I can't boot the system with OpenCore, the system freezes right after I select the USB disk.
If you find my posts or apps useful please feel free to [External Link Removed for Guests]
User avatar
erroruser
Olarila Staff
Olarila Staff
Posts: 492
Joined: 24 Apr 2018, 21:12
CPU: i9 9900k
Motherboard: asus z390-a
GPU: rx 590

OpenCore Bootloader

Post by erroruser » 29 Apr 2019, 19:43

im having an with OpenCore also with nvme m.2 as they are not showing in the boot selection only ssd
Image
Asus z390-A, i9 9900k, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, sapphire rx 590, fractal celcius s36
:superman :superman
HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB
Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler
User avatar
cyberdevs
Developer
Developer
Posts: 50
Joined: 19 Jan 2014, 11:09
CPU: Intel Core i7 6700K
Motherboard: Gigabyte Z170X-Gaming 5
GPU: AMD RX 580

OpenCore Bootloader

Post by cyberdevs » 30 Apr 2019, 13:21

From what I know OpenCore is in its early days of developments and there must be some issues with drivers and hardware recognition.
I even tested the OC on my old SandyBridge and it won't boot either lol
So for now the only system that I successfully booted from is my SkyLake rig.
Let's hope that in the next releases it brings support for more hardware :smoke:
If you find my posts or apps useful please feel free to [External Link Removed for Guests]
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14603
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

OpenCore Bootloader

Post by MaLd0n » 30 Apr 2019, 13:30

in my hacks skylake+ work good, very stable
--Donations via PayPal [External Link Removed for Guests] :guitar

--Donated? Send me one Private Message
User avatar
cyberdevs
Developer
Developer
Posts: 50
Joined: 19 Jan 2014, 11:09
CPU: Intel Core i7 6700K
Motherboard: Gigabyte Z170X-Gaming 5
GPU: AMD RX 580

OpenCore Bootloader

Post by cyberdevs » 30 Apr 2019, 13:42

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
30 Apr 2019, 13:30
in my hacks skylake+ work good, very stable
Yeah I guess the OC is working best with newer hardware.
If you find my posts or apps useful please feel free to [External Link Removed for Guests]
mathewgx
Posts: 66
Joined: 05 Jun 2018, 17:22
CPU: intel
Motherboard: dell
GPU: intel

OpenCore Bootloader

Post by mathewgx » 30 Apr 2019, 13:44

@MaLd0n , here is my current efi folder.

Could you modify it for opencore? I woudd love to try it.

Thanks in advance.
You do not have the required permissions to view the files attached to this post.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14603
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

OpenCore Bootloader

Post by MaLd0n » 30 Apr 2019, 14:08

mathewgx, check first post for one good preset ;)
--Donations via PayPal [External Link Removed for Guests] :guitar

--Donated? Send me one Private Message
User avatar
erroruser
Olarila Staff
Olarila Staff
Posts: 492
Joined: 24 Apr 2018, 21:12
CPU: i9 9900k
Motherboard: asus z390-a
GPU: rx 590

OpenCore Bootloader

Post by erroruser » 30 Apr 2019, 15:48

:crazy: :frantics :frantics :crazy:
still having issues with nvme m.2 evo not showing in the boot selection
Asus z390-A, i9 9900k, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, sapphire rx 590, fractal celcius s36
:superman :superman
HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB
Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler
User avatar
cyberdevs
Developer
Developer
Posts: 50
Joined: 19 Jan 2014, 11:09
CPU: Intel Core i7 6700K
Motherboard: Gigabyte Z170X-Gaming 5
GPU: AMD RX 580

OpenCore Bootloader

Post by cyberdevs » 30 Apr 2019, 17:25

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
30 Apr 2019, 15:48
still having issues with nvme m.2 evo not showing in the boot selection
I noticed that OpenCore Detects my Samsung EVO 960 nvme drive. But since it has my main macOS on it I didn't try to boot into it using OC.
If you find my posts or apps useful please feel free to [External Link Removed for Guests]
User avatar
erroruser
Olarila Staff
Olarila Staff
Posts: 492
Joined: 24 Apr 2018, 21:12
CPU: i9 9900k
Motherboard: asus z390-a
GPU: rx 590

OpenCore Bootloader

Post by erroruser » 30 Apr 2019, 17:31

cyberdevs, ya for some reason not for me an Maldon has the same nvme as i can only see ssd cards no m.2 ugh :frantics
Asus z390-A, i9 9900k, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, sapphire rx 590, fractal celcius s36
:superman :superman
HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB
Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler
User avatar
onemanosx
Olarila Staff
Olarila Staff
Posts: 1355
Joined: 03 Feb 2018, 05:42
CPU: Intel i7-6700HQ HM170 Chipset
Motherboard: Acer Aspire VN7-592G Laptop
GPU: Intel HD 530 + Nvidia GTX 960M

OpenCore Bootloader

Post by onemanosx » 04 May 2019, 04:13

2nd UPDATE: Alas, booted SKL laptop with OpenCore successfully after much tinkering. However, still need to figure out how to load I2C kexts. I'll take a rest now :mrgreen:

1st Post: Urghh, still not able to boot on my SKL laptop!

[External Link Removed for Guests]
[External Link Removed for Guests]

Acer Aspire V15 Nitro- Black Edition VN7-592G/HM170 Chipset
Intel i7-6700HQ, 8GB RAM (UEFI Clover Catalina)

MSI B360 Gaming Arctic
Intel i5-8600 16GB RAM Asus Radeon RX580 8GB (UEFI Clover Catalina)
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14603
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

OpenCore Bootloader

Post by MaLd0n » 04 May 2019, 13:55

-Update EFI in first post
--Donations via PayPal [External Link Removed for Guests] :guitar

--Donated? Send me one Private Message
User avatar
onemanosx
Olarila Staff
Olarila Staff
Posts: 1355
Joined: 03 Feb 2018, 05:42
CPU: Intel i7-6700HQ HM170 Chipset
Motherboard: Acer Aspire VN7-592G Laptop
GPU: Intel HD 530 + Nvidia GTX 960M

OpenCore Bootloader

Post by onemanosx » 04 May 2019, 14:02

MaLd0n, laptop boots good now. All kexts loaded but have not solved i2c device yet. And anyway, whats up with the screenshot? Its not detected as MBP :lol:

[External Link Removed for Guests]
[External Link Removed for Guests]

Acer Aspire V15 Nitro- Black Edition VN7-592G/HM170 Chipset
Intel i7-6700HQ, 8GB RAM (UEFI Clover Catalina)

MSI B360 Gaming Arctic
Intel i5-8600 16GB RAM Asus Radeon RX580 8GB (UEFI Clover Catalina)
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14603
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

OpenCore Bootloader

Post by MaLd0n » 04 May 2019, 14:13

onemanosx, change smbios(PlatformInfo) and add kexts in kernel(kernel/Add)
--Donations via PayPal [External Link Removed for Guests] :guitar

--Donated? Send me one Private Message
User avatar
onemanosx
Olarila Staff
Olarila Staff
Posts: 1355
Joined: 03 Feb 2018, 05:42
CPU: Intel i7-6700HQ HM170 Chipset
Motherboard: Acer Aspire VN7-592G Laptop
GPU: Intel HD 530 + Nvidia GTX 960M

OpenCore Bootloader

Post by onemanosx » 04 May 2019, 14:22

MaLd0n,

I think kexts loads good. But no I2C trackpad.

Code: [Local Link Removed for Guests]

Mac:~ vn7-592g$ kextstat | grep -v com.apple
Index Refs Address            Size       Wired      Name (Version) UUID <Linked Against>
   35    6 0xffffff7f83d91000 0x80000    0x80000    as.vit9696.Lilu (1.3.5) FDDBA1E3-B2DE-37FB-8997-88D28E69E007 <7 5 4 3 2 1>
   36    1 0xffffff7f83e11000 0x28000    0x28000    as.vit9696.VirtualSMC (1.0.2) 8814D940-2C42-3C45-9F42-8338AC4799EB <35 11 7 5 4 3 2 1>
   38    0 0xffffff7f83e39000 0x17000    0x17000    ru.usrsse2.SMCBatteryManager (1) F51BDDBC-E11D-3D46-BB61-6855F0FC7CC0 <37 36 35 11 7 5 4 3 2 1>
   39    0 0xffffff7f83e50000 0x11b000   0x11b000   as.vit9696.AppleALC (1.3.7) 4194C750-6151-377C-9C7C-E38886E3AC64 <35 12 7 5 4 3 2 1>
   40    0 0xffffff7f83f73000 0x7f000    0x7f000    as.vit9696.WhateverGreen (1.2.8) 2EB6FF06-A462-30B9-8121-88D5C9C6468D <35 12 7 5 4 3 2 1>
   41    0 0xffffff7f83ff6000 0xb000     0xb000     org.vanilla.driver.CPUFriend (1.1.6) A32118DA-09BD-37C3-BBF7-4DF6832CFC54 <35 11 7 5 4 3 2 1>
   42    0 0xffffff7f84073000 0x11000    0x11000    as.lvs1974.AirportBrcmFixup (2.0.0) B78B9C18-88E8-35E3-B489-C448FF764EE6 <35 15 12 7 5 4 3 2 1>
   43    0 0xffffff7f84318000 0x10000    0x10000    com.alexandred.VoodooI2CServices (1) 8D02CFDB-E378-3061-8591-7E199076722D <4 3>
   44    0 0xffffff7f84355000 0xf000     0xf000     com.XPS.VerbStub (1.0.3) 41D18E8C-8EFF-34A1-BD9C-2D806283284F <12 4 3>
   60    0 0xffffff7f842f4000 0x19000    0x19000    org.coolstar.VoodooGPIO (1.1) 584C5F47-466F-3585-9AFB-605777C0A2FE <11 5 4 3>
   61    1 0xffffff7f84328000 0xe000     0xe000     org.rehabman.voodoo.driver.PS2Controller (1.8.34) FE68E3D5-29E0-346A-9036-090411302A58 <11 7 5 4 3 1>
   80    0 0xffffff7f84001000 0x72000    0x72000    com.insanelymac.RealtekRTL8111 (2.2.2) 24D129C7-C25C-3D7B-9E10-EA71D9BE6511 <15 12 5 4 3 1>
   83    0 0xffffff7f84348000 0xd000     0xd000     org.rehabman.driver.FakePCIID (1.3.15) B185B092-1FC9-308E-B093-32FD88E5822D <12 7 5 4 3 1>
   87    0 0xffffff7f8433b000 0xd000     0xd000     org.rehabman.voodoo.driver.PS2Keyboard (1.8.34) 454845C4-36AE-37F0-995E-961CAAF609FB <61 58 17 7 6 5 4 3 1>
   99    1 0xffffff7f84084000 0x25f000   0x25f000   com.no-one.BrcmFirmwareStore (2.2.10) FEAD3CAB-F1B9-329A-8291-EAC222EBC0F0 <5 4 3>
  100    0 0xffffff7f842e3000 0x11000    0x11000    com.no-one.BrcmPatchRAM2 (2.2.10) EA8FADAF-E7F3-3CDF-8440-49C15C0E25F8 <99 24 5 4 3 1>

[External Link Removed for Guests]
[External Link Removed for Guests]

Acer Aspire V15 Nitro- Black Edition VN7-592G/HM170 Chipset
Intel i7-6700HQ, 8GB RAM (UEFI Clover Catalina)

MSI B360 Gaming Arctic
Intel i5-8600 16GB RAM Asus Radeon RX580 8GB (UEFI Clover Catalina)
User avatar
onemanosx
Olarila Staff
Olarila Staff
Posts: 1355
Joined: 03 Feb 2018, 05:42
CPU: Intel i7-6700HQ HM170 Chipset
Motherboard: Acer Aspire VN7-592G Laptop
GPU: Intel HD 530 + Nvidia GTX 960M

OpenCore Bootloader

Post by onemanosx » 05 May 2019, 00:32

I2C trackpad is now working simply by moving VoodooGPIO and VoodooI2CServices above in config.plist so they load firstly, then add VoodooI2C and lastly VoodooI2CHID. :work:
[External Link Removed for Guests]
[External Link Removed for Guests]

Acer Aspire V15 Nitro- Black Edition VN7-592G/HM170 Chipset
Intel i7-6700HQ, 8GB RAM (UEFI Clover Catalina)

MSI B360 Gaming Arctic
Intel i5-8600 16GB RAM Asus Radeon RX580 8GB (UEFI Clover Catalina)
Post Reply

Return to “New Releases and Updates”