-->Donations via PayPal [External Link Removed for Guests] :guitar
-->Installation/Post Installation Tutorial [Local Link Removed for Guests]
-->Useful Links [Local Link Removed for Guests]
-->Olarila Images - Updated images [Local Link Removed for Guests]
-->Guides and Tutorials [Local Link Removed for Guests]
-->Clover Folder for All Chipsets [Local Link Removed for Guests]
-->DSDT Patch Requests [Local Link Removed for Guests]

[Guide] Hackintool - Video Patch - Fast and Easy Solution

User avatar
kultrun
Donator
Donator
Posts: 41
Joined: 04 Jun 2018, 15:50
CPU: Intel i5 8400 4.0
Motherboard: Gigabyte GA-Z370 HD3
GPU: Intel Graphics UHD 630

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by kultrun » 19 Mar 2019, 15:52

Hi, just a more question ... when you said "remove SSDT about video, DSDT patch about video"... it means also that I must delete any clover entrys about "GFX0 to IGPU"?
also "HDAS to HDEF"? and anything else? I attach my config.plist before apply the hackintool patch for video platformid etc
thanks!
You do not have the required permissions to view the files attached to this post.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13612
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by MaLd0n » 19 Mar 2019, 16:34

kultrun, no, don't remove renames, only InjectIntel or other patch if u use
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
User avatar
kultrun
Donator
Donator
Posts: 41
Joined: 04 Jun 2018, 15:50
CPU: Intel i5 8400 4.0
Motherboard: Gigabyte GA-Z370 HD3
GPU: Intel Graphics UHD 630

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by kultrun » 19 Mar 2019, 17:18

Ah, ok... thanks MaLd0n!

I believe there are not any other patch in my hack... just the dsdt.aml provide by you (after sending you the resulting file of Runme). There is information about Intel Graphics UHD 630 in that dsdt.aml, in PCI section... but I think that's not a problem, right?

considering my mobo GA Z370 HD3 and the CoffeeLake 8400 i5 processor (with Graphics UHD 630), it is recommendable to use the definition of SMBIOS as MacMini 8.1? (Actually, I use the Imac 18,1 SMBIOS)

many thanks!
[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
19 Mar 2019, 16:34
kultrun, no, don't remove renames, only InjectIntel or other patch if u use
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13612
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by MaLd0n » 19 Mar 2019, 17:22

kultrun, both work good

Added in 38 seconds:
[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
19 Mar 2019, 17:18
There is information about Intel Graphics UHD 630 in that dsdt.aml, in PCI section... but I think that's not a problem, right?
no problem
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
User avatar
erroruser
Olarila Staff
Olarila Staff
Posts: 486
Joined: 24 Apr 2018, 21:12
CPU: i9 9900k
Motherboard: asus z390-a
GPU: rx 590

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by erroruser » 19 Mar 2019, 17:25

kultrun, for cofeelake either imac pro 1,1 or imac 18,3
Asus z390-A, i9 9900k, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, sapphire rx 590, fractal celcius s36
:superman :superman
HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB
Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler
User avatar
kultrun
Donator
Donator
Posts: 41
Joined: 04 Jun 2018, 15:50
CPU: Intel i5 8400 4.0
Motherboard: Gigabyte GA-Z370 HD3
GPU: Intel Graphics UHD 630

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by kultrun » 19 Mar 2019, 18:51

Thanks a lot, MalD0n and erroruser!

I will try tonight with these tips, so... considering that I only have the iGPU video (UHD 630), without a dedicated graphic card, I can try with the current smbios(18,1) or with macmini 8,1 or what erroruser recommends: imac pro 1,1 or imac 18,3

thanks!
User avatar
kultrun
Donator
Donator
Posts: 41
Joined: 04 Jun 2018, 15:50
CPU: Intel i5 8400 4.0
Motherboard: Gigabyte GA-Z370 HD3
GPU: Intel Graphics UHD 630

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by kultrun » 20 Mar 2019, 14:25

Hi friends! So, I believe everything is ok after apply the patch/changes!
What I did:
- follow this guide
- Set Platform ID to 0x3E9B0007
- on the first try, change smbios to MacMini 8.1 and in connectors I changed the active connector (in red) by type hdmi, which is the correct one of the mother. Result: the hack boots but the screen looks all in shades of pink.
- So I changed three things: the smbios to imac 18,3 and changed this parameters in hackintool patch:

ID: 3E9B0007, STOLEN: 57 MB, FBMEM: 0 bytes, VRAM: 1536 MB, Flags: 0x00801302
TOTAL STOLEN: 58 MB, TOTAL CURSOR: 1 MB (1572864 bytes), MAX STOLEN: 172 MB, MAX OVERALL: 173 MB (181940224 bytes)
GPU Name: Intel UHD Graphics 630

Model Name(s):
Camelia: Disabled
Mobile: 0, PipeCount: 3, PortCount: 3, FBMemoryCount: 3
[1] busId: 0x05, pipe: 9, type: 0x00000400, flags: 0x000003C7 - DP
[2] busId: 0x04, pipe: 10, type: 0x00000400, flags: 0x000003C7 - DP
[3] busId: 0x06, pipe: 8, type: 0x00000400, flags: 0x000003C7 - DP

01050900 00040000 C7030000
02040A00 00040000 C7030000
03060800 00040000 C7030000


- As you can see, I went back to all the connectors as DP
- But in the hackintool patch, I turned on the option DP → HDMI (patch /advanced)
- Result: no more pink screen but video glitches issues
- So, I changed the smbios definition again to MacMini 8,1
- Result: everything seems to be ok now!!
- Now, all connectors appears as HDMI :whistle

But, as I only have a monitor, with an HDMI port ... and my mobo has only two outputs: hdmi and dvi ... well, II do not worry too much (or should it be something to worry about it being that way?)

Image

I send you some screenshots to confirm that everything seems fine (for now, ja!)

Image

Image

Image


The only thing that seems strange to me is that (supposedly) the values ​​of "stolen, fbmem" etc ss you can see in the previous parameters, but they do not seem to reflect or are different (as can be seen in hackintool screenshot)

Image

for now, I tried the screen off and the sleep mode, and apparently it goes back well without black screen

Well, if everything seems perfect, I continue with this configuration ... but in any case I am attentive to advice and suggestions!

Many thanks for all that help, friends!

Image

Image
Last edited by kultrun on 21 Mar 2019, 16:16, edited 1 time in total.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13612
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by MaLd0n » 20 Mar 2019, 14:54

kultrun, to avoid glitches, use iMac18,1 smbios
good job
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
User avatar
kultrun
Donator
Donator
Posts: 41
Joined: 04 Jun 2018, 15:50
CPU: Intel i5 8400 4.0
Motherboard: Gigabyte GA-Z370 HD3
GPU: Intel Graphics UHD 630

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by kultrun » 20 Mar 2019, 15:31

Thanks, MaLd0n!

I use actually the MacMini 8,1 definition and there are not glitches... but if you recommed iMac 18,1, maybe I'll try

the only thing is what I said... I change the parameters in hackintool to:

STOLEN: 57 MB, FBMEM: 0 bytes, VRAM: 1536 MB, Flags: 0x00801302
TOTAL STOLEN: 58 MB, TOTAL CURSOR: 1 MB (1572864 bytes), MAX STOLEN: 172 MB, MAX OVERALL: 173 MB (181940224 bytes)

in VRAM section... but now, when I reboot (everything is ok) in hackintool shows: STOLEN 19 Mb / FBMem 9 Mb / VRAM 2048 Mb / Max Stolen 67 Mb / Total Stolen 20 Mb / Total Cursor 1 Mb / Max Overall 68 Mb

It seems like that wehn I open hackintool and select "framebuffer -- MacOs 10.14"

EDIT: In my Mobo I can set DVMT in 128 MB... So do I need to use the "DVMT pre-alloc 32 MB" option in hackintool? this option has something to do with the vram variables?
I don't have 4K monitor or screen... do I need to use the option "VRAM 2048 MB" ??



many thanks!


[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
20 Mar 2019, 14:54
kultrun, to avoid glitches, use iMac18,1 smbios
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13612
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by MaLd0n » 20 Mar 2019, 15:56

kultrun, dvmt, use it in mobiles with bios/uefi without some options, in desktop just up in bios/uefi

VRAM 2048 MB, i think is only cosmetic, i don't see any diff
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
User avatar
kultrun
Donator
Donator
Posts: 41
Joined: 04 Jun 2018, 15:50
CPU: Intel i5 8400 4.0
Motherboard: Gigabyte GA-Z370 HD3
GPU: Intel Graphics UHD 630

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by kultrun » 20 Mar 2019, 16:04

thanks MaLdon! I will do those changes for a final config.plist...

I'll tell you if everything is ok! :guitar :guitar
[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
20 Mar 2019, 15:56
ultrun, dvmt, use it in mobiles with bios/uefi without some options, in desktop just up in bios/uefi

VRAM 2048 MB, i think is only cosmetic, i don't see any diff
User avatar
kultrun
Donator
Donator
Posts: 41
Joined: 04 Jun 2018, 15:50
CPU: Intel i5 8400 4.0
Motherboard: Gigabyte GA-Z370 HD3
GPU: Intel Graphics UHD 630

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by kultrun » 20 Mar 2019, 17:04

Hi, all is ok and fine in my hack!!

I attach the config.plist if anybody needs it... My mobo GA Z370 HD3 (two connectors: HDMI and DVI) and CoffeLake i5 8400 - Intel UHD 630

Just the last question: can I update Lilu kext and there are no issues with that? I suppose is better have the lastet lilu.ket... bu just in case, I ask :)

thanks a lot for all the help and dedication!
saludos desde Argentina
You do not have the required permissions to view the files attached to this post.
User avatar
erroruser
Olarila Staff
Olarila Staff
Posts: 486
Joined: 24 Apr 2018, 21:12
CPU: i9 9900k
Motherboard: asus z390-a
GPU: rx 590

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by erroruser » 20 Mar 2019, 17:27

kultrun, yes you can update all kexts if they need to be
Asus z390-A, i9 9900k, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, sapphire rx 590, fractal celcius s36
:superman :superman
HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB
Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler
User avatar
kultrun
Donator
Donator
Posts: 41
Joined: 04 Jun 2018, 15:50
CPU: Intel i5 8400 4.0
Motherboard: Gigabyte GA-Z370 HD3
GPU: Intel Graphics UHD 630

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by kultrun » 20 Mar 2019, 19:26

Many thanks erroruser!

I don't know if it's necessary update some kets like Lilu, when everything seems to work great, but... many times users recommend that

something to advise: I do not know if it is related to having generated the patch for the video or with the current (newer) version of hackintool, but I had to generate the USB patch again because all the ports appeared as "internal"

saludos!
[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
20 Mar 2019, 17:27
kultrun, yes you can update all kexts if they need to be
adivajra
Geek
Geek
Posts: 105
Joined: 11 Feb 2012, 01:55
CPU: i5 9600K
Motherboard: ASUS TUF Z390M Gaming
GPU: UHD 630

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by adivajra » 22 Mar 2019, 12:36

I just update to 10.14.3, but before that I have changed the config on my PC I put another SSD 1Tb and installed win10 on it and I put my graphic card on that pc (msi rtx 2080).

Since I plug the card I have some issue with graphic on the Hackintosh part of the pc, the igpu uhd 630 is no more recognized like it was before I installed the DSDT from Mald0n

here's a screenshot [External Link Removed for Guests]
thanks for your help

also after the update I need to use a USB to boot into the hack now I have re-do the disablehibernate and master-command, and I just update clover too, I hope I will be able to boot normally now
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13612
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by MaLd0n » 23 Mar 2019, 14:15

adivajra, POST ONE FULL DUMP
--Run_Me
[Local Link Removed for Guests]


we need disable nvidia in macos
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
User avatar
gilgamet
Posts: 28
Joined: 15 Feb 2019, 18:35
CPU: i5-7200u
Motherboard: LNVNB161216
GPU: 110Mx

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by gilgamet » 23 Mar 2019, 18:14

1 things to say :frantics :frantics :superman

Grrrrrr after many test hdmi makes the laptop in freeeeeeeeze mode ,,,,, :evil: :twisted:
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13612
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by MaLd0n » 23 Mar 2019, 18:54

gilgamet, :lol: :mrgreen:
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
adivajra
Geek
Geek
Posts: 105
Joined: 11 Feb 2012, 01:55
CPU: i5 9600K
Motherboard: ASUS TUF Z390M Gaming
GPU: UHD 630

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by adivajra » 24 Mar 2019, 09:18

ok thank you Mald0n

here's the runme file : [External Link Removed for Guests]
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13612
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Hackintool - Video Patch - Fast and Easy Solution

Post by MaLd0n » 24 Mar 2019, 13:14

adivajra,
DSDT.aml.zip
You do not have the required permissions to view the files attached to this post.
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
Post Reply

Return to “Patches and tricks”