-->Donations via PayPal [External Link Removed for Guests] :guitar
-->Installation/Post Installation Tutorial [Local Link Removed for Guests]
-->Useful Links [Local Link Removed for Guests]
-->Olarila Images - Updated images [Local Link Removed for Guests]
-->Guides and Tutorials [Local Link Removed for Guests]
-->Clover Folder for All Chipsets [Local Link Removed for Guests]
-->DSDT Patch Requests [Local Link Removed for Guests]

Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13526
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by MaLd0n » 01 Mar 2019, 21:58

diamonddust, use bios/uefi in default, just enable intelhdgraphics

the correct config intelhd don't appears here
Image

u see in ioreg just for hardware accel
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
User avatar
diamonddust
Posts: 19
Joined: 18 Feb 2019, 18:59
CPU: i5 8500
Motherboard: GA Z370n WIFI
GPU: Sapphire rx 570 itx

Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by diamonddust » 01 Mar 2019, 22:12

MaLd0n ok went back to
IntelGFX 0x59128086
ig-platform-id 0x59120003
and Graphics/Display it's correct

Bios/UEFI is default and CSM disable and intelhdgraphics enable
You do not have the required permissions to view the files attached to this post.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13526
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by MaLd0n » 01 Mar 2019, 22:28

diamonddust, ;)
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
User avatar
diamonddust
Posts: 19
Joined: 18 Feb 2019, 18:59
CPU: i5 8500
Motherboard: GA Z370n WIFI
GPU: Sapphire rx 570 itx

Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by diamonddust » 01 Mar 2019, 22:56

MaLd0n one last question I forgot and than I will not bug you
For Hackintool USB patching it's suggest to edit config.plist and add the EHCI1, EHC2, XHCI and XHC1 like this:
config patch.png
should I remove them now that USB it's been fixed?

can I private sent you the boot verbose?

if it's ok with you and time it's ok will post a [Guide] for the GA Z370N Wifi
You do not have the required permissions to view the files attached to this post.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13526
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by MaLd0n » 01 Mar 2019, 23:04

diamonddust,

Code: [Local Link Removed for Guests]

change GFX0 to IGPU
47465830 
49475055 

change HDAS to HDEF
48444153 
48444546 

change HECI to IMEI
48454349 
494d4549 

change SAT0 to SATA
53415430 
53415441 

change GLAN to GIGE
474c414e
47494745
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
User avatar
diamonddust
Posts: 19
Joined: 18 Feb 2019, 18:59
CPU: i5 8500
Motherboard: GA Z370n WIFI
GPU: Sapphire rx 570 itx

Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by diamonddust » 01 Mar 2019, 23:42

got it ;-) cheers !
User avatar
jcrcarmo
Posts: 26
Joined: 01 Dec 2012, 05:29
CPU: Intel Core i5 6200U @ 2,40GHZ
Motherboard: Lenovo Ideapad 300 15isk
GPU: Intel HD 520

Re: Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by jcrcarmo » 07 Mar 2019, 01:33

Hello guys,

Greetings from Brazil! Where is the download link for the DSDT file? I've looked all over and I can't find it... Thanks for your help.

Jay Cee.
User avatar
erroruser
Olarila Staff
Olarila Staff
Posts: 486
Joined: 24 Apr 2018, 21:12
CPU: i9 9900k
Motherboard: asus z390-a
GPU: rx 590

Re: Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by erroruser » 07 Mar 2019, 01:43

you have to use the runme app an upload the zip file to this forum
[Local Link Removed for Guests]
Asus z390-A, i9 9900k, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, sapphire rx 590, fractal celcius s36
:superman :superman
HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB
Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler
EDV11
Posts: 14
Joined: 18 Mar 2019, 13:20
CPU: i5 8400
Motherboard: Z370N-WiFi
GPU: Intel 630

Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by EDV11 » 18 Mar 2019, 17:39

Hello

I tried using your DSDT or EFI folder but it did not work for me. It hangs with this message

Image

Image

I have configured the BIOS with the recommended options.

My setup is:
Z370 HD3 BIOS F10
i5 8400
Sapphire R580 Nitro 8GB
16GB DDR4

If I use a generic EFI I can boot and everything works fine, but the USB are not working. Devices are only detected if they are connected at boot, but if I plug them off/on nothing happens.

I use Mojave 10.14.3. Has something changed lately with the DSDT?
You do not have the required permissions to view the files attached to this post.
Last edited by EDV11 on 18 Mar 2019, 17:59, edited 1 time in total.
User avatar
erroruser
Olarila Staff
Olarila Staff
Posts: 486
Joined: 24 Apr 2018, 21:12
CPU: i9 9900k
Motherboard: asus z390-a
GPU: rx 590

Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by erroruser » 18 Mar 2019, 17:54

EDV11, you dont use other users dsdt you can block it in clover to boot back hit "O" then go to ACPI patching dsdt name change to BIOS.aml an you should be able to boot back on an you should use clover folders from here [Local Link Removed for Guests]
for changing the dsdt to bios here is also a guide [Local Link Removed for Guests]

Added in 3 minutes 26 seconds:
to run me app watch here
Asus z390-A, i9 9900k, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, sapphire rx 590, fractal celcius s36
:superman :superman
HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB
Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler
EDV11
Posts: 14
Joined: 18 Mar 2019, 13:20
CPU: i5 8400
Motherboard: Z370N-WiFi
GPU: Intel 630

Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by EDV11 » 18 Mar 2019, 18:01

Thanks. I went back to the EFI folder that allows me to boot up. I have added the Send Me file in the previous post
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13526
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by MaLd0n » 18 Mar 2019, 18:14

EDV11,
DSDT.aml.zip
You do not have the required permissions to view the files attached to this post.
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
EDV11
Posts: 14
Joined: 18 Mar 2019, 13:20
CPU: i5 8400
Motherboard: Z370N-WiFi
GPU: Intel 630

Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by EDV11 » 19 Mar 2019, 14:58

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
18 Mar 2019, 18:14
EDV11, DSDT.aml.zip
Thanks!

I've been testing it for some hours but I found that I have trouble with wake after sleep. The fans start spinning but there is no image. It responds to ping from a different computer, but I can't log through screen sharing and I have to force power off and restart.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13526
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by MaLd0n » 19 Mar 2019, 15:00

EDV11, strange
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
EDV11
Posts: 14
Joined: 18 Mar 2019, 13:20
CPU: i5 8400
Motherboard: Z370N-WiFi
GPU: Intel 630

Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by EDV11 » 19 Mar 2019, 15:04

I do have the Lilu.kext and WhateverGreen.kext in Other folder, boot argument with shikigva=40 and nothing in Graphics
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13526
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by MaLd0n » 19 Mar 2019, 15:05

EDV11, shikigva=60 with IntelHD enable in bios/uefi
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
EDV11
Posts: 14
Joined: 18 Mar 2019, 13:20
CPU: i5 8400
Motherboard: Z370N-WiFi
GPU: Intel 630

Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by EDV11 » 19 Mar 2019, 15:10

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
19 Mar 2019, 15:05
EDV11, shikigva=60 with IntelHD enable in bios/uefi
Thanks, I'm going to try it.

Also, when I uploaded the SendMe files I was using a PCI WiFi/Bluetooth that I have removed (now the computer is connected using LAN). But I see the WiFi icon showing there is no hardware installed. Could this be related?

Added in 9 minutes 54 seconds:
same issue with shikigva=60
EDV11
Posts: 14
Joined: 18 Mar 2019, 13:20
CPU: i5 8400
Motherboard: Z370N-WiFi
GPU: Intel 630

Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by EDV11 » 19 Mar 2019, 19:26

Also, I forgot to send you a beer! Sent now
EDV11
Posts: 14
Joined: 18 Mar 2019, 13:20
CPU: i5 8400
Motherboard: Z370N-WiFi
GPU: Intel 630

Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by EDV11 » 20 Mar 2019, 16:03

I've tested without DSDT and it's also the same, it won't come back after sleep. Also, it takes a really long time for boot.

I'm attaching my Clover folder
You do not have the required permissions to view the files attached to this post.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13526
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Mojave on GA-Z370 HD3 + i7-8700K / FULL DSDT Patch

Post by MaLd0n » 20 Mar 2019, 16:27

EDV11, post send me
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
Post Reply

Return to “Mojave (10.14)”