-->Donations via PayPal [External Link Removed for Guests] :guitar
-->Installation/Post Installation Tutorial [Local Link Removed for Guests]
-->Useful Links [Local Link Removed for Guests]
-->Olarila Images - Updated images [Local Link Removed for Guests]
-->Guides and Tutorials [Local Link Removed for Guests]
-->Clover Folder for All Chipsets [Local Link Removed for Guests]
-->DSDT Patch Requests [Local Link Removed for Guests]

Problemas com Kext de áudio

Post Reply
speedveloxlan
Posts: 8
Joined: 22 Apr 2019, 00:51
CPU: Core i5 4590 3.3Ghz
Motherboard: Dell Optiplex 3020
GPU: Nvidia Geforce 210

Problemas com Kext de áudio

Post by speedveloxlan » 11 Sep 2019, 19:05

Olá a todos do Fórum.
Instalei com sucesso o Mojave 10.14.5

Para efeito de informação, minha configuração segue de um Dell Optiplex 3020, o mesmo com i5 4590, 8GB DDR3, GT 710.
A princípio minha instalação está fluída, rede funcionando, driver de vídeo também.
Meu problema parte do áudio. Que pelo fabricante eu já procurei saber e é Realtek ALC3220. Tentei instalar o Apple ALC através do multishit e não obtive sucesso. Depois de instalar uns "trocentos" kexts diferentes, de raiva resolvi formatar novamente e instalar o Mojave novamente, e recorrer a uma solução.

Eu sei instalar kexts, possuo o mínimo de conhecimento de como fazer isso, e já fiz pegar outro PC meu com o Sierra.
Li também em outros tópicos na internet, que esse chip da Realtek também pode se chamar de outro nome, (alc280). Tentei instalar e também não obtive sucesso.

Alguém poderia me ajudar? Eu preciso muito do áudio pois utilizarei este hackintosh para trabalho. E creio que há possibilidade de ser compatível o áudio no mac. Só não sei como resolver.

Agradeço desde já à todos.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14545
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Problemas com Kext de áudio

Post by MaLd0n » 11 Sep 2019, 20:06

speedveloxlan, [Local Link Removed for Guests]
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
speedveloxlan
Posts: 8
Joined: 22 Apr 2019, 00:51
CPU: Core i5 4590 3.3Ghz
Motherboard: Dell Optiplex 3020
GPU: Nvidia Geforce 210

Problemas com Kext de áudio

Post by speedveloxlan » 11 Sep 2019, 20:51

Hi, I checked this post
But following the tutorial, I was unsuccessful.
Here's my screenshot of DCPIManager:
[External Link Removed for Guests]
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14545
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Problemas com Kext de áudio

Post by MaLd0n » 12 Sep 2019, 03:21

speedveloxlan, Image
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
speedveloxlan
Posts: 8
Joined: 22 Apr 2019, 00:51
CPU: Core i5 4590 3.3Ghz
Motherboard: Dell Optiplex 3020
GPU: Nvidia Geforce 210

Problemas com Kext de áudio

Post by speedveloxlan » 12 Sep 2019, 15:19

Estou seguindo o seu tutorial, desculpe minha ignorância, mas não sei como abrir o Clover Configurator. Poderia me dizer como?
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14545
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Problemas com Kext de áudio

Post by MaLd0n » 12 Sep 2019, 16:10

speedveloxlan, é um app, apenas abra o app dando dois cliques
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
speedveloxlan
Posts: 8
Joined: 22 Apr 2019, 00:51
CPU: Core i5 4590 3.3Ghz
Motherboard: Dell Optiplex 3020
GPU: Nvidia Geforce 210

Problemas com Kext de áudio

Post by speedveloxlan » 12 Sep 2019, 21:26

Amigo, eu injetei todas as possibilidades para o meu chip e nada.
Fui injetando os layouts até a última opção para o ALC 280. Não obtive sucesso.
O que devo fazer? Existe outra possibilidade?
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14545
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Problemas com Kext de áudio

Post by MaLd0n » 13 Sep 2019, 00:05

speedveloxlan, vc injetou e reiniciou?

se não funcionou use o applehdapatcher
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
speedveloxlan
Posts: 8
Joined: 22 Apr 2019, 00:51
CPU: Core i5 4590 3.3Ghz
Motherboard: Dell Optiplex 3020
GPU: Nvidia Geforce 210

Problemas com Kext de áudio

Post by speedveloxlan » 13 Sep 2019, 12:52

Sim, cada vez que injetei os layouts disponíveis para o ALC 280 eu reiniciava, ia nas configurações, verificava se reconhecia dispositivo de entrada e saída de áudio. Especificamente no layout 3 ficou até com dispositivo de saída de áudio, porém não funcionou. Testei na entrada P2 da própria placa, e nas entradas p2 frontal do gabinete.

Usei o applehdapatcher e nada.

Será que um downgrade para o high sierra resolveria?
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14545
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Problemas com Kext de áudio

Post by MaLd0n » 13 Sep 2019, 14:16

speedveloxlan, creio que não, o problema deve ser o codec msm, talvez tenha que editar, vc pode usar o applehdapatcher
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
speedveloxlan
Posts: 8
Joined: 22 Apr 2019, 00:51
CPU: Core i5 4590 3.3Ghz
Motherboard: Dell Optiplex 3020
GPU: Nvidia Geforce 210

Problemas com Kext de áudio

Post by speedveloxlan » 16 Sep 2019, 19:53

Não consegui de forma alguma. Ainda sigo persistindo para ver se de algum jeito resolvo.
Uma dúvida. Depois que fiz todos esses procedimentos precisaria reverter todos eles para fazer algum novo ou não afeta?
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14545
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Problemas com Kext de áudio

Post by MaLd0n » 16 Sep 2019, 20:57

speedveloxlan, se vc só alterou o layout id pelo clover não tem problema, se vc patcheou a applehda precisa de uma original
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
User avatar
Maf3r0
Posts: 89
Joined: 17 Sep 2011, 20:35
CPU: i3 8100
Motherboard: H310M-S2P (F13)
GPU: Sapphire RX 560+UHD630

Problemas com Kext de áudio

Post by Maf3r0 » 17 Sep 2019, 09:53

Só para revisar:

AppleAlc.kext + Lilu.kext em EFI/CLOVER/kexts/other.

Em EFI/CLOVER/config.plist/Devices:

Code: [Local Link Removed for Guests]

		<key>Audio</key>
		<dict>
			<key>Inject</key>
			<string>3</string>
		</dict>
Opções disponíveis: 3, 4, 11, 13, 15, 16 e 21.

Escolha apenas um layout por vez e teste.
iMac18,1 (10.14.6) + Win 10 @ Clover UEFI
DSDT: não | SSDT: não | Áudio ALC887 (AppleALC+Lilu) | TP-Link WN781ND | Realtek RTL8118 | 8GB DDR4
speedveloxlan
Posts: 8
Joined: 22 Apr 2019, 00:51
CPU: Core i5 4590 3.3Ghz
Motherboard: Dell Optiplex 3020
GPU: Nvidia Geforce 210

Problemas com Kext de áudio

Post by speedveloxlan » 17 Sep 2019, 22:05

Caros MaLd0n e Maf3r0,
Eu estou muito agradecido pelo auxilio de vocês, mas sinceramente não sei o que fazer mais para fazer esse som funcionar.
Eu verifiquei tbm se na bios está habilitado o áudio, e no Windows o som funciona.

Vou mandar a minha config.plist pra algum de vocês darem uma olhada, o que eu poderia fazer? Sinceramente não sei mais o que faço. Mas ficaria imensamente agradecido se de alguma forma vocês me dessem alguma luz para eu continuar tentando resolver isso.

[External Link Removed for Guests]
User avatar
Maf3r0
Posts: 89
Joined: 17 Sep 2011, 20:35
CPU: i3 8100
Motherboard: H310M-S2P (F13)
GPU: Sapphire RX 560+UHD630

Problemas com Kext de áudio

Post by Maf3r0 » 18 Sep 2019, 00:11

Qual a finalidade da entrada AppleHDA Patch Assertions em KernelAndKextPatches/KextsToPatch?

Faz um teste com ela desativada.

A princípio, o seu codec parece ter suporte. Mas se não funcionar automaticamente, acho que só editando a kext.

Ah, depois tenta limpar um pouco seu config.plist. Eu não seu nenhum expert, mas acho que tem muita coisa desnecessária nele.
iMac18,1 (10.14.6) + Win 10 @ Clover UEFI
DSDT: não | SSDT: não | Áudio ALC887 (AppleALC+Lilu) | TP-Link WN781ND | Realtek RTL8118 | 8GB DDR4
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14545
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Problemas com Kext de áudio

Post by MaLd0n » 18 Sep 2019, 00:53

speedveloxlan, faz uma nova instalação e tenta novamente, isso não tem mistério com a applealc, tem de funcionar, pode ser que vc tenha modificado algo. com a pasta clover Olarila vc não precisa instalar clover nem nada, apenas use GUID com HFS ou APFS e depois da instalação monte a EFI e cole a pasta lá, roda o run_me pra edição do DSDT que é essencial pra todo hackintosh

Added in 1 minute 27 seconds:
Maf3r0, AppleHDA Patch Assertions apenas desativa log error da applehda, veja pelo binário, não interfere em nada, em relação ao config.plist não tem nenhum extra, está correto, boa parte está disable
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
User avatar
Maf3r0
Posts: 89
Joined: 17 Sep 2011, 20:35
CPU: i3 8100
Motherboard: H310M-S2P (F13)
GPU: Sapphire RX 560+UHD630

Problemas com Kext de áudio

Post by Maf3r0 » 18 Sep 2019, 08:50

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
18 Sep 2019, 00:54
em relação ao config.plist não tem nenhum extra, está correto, boa parte está disable
Show!
iMac18,1 (10.14.6) + Win 10 @ Clover UEFI
DSDT: não | SSDT: não | Áudio ALC887 (AppleALC+Lilu) | TP-Link WN781ND | Realtek RTL8118 | 8GB DDR4
speedveloxlan
Posts: 8
Joined: 22 Apr 2019, 00:51
CPU: Core i5 4590 3.3Ghz
Motherboard: Dell Optiplex 3020
GPU: Nvidia Geforce 210

Problemas com Kext de áudio

Post by speedveloxlan » 18 Sep 2019, 19:09

Para fazer a instalação eu segui o posto do próprio MaLd0n. [Local Link Removed for Guests]
-Fiz o usb bootável utilizando um PC com Sierra que possuo.
-Segui tudo a risca no artigo que você fez.
E utilizei a clover folder 5,6,7,8,9 (pois o meu chipset é um H81)
Usei o clover efi para fazer tudo de acordo com que está no post.
A única coisa que não fiz, foi a partição que coloquei em mac os extended journaled
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14545
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Problemas com Kext de áudio

Post by MaLd0n » 18 Sep 2019, 19:12

speedveloxlan, agora extraia o send_me
--Run_Me
[Local Link Removed for Guests]
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
Post Reply

Return to “Mojave (10.14)”