-->Donations via PayPal [External Link Removed for Guests] :guitar
-->Installation/Post Installation Tutorial [Local Link Removed for Guests]
-->Useful Links [Local Link Removed for Guests]
-->Olarila Images - Updated images [Local Link Removed for Guests]
-->Guides and Tutorials [Local Link Removed for Guests]
-->Clover Folder for All Chipsets [Local Link Removed for Guests]
-->DSDT Patch Requests [Local Link Removed for Guests]

Thinkpad t450s Mojave Boot Stuck at "End RandomSeed"

Post Reply
dipper
Posts: 2
Joined: 01 Sep 2019, 02:55
CPU: i5-5300U @ 2.3 GHz
Motherboard: Thinkpad t450s
GPU: HD 5500

Thinkpad t450s Mojave Boot Stuck at "End RandomSeed"

Post by dipper » 01 Sep 2019, 22:41

I've been trying to get Olarila Mojave 10.14.5 to boot on a Thinkpad t450s, but it keeps getting stuck at "End RandomSeed". There is no line of pluses (+) afterwards.

I've tried swapping AptioMemoryFix for OsxAptioFixDrv 1-3, but this just resulted in memory allocation errors. Changing the usual BIOS options and swapping USB ports didn't work either, just gets stuck at End RandomSeed still.

I suspect the issue may be with the way the t450s handles it's soldered+socketed RAM DIMMS, or maybe it's a DSDT or SMBIOS issue. Regardless, I am out of ideas. Anyone have any suggestions?
(-hbar^2/2m)(d^2sai/dx^2)+(U-E)sai=0 =>(d^2sai/dx^2)-(2m/hbar^2)(V-E)sai =0
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14531
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Thinkpad t450s Mojave Boot Stuck at "End RandomSeed"

Post by MaLd0n » 02 Sep 2019, 03:57

dipper, if u change uefii driver, use slide=0
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
dipper
Posts: 2
Joined: 01 Sep 2019, 02:55
CPU: i5-5300U @ 2.3 GHz
Motherboard: Thinkpad t450s
GPU: HD 5500

Thinkpad t450s Mojave Boot Stuck at "End RandomSeed"

Post by dipper » 02 Sep 2019, 14:53

Using slide=0 causes boot to fail even earlier. With it I always get some variation of the following error:

Code: [Local Link Removed for Guests]

Error allocating 0x260c pages at 0x00000000067000 alloc type 2
Error loading kernel cache (0x9)
Boot hangs after this error. I'll retry each combination of AptioFix one more time just to be sure.
(-hbar^2/2m)(d^2sai/dx^2)+(U-E)sai=0 =>(d^2sai/dx^2)-(2m/hbar^2)(V-E)sai =0
Post Reply

Return to “Laptop”