***SOME FORUM UPDATES IN THE NEXT DAYS***SOME LOGIN BUGS, JUST WAIT FINISH OF THE UPDATE AND MIGRATE PROCESS***

-->Donations via PayPal [External Link Removed for Guests] :guitar
-->Installation/Post Installation Tutorial [Local Link Removed for Guests]
-->Useful Links [Local Link Removed for Guests]
-->Olarila Images - Updated images [Local Link Removed for Guests]
-->Guides and Tutorials [Local Link Removed for Guests]
-->Clover Folder for All Chipsets [Local Link Removed for Guests]
-->DSDT Patch Requests [Local Link Removed for Guests]

[HELP] i7 860, DFI p55, Sapphire RX570 - black screen on Mojave and High Sierra

Post Reply
vaibhavyagnik
Posts: 11
Joined: 13 Apr 2019, 11:28
CPU: i7 860
Motherboard: DFI Lanparty P55-T3eh9
GPU: Sapphire Pulse RX570 4GB

[HELP] i7 860, DFI p55, Sapphire RX570 - black screen on Mojave and High Sierra

Post by vaibhavyagnik »

Hello everyone. Looking for some help installing Mojave or High Sierra. Currently I am running Sierra on the same Hardware, but I do not have sound over HDMI - I am using Motherboard audio.
My Hardware:
Core i7 860
DFI P55 T3eH9
Sapphire Pulse RS570 4GB
Computer is connected to my TV via HDMI

I used Olarilla Mojave Image to prepare a Mojave installation USB. Using USB I boot the computer. The computer boots to present clover. In clover I change SMBIOS to 14,2 as advised in another thread with similar hardware ([Local Link Removed for Guests]) The installation starts to boot and I get white text and after some time, I get a black screen. The last messages are Unsupported CPU and after that the screen goes black. How do i solve the problem?

Alternatively If i can audio over HDMI on the current Sierra installation then that would also be great. Thanks !!
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 17285
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[HELP] i7 860, DFI p55, Sapphire RX570 - black screen on Mojave and High Sierra

Post by MaLd0n »

vaibhavyagnik, amd card RX5xx need a uefi mode for work
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
vaibhavyagnik
Posts: 11
Joined: 13 Apr 2019, 11:28
CPU: i7 860
Motherboard: DFI Lanparty P55-T3eh9
GPU: Sapphire Pulse RX570 4GB

[HELP] i7 860, DFI p55, Sapphire RX570 - black screen on Mojave and High Sierra

Post by vaibhavyagnik »

Thank you for your reply MaLd0n. So since my motherboard is legacy, I wont be able to install Mojave?
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 17285
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[HELP] i7 860, DFI p55, Sapphire RX570 - black screen on Mojave and High Sierra

Post by MaLd0n »

vaibhavyagnik, native no, u need change things, some people made it, i don't remember trick, check in google
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
vaibhavyagnik
Posts: 11
Joined: 13 Apr 2019, 11:28
CPU: i7 860
Motherboard: DFI Lanparty P55-T3eh9
GPU: Sapphire Pulse RX570 4GB

[HELP] i7 860, DFI p55, Sapphire RX570 - black screen on Mojave and High Sierra

Post by vaibhavyagnik »

can you guide me what I should google?
vaibhavyagnik
Posts: 11
Joined: 13 Apr 2019, 11:28
CPU: i7 860
Motherboard: DFI Lanparty P55-T3eh9
GPU: Sapphire Pulse RX570 4GB

[HELP] i7 860, DFI p55, Sapphire RX570 - black screen on Mojave and High Sierra

Post by vaibhavyagnik »

Any help will be appreciated
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 17285
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[HELP] i7 860, DFI p55, Sapphire RX570 - black screen on Mojave and High Sierra

Post by MaLd0n »

vaibhavyagnik, try with DP output
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
vaibhavyagnik
Posts: 11
Joined: 13 Apr 2019, 11:28
CPU: i7 860
Motherboard: DFI Lanparty P55-T3eh9
GPU: Sapphire Pulse RX570 4GB

[HELP] i7 860, DFI p55, Sapphire RX570 - black screen on Mojave and High Sierra

Post by vaibhavyagnik »

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
01 Nov 2019, 14:51
vaibhavyagnik, try with DP output
Hello MaLd0n,
You were right. I am getting Display on DP port. I used a DP to HDMI cable and was able to Install Mojave on my SSD. But now I am encountering another problem. The Installation seems to be having some problem. I do not see any EFI paritions on my mojave Install disk. Here is what my Diskutil list command looks like

Code: [Local Link Removed for Guests]

Vaibhavs-iMac:~ vaibhavyagnik$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *240.1 GB   disk0
   1:                  Apple_HFS Mojave                  240.1 GB   disk0s1

/dev/disk1 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *500.1 GB   disk1
   1:                  Apple_HFS MAC supplementary drive 500.1 GB   disk1s1

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *15.4 GB    disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:                  Apple_HFS Olarila Mojave 10.14.5  7.7 GB     disk2s2
I have made the USB twice and installed Mojave twice, but the EFI partition does not get created. Since EFI partition is not created, I cannot proceed with post install steps. Please help
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 17285
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[HELP] i7 860, DFI p55, Sapphire RX570 - black screen on Mojave and High Sierra

Post by MaLd0n »

vaibhavyagnik, u need format HDD/SSD with GUID and APFS
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
vaibhavyagnik
Posts: 11
Joined: 13 Apr 2019, 11:28
CPU: i7 860
Motherboard: DFI Lanparty P55-T3eh9
GPU: Sapphire Pulse RX570 4GB

[HELP] i7 860, DFI p55, Sapphire RX570 - black screen on Mojave and High Sierra

Post by vaibhavyagnik »

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
09 Nov 2019, 16:57
vaibhavyagnik, u need format HDD/SSD with GUID and APFS
While installation, I format the whole SSD using Mac OS journaled. I do not get option for using APFS.. I do not know how to format the SSD using both methods. Do I need to manually create both the partitions? Link to a guide will be helpful. Thanks
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 17285
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[HELP] i7 860, DFI p55, Sapphire RX570 - black screen on Mojave and High Sierra

Post by MaLd0n »

vaibhavyagnik, [Local Link Removed for Guests]
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
vaibhavyagnik
Posts: 11
Joined: 13 Apr 2019, 11:28
CPU: i7 860
Motherboard: DFI Lanparty P55-T3eh9
GPU: Sapphire Pulse RX570 4GB

[HELP] i7 860, DFI p55, Sapphire RX570 - black screen on Mojave and High Sierra

Post by vaibhavyagnik »

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
10 Nov 2019, 05:38
vaibhavyagnik, [Local Link Removed for Guests]
I followed the guide. But while using disk utility to format SSD, I do not get option to format using APFS.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 17285
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[HELP] i7 860, DFI p55, Sapphire RX570 - black screen on Mojave and High Sierra

Post by MaLd0n »

vaibhavyagnik, ???
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
vaibhavyagnik
Posts: 11
Joined: 13 Apr 2019, 11:28
CPU: i7 860
Motherboard: DFI Lanparty P55-T3eh9
GPU: Sapphire Pulse RX570 4GB

[HELP] i7 860, DFI p55, Sapphire RX570 - black screen on Mojave and High Sierra

Post by vaibhavyagnik »

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
11 Nov 2019, 14:35
vaibhavyagnik, ???
I was able to resolve the APFS not appearing problem. The problem was I had selection MBR as the partition map. As soon as I changed it GUID, APFS option was available. I was able to install Mojave without any problem. thanks to you, I have a working Mojave hackintosh. One more thing if you can help me please. I wanted to see if I can upgrade to Catalina. When catalina installation beings, I get addition entries in Clover. I should select which entry so that Mojave upgrades to Catalina. Entries are like Filevault, Preinstaller to Preinstallaer etc.

One more thing. Which SMBIOS will be the best for me. I believe 11,3 is the most suitable, but will I get full acceleration in final cut pro with my RX570 if I choose 11,3 or should I go for 14,2?
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 17285
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[HELP] i7 860, DFI p55, Sapphire RX570 - black screen on Mojave and High Sierra

Post by MaLd0n »

vaibhavyagnik, check clover configurator smbios tab and use -no_compat_check flag
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
vaibhavyagnik
Posts: 11
Joined: 13 Apr 2019, 11:28
CPU: i7 860
Motherboard: DFI Lanparty P55-T3eh9
GPU: Sapphire Pulse RX570 4GB

[HELP] i7 860, DFI p55, Sapphire RX570 - black screen on Mojave and High Sierra

Post by vaibhavyagnik »

This is a update for anyone on the internet who has the same hardware configuration as mine and wants to install Catalina. Here is what I did
1. Using Maldon's Mojave Image, I installed Mojave - Keep SMBIOS as 14,2 or you will get "Mac OS cannot be installed on your computer error". Also you will have to use the DP port of your graphics card, else you will get black screen after verbose boot mode finishes
2. After succesful Installation, Install Clover boot loader on installation HDD/SSD, copy clover of USB to /volumes/EFI/ of you installation disk
3. check for updates on mac store. download catalina
4. Follow this guide to prepare a bootable USB: [External Link Removed for Guests]
5. Copy all the kexts from /volumes/EFI/Clover/Kexts/Others to your catalina USB/EFI/Clover/Kexts/Others
6. Replace Whatevergreen and lilu by their latest versions on catalina USB/EFI/Clover/Kexts/Others The Latest Whatevergreen will also have a .aml file which needs to be placed in USB/EFI/Clover/ACPI/Patched - if you use 1.3.4 or less, you will black screen after verbose login of catalina.
7. Install Catalina by first erasing your SSD to APFS and then installing Catalina
8. Download and Install latest clover boot loader on to the Catalina HDD/SSD
9. Dowload clover configurator and mount EFI of Catalina SSD/HDD and USB
10. Copy clover from /USB/EFI/Clover to /Volumes/EFI/
11. To get Audio working, place APPLEALC.kext in USB/EFI/Clover/Kexts/Others and modify config.plist in USB/EFI/Clover. Add Inject =1 under Device/Audio. Save config.plist and reboot. you can use clover configurator to modify config.plist.

I tried couple of times but i always got a kernel panic when directly upgrading from mojave to catalina. So i chose to do a fresh install.

Still working on getting iMessage working but that is on low priority. I dont really need iMessage.
lazpanyol
Posts: 8
Joined: 25 Nov 2019, 22:22
CPU: intel i5 3570 3.20 ghz
Motherboard: asus p8h67 1155
GPU: rx 460 oem 2gb
Contact:

[HELP] i7 860, DFI p55, Sapphire RX570 - black screen on Mojave and High Sierra

Post by lazpanyol »

i have to same problem with my rx 460 2gb
so am waiting my dp convertor I'll try thanks
intel i5 3570 3.20ghz
amd rx 460 oem 2gb
10gb ddr3 ram
asus p8h67 1155 motherboard
:superman
Post Reply

Return to “Desktop”