Page 1 of 1

780GTX HDMI Audio

Posted: 02 Dec 2014, 02:35
by bsides
Ola pessoal,

Estou com a maquina abaixo e ja esta rodando tudo muito bem (Yosemite), exceto o audio via hdmi. Sera que alguém pode me dar uma luz? Agradeço qualquer sugestão.

Obrigado!

Specs:
cpu Intel i7 4790 (4Ghz), mobo Gigabyte z97x-sli, ram 8gb DDR3 1600 Kingston Viper, vga Gigabyte NVidia 780GTX 384bits 3gb DDR5, ssd Samsung EVO 120gb, hd 1tb Seagate, fonte Akasa 750w modular, wifi PCI-E TP-Link

Re: 780GTX HDMI Audio

Posted: 04 Dec 2014, 18:45
by Mirone
Me envie estes arquivos:
1-DSDT.aml
2-IOREG.ioreg

Re: 780GTX HDMI Audio

Posted: 06 Dec 2014, 17:02
by bsides
Ola Mirone,

Segue o que pediu, espero ser isso heh. Se nao for me avise que vou atras. Obrigado pela atencao, abraco.

Re: 780GTX HDMI Audio

Posted: 14 Dec 2014, 03:28
by bsides
Entendi que devo fazer algumas modificacoes, porem esta um pouco mais complexo que o usual...sera q alguem pode me dar uma direcao?

Obrigado de novo!

Re: 780GTX HDMI Audio

Posted: 16 Dec 2014, 03:06
by Mirone
bsides wrote:Entendi que devo fazer algumas modificacoes, porem esta um pouco mais complexo que o usual...sera q alguem pode me dar uma direcao?

Obrigado de novo!
Instala AppleHDA+DSDT.
[External Link Removed for Guests]
Te aconselho a mudar seu SMBIOS para iMac14,2.

Re: 780GTX HDMI Audio

Posted: 18 Dec 2014, 01:54
by bsides
Ola Mirone,

Coloquei o DSDT.aml que passou na pasta /Extra e instalei o AppleHDA.kext na pasta /S/L/E (resetei cache e a coisa toda). Alterei no SMBIOS pra iMac14,2. Ainda nao funcionou, infelizmente. Algum outro passo que possa testar? Ja vi alguns outros guias, mas eles estao muito complexos e nao consegui entender o que fazer mais... :oops:

Tela de preferencias de som:
[External Link Removed for Guests]

Hardware info e Graphics com Television: YES
[External Link Removed for Guests]
[External Link Removed for Guests]

ioreg agora (anexo):
Rafael’s.ioreg.zip

Re: 780GTX HDMI Audio

Posted: 21 Dec 2014, 15:47
by Mirone
você tem que fazer boot com o cabo HDMI conectado.
me envia seu boot.plist.

Re: 780GTX HDMI Audio

Posted: 23 Dec 2014, 06:07
by bsides
Mirone wrote:você tem que fazer boot com o cabo HDMI conectado.
me envia seu boot.plist.
Mirone, nao tenho outro cabo, sempre fiz boot pelo cabo HDMI. Minha vga soh tem uma saida HDMI. As outras saidas sao: 2 dvis e 1 display port (q nao posso usar por nao ter cabo/adaptador). O que nao entendi eh por que achou q estava fazendo boot com outro cabo? Tem algo na minha config dizendo isso?

O conteudo do meu org.chameleon.Boot.plist:

Code: [Local Link Removed for Guests]

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>EthernetBuiltIn</key>
	<string>Yes</string>
	<key>GenerateCStates</key>
	<string>Yes</string>
	<key>GeneratePStates</key>
	<string>Yes</string>
	<key>GraphicsEnabler</key>
	<string>No</string>
	<key>HDAEnabler</key>
	<string>Yes</string>
	<key>HDEFLayoutID</key>
	<string>01000000</string>
	<key>IGPEnabler</key>
	<string>Yes</string>
	<key>Kernel Flags</key>
	<string>kext-dev-mode=1 nvda_drv=1</string>
	<key>Legacy Logo</key>
	<string>Yes</string>
	<key>Timeout</key>
	<string>2</string>
	<key>UseKernelCache</key>
	<string>Yes</string>
</dict>
</plist>

Re: 780GTX HDMI Audio

Posted: 23 Dec 2014, 08:32
by mendietinha
usando chimera?

Re: 780GTX HDMI Audio

Posted: 24 Dec 2014, 04:30
by Mirone
você deve usar clover em modo UEFI, usar chameleon com uma maquina dessas não vale a pena.
e outra deleta qualquer coisa relacionada ao audio, as injeções ja foram feitas através do seu DSDT.

Re: 780GTX HDMI Audio

Posted: 13 Mar 2015, 01:23
by bsides
Olá Mirone, desculpe por demorar tanto pra postar e rescussitar esse post, mas acredito se importante para futuros installs (meu e de qq pessoa).

Fiz o que falou, instalei o osx com clover e estou postando dele. Está com a configuração mais básica seguindo informações desse site: [External Link Removed for Guests]

O audio aqui simplesmente não existe, mas não tenho nada no meu config.plist pra ele também - será q poderia me dar uma direção de como conseguir?

Agradeço novamente!

Re: 780GTX HDMI Audio

Posted: 13 Mar 2015, 11:06
by dininhogrimmjow
Usa essa kext, comigo funcionou

[External Link Removed for Guests]

Re: 780GTX HDMI Audio

Posted: 13 Mar 2015, 12:39
by bsides
Eu já tentei tudo do Toleda
[External Link Removed for Guests]
[External Link Removed for Guests]

O audio aparece nas preferencias, mas não sai de jeito algum pelo hdmi. Pelo fone normal e caixas de som vai numa boa, inclusive a entrada da frente, auto reconhecendo fones de ouvido por exemplo (Apple). Mas nada de HDMI.

dininho, sua mobo/vga são iguais as minhas? Vc só jogou esse kext em EFI/CLOVER/KEXT/10.10 ? Obrigado!

Re: 780GTX HDMI Audio

Posted: 13 Mar 2015, 16:48
by dininhogrimmjow
Eu também uso clover, mas não coloquei na EFI/CLOVER/KEXT/10.10, instalei ela usando o kext ultility e funcionou. minha VGA é uma R9 280 porem no topico la mostra que funciona em ambas e varios comentarios agradecendo também, não custa tentar né ^^

Re: 780GTX HDMI Audio

Posted: 13 Mar 2015, 19:36
by bsides
É, não rolou com esse kext também. Não sei mais o que fazer pra ser sincero, em todo lugar que leio diz que a placa é compatível. O layout id é o mesmo que o Toledo indica. Aparece nas preferencias o painel (imagem anexa)... e nada do som sair =/
Screen Shot 2015-03-13 at 4.34.16 PM.png
Se alguém puder dar uma luz, segue anexo também meu config.plist do clover. No folder /efi/clover/kexts/10.10 só tem o fakesmc.kext.

Abraço, obrigado!
config.plist.zip

EDIT: Depois de olha esse meu post por muito tempo percebi que havia um scroll... e ao dar o scroll apareceu a opção do monitor. Agora estou na dúvida se já estava funcionando antes ou não. Irei testar e atualizar esse post. De qualquer forma, MUITO OBRIGADO pelo kext. Eu gostaria muito que fosse mais simples, mas isso já basta. Obrigado mesmo! :D
Screen Shot 2015-03-13 at 4.43.58 PM.png

Re: 780GTX HDMI Audio

Posted: 13 Mar 2015, 22:58
by dininhogrimmjow
Acho que foi a kext viu, também tentei de tudo pra funcionar mas não teve conversa, só com a kext kkkkkkkkkkkkkkkkkk foi dias de pesquisa pra resolver em 2 minutos kkkkkkkkkkkkkkkkkkkkk

Re: 780GTX HDMI Audio

Posted: 16 Mar 2015, 12:53
by bsides
Foi isso mesmo rapaz, tentei de outras formas, mas essa foi a que rolou. Valeu de novo, abraço!