-->Donations via PayPal [External Link Removed for Guests] :guitar
-->Installation/Post Installation Tutorial [Local Link Removed for Guests]
-->Useful Links [Local Link Removed for Guests]
-->Olarila Images - Updated images [Local Link Removed for Guests]
-->Guides and Tutorials [Local Link Removed for Guests]
-->Clover Folder for All Chipsets [Local Link Removed for Guests]
-->DSDT Patch Requests [Local Link Removed for Guests]

[Guide] Easy Audio Solution with AppleAlc

Clawric
Posts: 31
Joined: 07 Jun 2019, 07:46
CPU: Intel Core i7-740QM 2.93 GHz
Motherboard: OEM Motherboard
GPU: Geforce GT 330M

[Guide] Easy Audio Solution with AppleAlc

Post by Clawric » 16 Aug 2019, 15:08

MaLd0n, nevermind fixed it by reinstalling clover

Added in 10 minutes 30 seconds:
I followed all the steps but it's still not working :|
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14603
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Easy Audio Solution with AppleAlc

Post by MaLd0n » 16 Aug 2019, 15:22

Clawric, u need try all layouts, inject, save, reboot, test, every time
--Donations via PayPal [External Link Removed for Guests] :guitar

--Donated? Send me one Private Message
Clawric
Posts: 31
Joined: 07 Jun 2019, 07:46
CPU: Intel Core i7-740QM 2.93 GHz
Motherboard: OEM Motherboard
GPU: Geforce GT 330M

[Guide] Easy Audio Solution with AppleAlc

Post by Clawric » 17 Aug 2019, 06:48

MaLd0n, but i only have 1 layout
Clawric
Posts: 31
Joined: 07 Jun 2019, 07:46
CPU: Intel Core i7-740QM 2.93 GHz
Motherboard: OEM Motherboard
GPU: Geforce GT 330M

[Guide] Easy Audio Solution with AppleAlc

Post by Clawric » 17 Aug 2019, 16:04

my only layout is 28. when I injected and rebooted it showed my speakers in system information but when I go to system preferences<sound<input it shows nothing and I tried playing a song but nothing worked
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14603
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Easy Audio Solution with AppleAlc

Post by MaLd0n » 17 Aug 2019, 17:03

Clawric, use voodoohda or patch applehda
--Donations via PayPal [External Link Removed for Guests] :guitar

--Donated? Send me one Private Message
Clawric
Posts: 31
Joined: 07 Jun 2019, 07:46
CPU: Intel Core i7-740QM 2.93 GHz
Motherboard: OEM Motherboard
GPU: Geforce GT 330M

[Guide] Easy Audio Solution with AppleAlc

Post by Clawric » 19 Aug 2019, 11:33

MaLd0n, now it shows "digital out (hdmi)"but speakers still do not work.
mody44ever
Posts: 21
Joined: 31 Oct 2018, 22:06
CPU: i7 8550U
Motherboard: lenovo
GPU: nvidia mx 150

[Guide] Easy Audio Solution with AppleAlc

Post by mody44ever » 29 Aug 2019, 06:38

i can't find the alc id through dpci manager or runme please help me when i see in RunMe or DPCI Manager it says
Vendor : INTEL DP/HDMI
Name : Haswell
Codec : 0x80862807
what should i do
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14603
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Easy Audio Solution with AppleAlc

Post by MaLd0n » 29 Aug 2019, 13:59

mody44ever, check ur notebook specs, check manufacturer site
--Donations via PayPal [External Link Removed for Guests] :guitar

--Donated? Send me one Private Message
User avatar
aryaone
Posts: 26
Joined: 06 Aug 2019, 06:57
CPU: Intel core i3-8100
Motherboard: gigabyte B360M
GPU: RX 570

[Guide] Easy Audio Solution with AppleAlc

Post by aryaone » 04 Sep 2019, 09:03

hi MaLd0n,
i have alc235 and already try to install latest applealc.kext and lilu.kext on L/E, and inject layout id = 28 to config.plist, but the sound still not work. when i check the ioreg file, why alc-layout-id always 7? even if i already inject other layout id, but on ioreg still not change. here is my send_me file
Send me LONEXTs-MacBook-Pro.zip
You do not have the required permissions to view the files attached to this post.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14603
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Easy Audio Solution with AppleAlc

Post by MaLd0n » 04 Sep 2019, 16:12

aryaone, Image
--Donations via PayPal [External Link Removed for Guests] :guitar

--Donated? Send me one Private Message
User avatar
aryaone
Posts: 26
Joined: 06 Aug 2019, 06:57
CPU: Intel core i3-8100
Motherboard: gigabyte B360M
GPU: RX 570

[Guide] Easy Audio Solution with AppleAlc

Post by aryaone » 05 Sep 2019, 01:36

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
04 Sep 2019, 16:12
aryaone, Image
so, i need to change that value in order to make apple alc work?
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14603
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Easy Audio Solution with AppleAlc

Post by MaLd0n » 05 Sep 2019, 13:54

aryaone, remove it, Inject ur layout id in option above, Audio/Inject
--Donations via PayPal [External Link Removed for Guests] :guitar

--Donated? Send me one Private Message
User avatar
Naskall
Posts: 3
Joined: 05 Sep 2019, 01:50
CPU: Intel i5 3330
Motherboard: Gigabyte b75m-d3h
GPU: Nvidia 1060gt

[Guide] Easy Audio Solution with AppleAlc

Post by Naskall » 09 Sep 2019, 22:54

What about Nvidia 1060 HDMI audio ? :crazy:
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14603
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Easy Audio Solution with AppleAlc

Post by MaLd0n » 10 Sep 2019, 04:03

Naskall, applealc
--Donations via PayPal [External Link Removed for Guests] :guitar

--Donated? Send me one Private Message
ahmedgamal09
Posts: 21
Joined: 25 Apr 2019, 09:17
CPU: core i3-6006u
Motherboard: Unknown
GPU: Intel hd520

[Guide] Easy Audio Solution with AppleAlc

Post by ahmedgamal09 » 11 Sep 2019, 22:23

i have alc236 and tried all the layouts available for it and installed lilu.kext and AppleALC.kexst and it didn't work :wallbash is there any thing i can do to make it work :?: :)
You do not have the required permissions to view the files attached to this post.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14603
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Easy Audio Solution with AppleAlc

Post by MaLd0n » 12 Sep 2019, 03:23

ahmedgamal09, applehdapatcher, check tread
--Donations via PayPal [External Link Removed for Guests] :guitar

--Donated? Send me one Private Message
astroboyvn88
Posts: 12
Joined: 31 Jul 2019, 09:10
CPU: i9 9900k
Motherboard: z390m Gaming
GPU: GTX 1060

[Guide] Easy Audio Solution with AppleAlc

Post by astroboyvn88 » 19 Sep 2019, 15:28

Mald0n,

I use the same Z390 M gaming as yours, ALC892 but when I tried layout 7 like you did, no sound at all. I tried all other layout but they didn't work either.

Audio works via bluetooth connection though. Help! :(
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 14603
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Easy Audio Solution with AppleAlc

Post by MaLd0n » 19 Sep 2019, 15:37

astroboyvn88, work fine, 1, 7 and others

just use hdas to hdef, layout id, applealc+lilu
--Donations via PayPal [External Link Removed for Guests] :guitar

--Donated? Send me one Private Message
Raqha
Posts: 12
Joined: 26 Sep 2019, 13:40
CPU: Dell Inspiron 15 7500
Motherboard: Asus Zenrock z370
GPU: GT750

[Guide] Easy Audio Solution with AppleAlc

Post by Raqha » 01 Oct 2019, 09:51

How do I inject a layout?

I mean, do I have to paste the code or what? You just say inject but don't say how :oops:
User avatar
onemanosx
Olarila Staff
Olarila Staff
Posts: 1355
Joined: 03 Feb 2018, 05:42
CPU: Intel i7-6700HQ HM170 Chipset
Motherboard: Acer Aspire VN7-592G Laptop
GPU: Intel HD 530 + Nvidia GTX 960M

[Guide] Easy Audio Solution with AppleAlc

Post by onemanosx » 01 Oct 2019, 12:27

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
01 Oct 2019, 09:51
How do I inject a layout?

I mean, do I have to paste the code or what? You just say inject but don't say how :oops:


[External Link Removed for Guests]
[External Link Removed for Guests]

Acer Aspire V15 Nitro- Black Edition VN7-592G/HM170 Chipset
Intel i7-6700HQ, 8GB RAM (UEFI Clover Catalina)

MSI B360 Gaming Arctic
Intel i5-8600 16GB RAM Asus Radeon RX580 8GB (UEFI Clover Catalina)
Post Reply

Return to “Guides and tutorials”