-->Donations via PayPal [External Link Removed for Guests] :guitar
-->Installation/Post Installation Tutorial [Local Link Removed for Guests]
-->Useful Links [Local Link Removed for Guests]
-->Olarila Images - Updated images [Local Link Removed for Guests]
-->Guides and Tutorials [Local Link Removed for Guests]
-->Clover Folder for All Chipsets [Local Link Removed for Guests]
-->DSDT Patch Requests [Local Link Removed for Guests]

[Guide] Native USB Fix for Desktops - No Injector/Kext Required - SkyLake+

User avatar
MaLd0n
Site Admin
Site Admin
Posts: 15722
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by MaLd0n » 21 Jun 2019, 21:44

telepati, checked here and hs10 is not used port, enable port in ssdt
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
User avatar
telepati
Posts: 86
Joined: 03 Mar 2012, 01:21
CPU: i9 9900K
Motherboard: GigaByte Z390 M Gaming
GPU: Asus ROG RX 560

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by telepati » 21 Jun 2019, 23:43

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
21 Jun 2019, 21:44
telepati, checked here and hs10 is not used port, enable port in ssdt
Sorry, but what do you mean? Just like you said I enabled port in ssdt. Please look at the pictures isn't it right?

I also tried both connectors type but nothing changed.

Image
Image
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 15722
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by MaLd0n » 22 Jun 2019, 00:05

telepati, extract one send_me
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
User avatar
telepati
Posts: 86
Joined: 03 Mar 2012, 01:21
CPU: i9 9900K
Motherboard: GigaByte Z390 M Gaming
GPU: Asus ROG RX 560

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by telepati » 22 Jun 2019, 19:44

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
22 Jun 2019, 00:05
telepati, extract one send_me
Here is my send me files.
You do not have the required permissions to view the files attached to this post.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 15722
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by MaLd0n » 23 Jun 2019, 03:49

telepati, hs10 is full load
Image

sound like a bug system

repair permission, rebuild cache
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
User avatar
telepati
Posts: 86
Joined: 03 Mar 2012, 01:21
CPU: i9 9900K
Motherboard: GigaByte Z390 M Gaming
GPU: Asus ROG RX 560

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by telepati » 23 Jun 2019, 15:07

MaLd0n, I made a couple of changes in BIOS enabled XHC and 4G then repair permission and rebuild the cache,

Now everything works.

The picture you released it says AppleUSB20InternalHub now it says AppleUSB20Hub. But I will make a test with default BIOS settings. Cause I want to be sure this is BIOS related issue or not.

Image

Edit: Test it with Default BIOS settings not changed. Everything still works. Thats mean repairs and rebuild cache fixed my problem. Thank you. :frantics
aldebaran
Posts: 69
Joined: 16 Jun 2011, 18:04
CPU: i5 8600k
Motherboard: Z370 gaming 3
GPU: RX560

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by aldebaran » 28 Jun 2019, 11:14

MaLd0n,
I have different SSDT-5-AMI.aml file. So what should I do to get fixed SSDT file?
Here is my USB SSDT file.

Thank you for any help.

Regards, Aldebaran
You do not have the required permissions to view the files attached to this post.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 15722
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by MaLd0n » 28 Jun 2019, 12:31

aldebaran, just create devices and check all _UPC
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
aldebaran
Posts: 69
Joined: 16 Jun 2011, 18:04
CPU: i5 8600k
Motherboard: Z370 gaming 3
GPU: RX560

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by aldebaran » 02 Jul 2019, 20:38

MaLd0n,
What do you mean by creating device?
Regards, Aldebaran
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 15722
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by MaLd0n » 02 Jul 2019, 20:45

aldebaran, is a methods for identify ports

Method (MALD for example
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
swede420
Posts: 18
Joined: 03 Apr 2012, 18:26
CPU: i7 6700 3.4
Motherboard: GA-Z170M-D3H
GPU: SAPPHIRE RX 570 PULSE

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by swede420 » 12 Jul 2019, 10:13

Hi Madl0n!
This is my SSDT for usb, I want do do native USB patches but I am confused about all those DP01,DP02, exec...
Cn you please help me?

Thanks in advance.
You do not have the required permissions to view the files attached to this post.
User avatar
onemanosx
Olarila Staff
Olarila Staff
Posts: 1430
Joined: 03 Feb 2018, 05:42
CPU: Intel i7-6700HQ HM170 Chipset
Motherboard: Acer Aspire VN7-592G Laptop
GPU: Intel HD 530 + Nvidia GTX 960M

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by onemanosx » 12 Jul 2019, 11:47

MaLd0n, My OEM does not contain UMAP and I have difficulty enabling the ports. Even adding UMAP didnt help either.
[External Link Removed for Guests]
[External Link Removed for Guests]

Acer Aspire V15 Nitro- Black Edition VN7-592G/HM170 Chipset
Intel i7-6700HQ, 8GB RAM (UEFI Clover Catalina)

MSI B360 Gaming Arctic
Intel i5-8600 16GB RAM Asus Radeon RX580 8GB (UEFI Clover Catalina)
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 15722
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by MaLd0n » 12 Jul 2019, 15:50

swede420, u need test

Added in 2 minutes 3 seconds:
onemanosx, have many variations
in my notebook for example
0xff enable and Zero disable
Image
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
swede420
Posts: 18
Joined: 03 Apr 2012, 18:26
CPU: i7 6700 3.4
Motherboard: GA-Z170M-D3H
GPU: SAPPHIRE RX 570 PULSE

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by swede420 » 12 Jul 2019, 20:13

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
12 Jul 2019, 15:52
swede420, u need test
I have bild this one but when I boot with it no USB att all. Can you please take a look?
You do not have the required permissions to view the files attached to this post.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 15722
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by MaLd0n » 12 Jul 2019, 20:27

swede420, u have a many ports disable, many many, check all and put One
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
swede420
Posts: 18
Joined: 03 Apr 2012, 18:26
CPU: i7 6700 3.4
Motherboard: GA-Z170M-D3H
GPU: SAPPHIRE RX 570 PULSE

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by swede420 » 12 Jul 2019, 20:42

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
12 Jul 2019, 20:27
swede420, u have a many ports disable, many many, check all and put One
How do I check? Is there a utility for it?
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 15722
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by MaLd0n » 12 Jul 2019, 20:50

swede420, read first post, u need check all _UPC
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
swede420
Posts: 18
Joined: 03 Apr 2012, 18:26
CPU: i7 6700 3.4
Motherboard: GA-Z170M-D3H
GPU: SAPPHIRE RX 570 PULSE

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by swede420 » 12 Jul 2019, 23:06

Now I thought I got it right but one port does not work. Tried to enable the disabled ports one by one but it did not work. What can I do?
You do not have the required permissions to view the files attached to this post.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 15722
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by MaLd0n » 13 Jul 2019, 01:05

swede420, full efi folder, replace, reboot and check if work, don't change nothing, just replace full efi
EFI.zip
You do not have the required permissions to view the files attached to this post.
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
swede420
Posts: 18
Joined: 03 Apr 2012, 18:26
CPU: i7 6700 3.4
Motherboard: GA-Z170M-D3H
GPU: SAPPHIRE RX 570 PULSE

[Guide] Native USB Fix - No Injector/Kext Required - SkyLake+

Post by swede420 » 13 Jul 2019, 20:43

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
13 Jul 2019, 01:05
swede420, full efi folder, replace, reboot and check if work, don't change nothing, just replace full efi
EFI.zip
Thankyou, but it did not work. The same USB port still don't work, it is working until boot though.
Post Reply

Return to “Guides and tutorials”