-->Donations via PayPal [External Link Removed for Guests] :guitar
-->Installation/Post Installation Tutorial [Local Link Removed for Guests]
-->Useful Links [Local Link Removed for Guests]
-->Olarila Images - Updated images [Local Link Removed for Guests]
-->Guides and Tutorials [Local Link Removed for Guests]
-->Clover Folder for All Chipsets [Local Link Removed for Guests]
-->DSDT Patch Requests [Local Link Removed for Guests]

DSDT patch requests

User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13522
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

DSDT patch requests

Post by MaLd0n » 08 May 2019, 17:02

dannyramdhani,
CLOVER.zip
Added in 5 minutes 47 seconds:
yagomp, check with hackintool, i don't have ur hardware for try solve it

Added in 1 minute 13 seconds:
vikindap, u need usea correct renames patches for ur chipset, check Olarila clover folder

Added in 7 minutes 18 seconds:
platinumsteel,
DSDT.aml.zip
You do not have the required permissions to view the files attached to this post.
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
mike390
Posts: 2
Joined: 08 May 2019, 12:54
CPU: i5 3570k
Motherboard: AsRock z77 Extreme4
GPU: MSI Armour Radeon RX 570

DSDT patch requests

Post by mike390 » 08 May 2019, 18:05

Hi, I just installed Mojave 10.14.4 and was having random CPU lag. I was hoping you could help me out, my system is:
AsRock z77 Extreme4
i5 i3570k (Ivy Bridge)
20GB Ram
MSI Armour Radeon RX 570 4GB

Ive attached the output of `Run me.app`

Thanks for your time! :)
You do not have the required permissions to view the files attached to this post.
Last edited by mike390 on 08 May 2019, 20:49, edited 1 time in total.
User avatar
RedStarOne
Posts: 7
Joined: 01 Nov 2018, 09:38
CPU: Xenon X5670
Motherboard: Gigabyte-X58A-UD3R
GPU: NVIDIA GTX960
Location: Germany/Köngen
Contact:

DSDT patch requests

Post by RedStarOne » 08 May 2019, 19:01

Hello,

I need a DSDT Patch too, my file:

THANK You, greets JOEL Kind
(zerozone@gmx.de)

SYSTEM: GA-Z170X Ultra Gaming (Rev. 1.0)
GTX680/i5-6400/4GB Ram
Bye
You do not have the required permissions to view the files attached to this post.
1.) Gigabyte GA-X58A-Ud3R/INTEL X5670/GTX960(2GB)/12GB Ram/Manjaro XFCE/Win 10/Mojave 10.14.4(Olarila)
2.) Gigabyte GA-Z170X Ultra Gaming/INTEL i5-6400/GTX680(4GB)/4GB Ram/Mojave 10.14.4(Olarila)
3.) iMac 12.2/INTEL i5-2400/HD6970M(1GB)/4GB Ram/El Capitan
4.) Liantec ITX-6M45/INTEL P8600/GTX285(1GB)/8GB Ram/Win 10
T1m3rlan
Posts: 7
Joined: 02 Mar 2019, 19:08
CPU: i5 3210m
Motherboard: Dell Lattitude 5430
GPU: HD 4000

DSDT patch requests

Post by T1m3rlan » 08 May 2019, 19:53

Hello!
Got HS on my desktop.

MB: Gigabyte H61m-s2 ver.2.0
CPU: i5 2400
GB: Nvidia 1050ti 4 Gb + Intel HD2000
RAM: 8Gb

All files are attached.
Thanks in advance!
You do not have the required permissions to view the files attached to this post.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13522
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

DSDT patch requests

Post by MaLd0n » 09 May 2019, 03:26

mike390,
DSDT.aml.zip
Generate one SSDT for good PM
[Local Link Removed for Guests]

Added in 3 minutes 14 seconds:
RedStarOne,
DSDT.aml.zip
Added in 5 minutes 11 seconds:
T1m3rlan,
DSDT.aml.zip
You do not have the required permissions to view the files attached to this post.
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
papa
Posts: 28
Joined: 22 Apr 2019, 00:06
CPU: Intel i7-3960X
Motherboard: GA-X79-UD5
GPU: AMD RX 580 Pulse

DSDT patch requests

Post by papa » 09 May 2019, 03:54

papa, u just need a driver for LAN work
Thanks again for your help you are the best!
i'm still searching for a good Kext hope i'll find it.
i have AMD Fire pro w7000 4GB old workstation GPU it support 10bit output for Color Grading monitor.
any chance i can put it ?do i need a patch kext or it will work OOB?
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13522
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

DSDT patch requests

Post by MaLd0n » 09 May 2019, 04:01

papa, i think work oob, let's try
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
papa
Posts: 28
Joined: 22 Apr 2019, 00:06
CPU: Intel i7-3960X
Motherboard: GA-X79-UD5
GPU: AMD RX 580 Pulse

DSDT patch requests

Post by papa » 09 May 2019, 04:31

amazing this old card back to life it's working OOB :crazy: :crazy: :crazy:
Thank you !!!


i think someone found how to fix the lan

Intel i350 with Clover:

Just enter faked for LAN 0x15338086 in Devices and FixLan in ACPI. No kext patching, etc.

attached his DSDT for Supermicro X9DAi maybe you can fix my with his solution?

i don't understand nothing :D
You do not have the required permissions to view the files attached to this post.
freethinker
Posts: 9
Joined: 23 Nov 2011, 06:01

DSDT patch requests

Post by freethinker » 09 May 2019, 05:11

Hi, I have a HPdv7 ivy bridge laptop, with a i7 3610 cpu, 16gb ram Nvidia gt650/intel4000. etc.. i made the bootable usb, installed image onto a 320GB 7200rpm HDD.
then let it reboot followed the directions to remove hibernation via the 2 hibernation scripts. installed the clover onto the hd, i got a kernel panic, when booting from the hd (yes, i used config2 ) my guess is that the DSDT needs modification. please note i am able to boot from the usb and start the image from the hd. i have attached the sendme file as well as a sysinfo file that i made from a linux disto... thanks.
You do not have the required permissions to view the files attached to this post.
Last edited by freethinker on 09 May 2019, 13:45, edited 2 times in total.
mogimog
Posts: 1
Joined: 09 May 2019, 06:29
CPU: i5-5200
Motherboard: Asus
GPU: Intel GPU 5500

DSDT patch requests

Post by mogimog » 09 May 2019, 06:38

my config
i5-5200
6gigs of ram
hd5500
You do not have the required permissions to view the files attached to this post.
adrianmorrin
Posts: 3
Joined: 08 May 2019, 09:51
CPU: i5 4570
Motherboard: dell 3020mt
GPU: 4600 intel

DSDT patch requests

Post by adrianmorrin » 09 May 2019, 09:28

Thank you so much! This has fixed my keyboard, strangely though, it fixed my monitor, which worked after the first reboot (Added my own SMBIOS/sys defs) and all was fine. system went to sleep and the monitor never came back on, even after reboot. SO back to using dell u2410 now again. Any idea what could be causing this or how to fix it? When I plug the DP in the monitor powers up light goes blue and "No signal". If I then grab the DP cable and plug back into dell it comes on no problem. I also have a pice adapter that has Mac wifi/bt card - Wifi works fine, bluetooth not, Ive tried Mobo header cable to card also straight usb cable for BT, the straight USB will actually show up in system settings but won't connect to anything.

BCM94331PCIEBT4CAX Card being used in:
ABWB WIFI+Bluetooth Wireless PCI-E Card For Apple Hackintosh MAC OS X Computer
[External Link Removed for Guests]

Thank you so much again you absolute legend!
User avatar
RedStarOne
Posts: 7
Joined: 01 Nov 2018, 09:38
CPU: Xenon X5670
Motherboard: Gigabyte-X58A-UD3R
GPU: NVIDIA GTX960
Location: Germany/Köngen
Contact:

DSDT patch requests

Post by RedStarOne » 09 May 2019, 10:42

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
09 May 2019, 03:34
mike390, DSDT.aml.zip
Generate one SSDT for good PM
[Local Link Removed for Guests]

Added in 3 minutes 14 seconds:
RedStarOne, DSDT.aml.zip

Added in 5 minutes 11 seconds:
T1m3rlan, DSDT.aml.zip
[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
09 May 2019, 03:34
mike390, DSDT.aml.zip
Generate one SSDT for good PM
[Local Link Removed for Guests]

Added in 3 minutes 14 seconds:
RedStarOne, DSDT.aml.zip

Added in 5 minutes 11 seconds:
T1m3rlan, DSDT.aml.zip
THANK YOU! Greets JOEL!

Added in 2 minutes 58 seconds:
:D :) :D :work: :frantics :guitar :poke :meeting :superman :bye
1.) Gigabyte GA-X58A-Ud3R/INTEL X5670/GTX960(2GB)/12GB Ram/Manjaro XFCE/Win 10/Mojave 10.14.4(Olarila)
2.) Gigabyte GA-Z170X Ultra Gaming/INTEL i5-6400/GTX680(4GB)/4GB Ram/Mojave 10.14.4(Olarila)
3.) iMac 12.2/INTEL i5-2400/HD6970M(1GB)/4GB Ram/El Capitan
4.) Liantec ITX-6M45/INTEL P8600/GTX285(1GB)/8GB Ram/Win 10
mircea_h
Posts: 3
Joined: 29 Apr 2019, 16:58
CPU: i7-4750HQ
Motherboard: Intel HM86
GPU: Intel Iris Pro 5200; GTX 960M

DSDT patch requests

Post by mircea_h » 09 May 2019, 11:52

Hi,

I managed to patch my DSDT and SSDT files. Most of the things are working (sound, ethernet, sleep/wake up, backlight control, keyboard, FnKeys, touchpad, battery meter, SDCard reader). My laptop is a ASUS RoG G551JW, i7-4750HQ, Intel Iris Pro 5200 + GTX 960M in a triple boot configuration (Win 10, MacOS Mojave 10.14.5, Ubuntu).

What doesn't work is the keyboard backlight (I tried various keyboard backlight patches for the DSDT but each one gave me a kernel panic). The second one is the external monitor. I managed to disable the discrete GPU (it doesn't show up anymore between the recognized devices on Mojave), anyway when I boot up MacOS Mojave with connected external monitor (Display Port to DVI-D), the boot process gives me a error "gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0". If I disconnect the external monitor I don't have that error and everything is working just OK. After the MacOS starts, if I reconnect the cable I can use the external monitor, too.

Could anybody tell me what would be the best solution not to have to disconnect and reconnect each time I boot into MacOS Mojave.

Thank you very much for any solution or idea.

Have a nice day.
You do not have the required permissions to view the files attached to this post.
compicat
Posts: 2
Joined: 07 May 2019, 18:44
CPU: i7-3740QM
Motherboard: W530
GPU: Quadro K2000M

DSDT patch requests

Post by compicat » 09 May 2019, 12:54

Hi All,

My first message here it is. I hope I understood the things correct. By following your valuable guides I returned my W530 (with hacked bios and Broadcom Wifi Card) Mojave Hackintosh. I am glad, nearly everything works. Power management, IGPU, Framebuffer, wifi, bluetooth, brightness fn keys on HD4000 etc.

Battery Indicator: I ve used the one at Rehabman's repo, It is written there that X220 one is compatible. I ve used that patch. Generally percentage is correct, sometimes does not update, but bigger problem is that battery indicator does not update, even shows wrong symbols even if updates. I mean it shows "low battery" indicator, while it is charging etc. I also use Rehabman's fakesmc and hwmonitor, hw monitor reflects battery percentage correct. Could you please help about patching it correct?
You do not have the required permissions to view the files attached to this post.
dannyramdhani
Posts: 14
Joined: 20 Apr 2019, 01:33
CPU: i5 2340
Motherboard: Onda H67
GPU: GTX 670

DSDT patch requests

Post by dannyramdhani » 09 May 2019, 12:55

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
08 May 2019, 17:16
dannyramdhani, CLOVER.zip

Added in 5 minutes 47 seconds:
yagomp, check with hackintool, i don't have ur hardware for try solve it

Added in 1 minute 13 seconds:
vikindap, u need usea correct renames patches for ur chipset, check Olarila clover folder

Added in 7 minutes 18 seconds:
platinumsteel, DSDT.aml.zip
Thank you Mald0n
but now I got a problem about Usb port.
the warning always shows up (USB Accessory Needs Power) when I try to connected the flash drive or external hard drive.
Can you help me out?
kim133
Posts: 1
Joined: 08 May 2019, 12:19
CPU: i5 8600k
Motherboard: asus b360 itx
GPU: asus rx580

DSDT patch requests

Post by kim133 » 09 May 2019, 13:41

please help me
my mac
cpu : i5 8600k
mb : asus b360 i gaming
graphic : asus rx580 8 gb
ssd 250 gb evo 970
You do not have the required permissions to view the files attached to this post.
Lenn0n
Posts: 13
Joined: 04 Oct 2011, 07:06

DSDT patch requests

Post by Lenn0n » 09 May 2019, 14:20

Ould you please kelp me with a working DSDT.
Thanks
You do not have the required permissions to view the files attached to this post.
mike390
Posts: 2
Joined: 08 May 2019, 12:54
CPU: i5 3570k
Motherboard: AsRock z77 Extreme4
GPU: MSI Armour Radeon RX 570

DSDT patch requests

Post by mike390 » 09 May 2019, 15:00

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
09 May 2019, 03:34
mike390, DSDT.aml.zip
Generate one SSDT for good PM
[Local Link Removed for Guests]

Added in 3 minutes 14 seconds:
RedStarOne, DSDT.aml.zip

Added in 5 minutes 11 seconds:
T1m3rlan, DSDT.aml.zip
Thank you SO much! Ill try this out tonight :)
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13522
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

DSDT patch requests

Post by MaLd0n » 09 May 2019, 16:20

papa, use previous version, i patched it

Added in 6 minutes 11 seconds:
freethinker,
DSDT.aml.zip
Check useful links

Added in 7 minutes 48 seconds:
mogimog,
DSDT.aml.zip
check useful links in my sig

Added in 1 minute 38 seconds:
adrianmorrin, u try a power button for wake?

Added in 1 minute 2 seconds:
mircea_h, u check here?
[External Link Removed for Guests]

Added in 7 minutes 23 seconds:
compicat,
DSDT.aml.zip
remove ssdt pnlf, try with my dsdt and whatevergreen kext

Added in 39 seconds:
dannyramdhani, yes, extract new send_me

Added in 3 minutes 20 seconds:
kim133,
DSDT.aml.zip
Added in 8 minutes 8 seconds:
Lenn0n,
DSDT.aml.zip
You do not have the required permissions to view the files attached to this post.
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
compicat
Posts: 2
Joined: 07 May 2019, 18:44
CPU: i7-3740QM
Motherboard: W530
GPU: Quadro K2000M

DSDT patch requests

Post by compicat » 09 May 2019, 17:22

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
09 May 2019, 16:57
papa, use previous version, i patched it

Added in 6 minutes 11 seconds:
freethinker, DSDT.aml.zip
Check useful links

Added in 7 minutes 48 seconds:
mogimog, DSDT.aml.zip
check useful links in my sig

Added in 1 minute 38 seconds:
adrianmorrin, u try a power button for wake?

Added in 1 minute 2 seconds:
mircea_h, u check here?
[External Link Removed for Guests]

Added in 7 minutes 23 seconds:
compicat, DSDT.aml.zip
remove ssdt pnlf, try with my dsdt and whatevergreen kext

Added in 39 seconds:
dannyramdhani, yes, extract new send_me

Added in 3 minutes 20 seconds:
kim133, DSDT.aml.zip

Added in 8 minutes 8 seconds:
Lenn0n, DSDT.aml.zip
Hi, thanks for your fast action. I ve applied. battery is still same, percentage shows correct and updates, but indicator behaving weird and indicator does not update when adapter plugged in or out. Could you please check attached pic? I can supply if you need any other thing. I guess Rehabman's X220 battery patch is not totally compatible with w530 70++ battery even if it is written like that in comments. I don't know. Thanks in advance.
You do not have the required permissions to view the files attached to this post.
Post Reply

Return to “DSDT”