-->Donations via PayPal [External Link Removed for Guests] :guitar
-->Installation/Post Installation Tutorial [Local Link Removed for Guests]
-->Useful Links [Local Link Removed for Guests]
-->Olarila Images - Updated images [Local Link Removed for Guests]
-->Guides and Tutorials [Local Link Removed for Guests]
-->Clover Folder for All Chipsets [Local Link Removed for Guests]
-->DSDT Patch Requests [Local Link Removed for Guests]

DSDT patch requests

User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13610
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

DSDT patch requests

Post by MaLd0n » 19 Apr 2019, 02:54

hugodantas, [External Link Removed for Guests]
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
mrintegra
Posts: 37
Joined: 05 Jan 2013, 07:07
CPU: Core i7 - 7700
Motherboard: HP Pavilion 570-p033w
GPU: AMD Radeon RX580

DSDT patch requests

Post by mrintegra » 19 Apr 2019, 04:45

I think the newly patched DSDT, modified config.plist and files worked out. The HD4400 and GTX860M are now shown in iStats Menu. :guitar Sent some more beer money. Thanks again for your help MaLd0n!

Image
MaLd0n wrote: mrintegra, check if work good
CLOVER.zip
User avatar
Akshunhiro
Posts: 31
Joined: 26 Nov 2018, 05:21
CPU: i3-8100
Motherboard: GA-B360M-D3H
GPU: UHD 630

DSDT patch requests

Post by Akshunhiro » 19 Apr 2019, 06:57

MaLd0n, could you please help me with audio? I am still stuck without audio device on cold boot.
I did find that other config which did work but then my brightness doesn't work properly and I get no overlay when the keys are pressed.
I updated my current config to inject IntelGFX for correct detection of HD5500 and also changed my SMBIOS to MacBookAir7,2 but still no audio after trying to copy a lot of things from the other config.
I worked out how to patch with Hackintool (overwrite existing config to update devices) but still can't get audio with this config and I don't know why.
You do not have the required permissions to view the files attached to this post.
iheymanth
Posts: 11
Joined: 16 Apr 2019, 21:34
CPU: i7 8700k
Motherboard: Asus ROG Z370-E Gaming (WiFi)
GPU: Intel UHD 630

DSDT patch requests

Post by iheymanth » 19 Apr 2019, 08:13

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
19 Apr 2019, 01:56
moman2000, use usb patch for sierra
[Local Link Removed for Guests]

audio
[Local Link Removed for Guests]

Added in 2 minutes 49 seconds:
hugodantas, use same files
trackpad need a VoodooI2CSynaptics.kext

-Useful Links

-Video Solution
[Local Link Removed for Guests]

-Audio Solution
[Local Link Removed for Guests]

-Laptop Battery Patches
[Local Link Removed for Guests]

-Clover Folder for all Chipsets
[Local Link Removed for Guests]

-USB Raise/Remove limit port patches
[Local Link Removed for Guests]

-Brightness Hotkey Remapping
[Local Link Removed for Guests]

-Block injected kexts in boot
[Local Link Removed for Guests]

-Drop edited DSDT
[Local Link Removed for Guests]

-Hardware Encoder / Hardware Decoder / Video Processing / HEVC Support / Intel Quick Sync
[Local Link Removed for Guests]

-How to Activate Microphone on Conexant Codecs and others
[Local Link Removed for Guests]

Added in 9 minutes 54 seconds:
Epsylon, 1- replace full clover folder
CLOVER.zip
2- install clover bootloader again with these option
Image
3- reboot
@MaLd0n

hi
remember you patched my dsdt and replacing that entire clover folder didn't boot up my mac.

i just followed the above quoted instruction and replaced the patched clover and reupdated the clover bootloader with ur suggested options in screenshot and it successfully booted.

however the volume slider is still disabled

[External Link Removed for Guests]
User avatar
onemanosx
Olarila Staff
Olarila Staff
Posts: 1228
Joined: 03 Feb 2018, 05:42
CPU: Intel i7-6700HQ HM170 Chipset
Motherboard: Acer Aspire VN7-592G Laptop
GPU: Intel HD 530 + Nvidia GTX 960M

DSDT patch requests

Post by onemanosx » 19 Apr 2019, 08:37

iheymanth, is that hdmi audio? no volume control for hdmi out.
[External Link Removed for Guests]
[External Link Removed for Guests]

Acer Aspire V15 Nitro- Black Edition VN7-592G/HM170 Chipset
Intel i7-6700HQ, 8GB RAM (UEFI Clover Mojave)

MSI B360 Gaming Arctic
Intel i5-8600 16GB RAM Asus Radeon RX580 8GB (UEFI Clover Mojave)

Gigabyte GA-Z68-D3H-B3 (Retired)
Intel i7-2600 16GB RAM Asus Radeon RX580 (UEFI Clover High Sierra)
cla974
Posts: 2
Joined: 26 Mar 2019, 19:55
CPU: intel core i7 8700k
Motherboard: gigabyte z390 aorus pro wifi
GPU: Sapphire Radeon RX 580 8gb

DSDT patch requests

Post by cla974 » 19 Apr 2019, 08:41

Hello everyone, I asked you for a DSDT immediately received, it seems to work fine, but sometimes the PC crashes and I am forced to force the arrest. usually it stops immediately after starting, but other times I use the PC for hours without any problem. I attach a new send me file, and the kernal panic report. maybe I'm posting in the wrong section, I apologize. it's my first hackintosh, I kindly ask you for help. Thanks in advance
You do not have the required permissions to view the files attached to this post.
devmanus1
Posts: 20
Joined: 23 Jul 2018, 07:38
CPU: i5 8300H
Motherboard: MSI GL638RC
GPU: UHD 630

DSDT patch requests

Post by devmanus1 » 19 Apr 2019, 10:08

Hello sir,
Finally, dsdt is loaded and got the files here is the files attached and the issue list i am facing now
1. My low brightness is the highest in the slider.
2. Sound is not working in internal speaker.
3. Touchpad not working I2C touchpad
4. laptop working slow.

Please help me to fix the issues and thank you for your time.
Send me Devendras-MacBook-Pro.zip
You do not have the required permissions to view the files attached to this post.
mtc88
Posts: 14
Joined: 12 Apr 2019, 11:38
CPU: i7 3720QM
Motherboard: HP 176B (QM77)
GPU: AMD Firepro M4000

DSDT patch requests

Post by mtc88 » 19 Apr 2019, 12:03

the mojave installer will not boot, it hangs on

Forcing CS_RUNTIME for entitlement: com.apple.rootless.install


in 10.12 the AMD Firepro m4000 GPU still is not working properly, only loading 7mb ram no acceleration. Verde.kext, whatevergreen, nothing seems to work!
iheymanth
Posts: 11
Joined: 16 Apr 2019, 21:34
CPU: i7 8700k
Motherboard: Asus ROG Z370-E Gaming (WiFi)
GPU: Intel UHD 630

DSDT patch requests

Post by iheymanth » 19 Apr 2019, 13:44

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
19 Apr 2019, 08:37
iheymanth, is that hdmi audio? no volume control for hdmi out.
omg! how is that even possible when it worked fine at my very first boot for 2days but only keyboard controlling didn't worked
I do see some user also has the volume control disabled for hdmi out but how did it worked for me.
I'm noob to find it out unless I reinstall the Mac again -_-
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13610
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

DSDT patch requests

Post by MaLd0n » 19 Apr 2019, 14:45

Akshunhiro, [Local Link Removed for Guests]
[Local Link Removed for Guests]
[Local Link Removed for Guests]

Added in 3 minutes 35 seconds:
cla974, first fix it
[Local Link Removed for Guests]

kp is about nvme, avoid samsung 970 evo plus, use a 970 evo

Added in 4 minutes 59 seconds:
devmanus1, 1- [External Link Removed for Guests]
[Local Link Removed for Guests]

2- [Local Link Removed for Guests]

3- i dont see any i2c, check bios/uefi version

4- seems good in ioreg, rec one movie with slow problem

ur notebook is optimus?

Added in 56 seconds:
mtc88, [Local Link Removed for Guests]
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
devmanus1
Posts: 20
Joined: 23 Jul 2018, 07:38
CPU: i5 8300H
Motherboard: MSI GL638RC
GPU: UHD 630

DSDT patch requests

Post by devmanus1 » 19 Apr 2019, 15:42

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
19 Apr 2019, 14:55
Akshunhiro, [Local Link Removed for Guests]
[Local Link Removed for Guests]
[Local Link Removed for Guests]

Added in 3 minutes 35 seconds:
cla974, first fix it
[Local Link Removed for Guests]

kp is about nvme, avoid samsung 970 evo plus, use a 970 evo

Added in 4 minutes 59 seconds:
devmanus1, 1- [External Link Removed for Guests]
[Local Link Removed for Guests]

2- [Local Link Removed for Guests]

3- i dont see any i2c, check bios/uefi version

4- seems good in ioreg, rec one movie with slow problem

ur notebook is optimus?

Added in 56 seconds:
mtc88, [Local Link Removed for Guests]
my notebook is msi gl 638rc
spec: Intel i5 8300H
Nvdia 1050
8gn ddr4 ram
1tb hdd
1080 display

Please tell me if any other problem in my notebook so that we can fix it if noting else then aslo tell me about that thank you for the support and i read about one guide on the internet. They used linux and kvm for the fully functional hackintosh i am pasting the link please try it once and let us know it will work for us or not.
[External Link Removed for Guests]

Linus Tech Tips video
User avatar
erroruser
Olarila Staff
Olarila Staff
Posts: 486
Joined: 24 Apr 2018, 21:12
CPU: i9 9900k
Motherboard: asus z390-a
GPU: rx 590

DSDT patch requests

Post by erroruser » 19 Apr 2019, 15:49

devmanus1, forget about linus's fake hackintosh use this guide for high sierra [Local Link Removed for Guests]
Asus z390-A, i9 9900k, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, sapphire rx 590, fractal celcius s36
:superman :superman
HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB
Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13610
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

DSDT patch requests

Post by MaLd0n » 19 Apr 2019, 16:03

devmanus1, in ioreg ur hack looks good
SOME TWEAKS
clover folder with last clover version
CLOVER.zip
[External Link Removed for Guests]
Image
You do not have the required permissions to view the files attached to this post.
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
devmanus1
Posts: 20
Joined: 23 Jul 2018, 07:38
CPU: i5 8300H
Motherboard: MSI GL638RC
GPU: UHD 630

DSDT patch requests

Post by devmanus1 » 19 Apr 2019, 19:05

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
19 Apr 2019, 15:49
devmanus1, forget about linus's fake hackintosh use this guide for high sierra [Local Link Removed for Guests]
I did Mojave bro 😁 I just want to know it is possible with laptop and old systen
User avatar
erroruser
Olarila Staff
Olarila Staff
Posts: 486
Joined: 24 Apr 2018, 21:12
CPU: i9 9900k
Motherboard: asus z390-a
GPU: rx 590

DSDT patch requests

Post by erroruser » 19 Apr 2019, 19:11

yes its possible but with what i recommend is 4th gen an up with no dgpu enabled as some are not able to use an for desktop be the same 4th gen an up with an amd card or kepler an fermi cards for mojave when installing on a laptop you need to use config2plist can be changed in the option section of the boot screen
Asus z390-A, i9 9900k, Corsair Vengeance RGB PRO 16GB DDR4 3200MHz, sapphire rx 590, fractal celcius s36
:superman :superman
HP Notebook - 15-ay028ca (Touch), 16 GB 2133 MHz DDR4, Intel HD Graphics 520 1536 MB
Asus z97-c i5, i5 4460, 32 GB 1648 MHz DDR3, Radeon RX 560 4096 MB, Corsair H75 Liquid CPU Cooler
Dysergy
Posts: 1
Joined: 16 Mar 2019, 06:12
CPU: i7-8700K
Motherboard: Designare Z390
GPU: Sapphire Radeon Rx580

DSDT patch requests

Post by Dysergy » 19 Apr 2019, 22:17

Restart stops at Black Screen
No Internal Audio despite installing codec
Cannot turn off Verbose (maybe auto-toggles on?)

Please assist when possible. :)
Send me Drews-iMac.zip
You do not have the required permissions to view the files attached to this post.
User avatar
Akshunhiro
Posts: 31
Joined: 26 Nov 2018, 05:21
CPU: i3-8100
Motherboard: GA-B360M-D3H
GPU: UHD 630

DSDT patch requests

Post by Akshunhiro » 19 Apr 2019, 22:33

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
19 Apr 2019, 14:55
Akshunhiro
Audio is working though with one of the configs I posted. I just don't know what settings are making it work.
I did say to inject layout id 13 but I lose audio after cold boot.
With the working config, audio works all the time but I don't have brightness overlay.
I would prefer to use the config with the working brightness overlay and then change the settings to get audio working, I just don't know which settings.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 13610
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

DSDT patch requests

Post by MaLd0n » 20 Apr 2019, 00:05

Dysergy,
DSDT.aml.zip
USE IT TOO
WEG.zip
Added in 52 seconds:
Akshunhiro, i never see this problem, very strange
You do not have the required permissions to view the files attached to this post.
:guitar[External Link Removed for Guests]:guitar-[Local Link Removed for Guests]:guitar

Problems with Paypal Donate? Check [Local Link Removed for Guests]

-Donated? Send me one PM-
User avatar
Akshunhiro
Posts: 31
Joined: 26 Nov 2018, 05:21
CPU: i3-8100
Motherboard: GA-B360M-D3H
GPU: UHD 630

DSDT patch requests

Post by Akshunhiro » 20 Apr 2019, 01:19

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
20 Apr 2019, 00:06
Akshunhiro, i never see this problem, very strange
It's something to do with these entries. If they're disabled, I get audio but no brightness overlay. If they're enabled, I get brightness overlay but no audio on cold boot. I have tried disabling one at a time but same issue after second boot (thought I fixed as audio came back on one boot but lost it on the next).

Image
lucchilam
Posts: 4
Joined: 19 Apr 2019, 07:49
CPU: Asus K45A i3-2730M
Motherboard: HM75
GPU: Intel HD Graphic 3000

DSDT patch requests

Post by lucchilam » 20 Apr 2019, 01:36

Hello oldnapalm...
I am the newbie on Hackintosh. I have successfully installed Mac OS Niressh Sierra 10.12.3 on my Laptop. But my laptop can't get full Intel HD Graphic 3000 on Hackintosh, it just get 4MB on Graphic, and I can't change the brightness too. Please help me with DSDT patch for my Graphic work and able to change the brightness.

Attached is my send_me.zip from my laptop......
Thank you so much!
You do not have the required permissions to view the files attached to this post.
Post Reply

Return to “DSDT”