-->Donations via PayPal [External Link Removed for Guests] :guitar
-->Installation/Post Installation Tutorial [Local Link Removed for Guests]
-->Useful Links [Local Link Removed for Guests]
-->Olarila Images - Updated images [Local Link Removed for Guests]
-->Guides and Tutorials [Local Link Removed for Guests]
-->Clover Folder for All Chipsets [Local Link Removed for Guests]
-->DSDT Patch Requests [Local Link Removed for Guests]

AppleHDA Patcher v1.9

User avatar
bcuraboy
Posts: 8
Joined: 11 Feb 2018, 00:57
CPU: i7
Motherboard: asus
GPU: intel

AppleHDA Patcher v1.9

Post by bcuraboy » 04 Aug 2018, 22:25

Hey Mirone. First of all, thanks for your work, it actually activated my output, and the sound is amazing. But there's a catch, my microphone is not working. I have used AppleHDA Patcher and placed AppleHDA and HDAEnabler in S/L/E.
My device is a Conexant CX20751/2 (14f1:510f) Rev.(00100100)
- Controller 8086:9d70 (sub-ven:1043:1b1d)
- Driver: AppleHDA.kext

I have already modified platforms.xml.zlib but without success...
Thanks for your attention
User avatar
diepnt
Posts: 7
Joined: 06 Jun 2018, 14:29
CPU: i3 7100
Motherboard: H170N
GPU: HD630

AppleHDA Patcher v1.9

Post by diepnt » 07 Aug 2018, 12:25

after upgrading to 10.14 Beta (18A353d) i lost the sound.

ran the patch again but still not output on sound.

it works for beta 5?

PS: resoved. forgot to refresh cache :D
User avatar
Mirone
Olarila Staff
Olarila Staff
Posts: 1749
Joined: 15 Jun 2011, 14:22
CPU: Intel Core i7-8700k
Motherboard: GA-Z370M Aorus Gaming
GPU: Radeon RX 560 - 4GB

AppleHDA Patcher v1.9

Post by Mirone » 07 Aug 2018, 23:03

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests] I have already modified platforms.xml.zlib but without success...
I need your codec_dump for a better analysis, in some cases the external microphone in Conexsnt codecs does not work.
[External Link Removed for Guests]
fasterday
Posts: 5
Joined: 07 Aug 2018, 23:46
CPU: i5200u
Motherboard: laptop
GPU: 940m

AppleHDA Patcher v1.9

Post by fasterday » 07 Aug 2018, 23:55

Hello Mirone,

First, thank you so much for your work. ;)

I have the same problem with line mic and conexant CX20751/2. Here is a dump of the codec:
[External Link Removed for Guests]
User avatar
Mirone
Olarila Staff
Olarila Staff
Posts: 1749
Joined: 15 Jun 2011, 14:22
CPU: Intel Core i7-8700k
Motherboard: GA-Z370M Aorus Gaming
GPU: Radeon RX 560 - 4GB

AppleHDA Patcher v1.9

Post by Mirone » 08 Aug 2018, 18:03

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests] First, thank you so much for your work.
I'll analyze and see you with something as fast as possible.
[External Link Removed for Guests]
User avatar
Mirone
Olarila Staff
Olarila Staff
Posts: 1749
Joined: 15 Jun 2011, 14:22
CPU: Intel Core i7-8700k
Motherboard: GA-Z370M Aorus Gaming
GPU: Radeon RX 560 - 4GB

AppleHDA Patcher v1.9

Post by Mirone » 09 Aug 2018, 19:14

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests] I have the same problem with line mic and conexant CX20751/2. Here is a dump of the codec:
try this files:
AppleHDA-281.52-CX20752.zip
install All files in: System/Library/Extensions, repair permissions rebuild caches.
You do not have the required permissions to view the files attached to this post.
[External Link Removed for Guests]
fasterday
Posts: 5
Joined: 07 Aug 2018, 23:46
CPU: i5200u
Motherboard: laptop
GPU: 940m

AppleHDA Patcher v1.9

Post by fasterday » 09 Aug 2018, 20:02

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests] try this files:
AppleHDA-281.52-CX20752.zip
(1.79 MiB) Downloaded 1 time
install All files in: System/Library/Extensions, repair permissions rebuild caches.
The audio input level varies but this is the sound it produces :
[External Link Removed for Guests]

Image

Thank you
User avatar
Mirone
Olarila Staff
Olarila Staff
Posts: 1749
Joined: 15 Jun 2011, 14:22
CPU: Intel Core i7-8700k
Motherboard: GA-Z370M Aorus Gaming
GPU: Radeon RX 560 - 4GB

AppleHDA Patcher v1.9

Post by Mirone » 09 Aug 2018, 23:10

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests] The audio input level varies but this is the sound it produces :
try this:
AppleHDA-281.52-CX20752.zip
You do not have the required permissions to view the files attached to this post.
[External Link Removed for Guests]
fasterday
Posts: 5
Joined: 07 Aug 2018, 23:46
CPU: i5200u
Motherboard: laptop
GPU: 940m

AppleHDA Patcher v1.9

Post by fasterday » 10 Aug 2018, 08:36

With this line in does not work and the external microphone is still not detected.

Image
User avatar
Mirone
Olarila Staff
Olarila Staff
Posts: 1749
Joined: 15 Jun 2011, 14:22
CPU: Intel Core i7-8700k
Motherboard: GA-Z370M Aorus Gaming
GPU: Radeon RX 560 - 4GB

AppleHDA Patcher v1.9

Post by Mirone » 10 Aug 2018, 16:25

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests] With this line in does not work and the external microphone is still not detected.
as I mentioned earlier, this is a known problem but no solution so far.
[External Link Removed for Guests]
fasterday
Posts: 5
Joined: 07 Aug 2018, 23:46
CPU: i5200u
Motherboard: laptop
GPU: 940m

AppleHDA Patcher v1.9

Post by fasterday » 10 Aug 2018, 17:09

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
10 Aug 2018, 16:25
as I mentioned earlier, this is a known problem but no solution so far.
I misunderstood. I thought this could be fixed with the codec dump from linux. :(
So I'm gonna give up the hackintosh idea with this computer.

Thanks for the help anyway
User avatar
Mirone
Olarila Staff
Olarila Staff
Posts: 1749
Joined: 15 Jun 2011, 14:22
CPU: Intel Core i7-8700k
Motherboard: GA-Z370M Aorus Gaming
GPU: Radeon RX 560 - 4GB

AppleHDA Patcher v1.9

Post by Mirone » 10 Aug 2018, 18:54

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests] So I'm gonna give up the hackintosh idea with this computer.
You can use voodooHDA.kext if you need so much of your external microphone working, next week I'll try something about those codecs, conexant.
[External Link Removed for Guests]
fasterday
Posts: 5
Joined: 07 Aug 2018, 23:46
CPU: i5200u
Motherboard: laptop
GPU: 940m

AppleHDA Patcher v1.9

Post by fasterday » 13 Aug 2018, 15:16

Yes, but the sound is not of the same quality with VoodooHDA
Thanks if you can try something.
mahmoudtarek19
Posts: 7
Joined: 15 Aug 2018, 12:05
CPU: Core i5
Motherboard: Laptop lenovo z51
GPU: Intel 5500

AppleHDA Patcher v1.9

Post by mahmoudtarek19 » 15 Aug 2018, 15:34

Does it patch alc 236 for lenovo z51 laptop or not?
Iam using mojave os beta 7
User avatar
Mirone
Olarila Staff
Olarila Staff
Posts: 1749
Joined: 15 Jun 2011, 14:22
CPU: Intel Core i7-8700k
Motherboard: GA-Z370M Aorus Gaming
GPU: Radeon RX 560 - 4GB

AppleHDA Patcher v1.9

Post by Mirone » 16 Aug 2018, 03:14

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests] Does it patch alc 236 for lenovo z51 laptop or not?
Not specifically for the laptop in question but have a patch for ALC236 that you can try
[External Link Removed for Guests]
mahmoudtarek19
Posts: 7
Joined: 15 Aug 2018, 12:05
CPU: Core i5
Motherboard: Laptop lenovo z51
GPU: Intel 5500

AppleHDA Patcher v1.9

Post by mahmoudtarek19 » 17 Aug 2018, 15:20

I tried to patch alc but with no result (Mojave 10.14 )
also, Jarvis hardware info show this :
Hardware info:
- Realtek (Unknown) (10ec:0236) Rev.(00100001)
- Controller 8086:9ca0 (sub-ven:17aa:3823)
- Driver: AppleHDA.kext

try different layouts but still not found
voodohda run but it is low in efficiency and mic with background noise in rec
below attached info of my system
You do not have the required permissions to view the files attached to this post.
User avatar
Mirone
Olarila Staff
Olarila Staff
Posts: 1749
Joined: 15 Jun 2011, 14:22
CPU: Intel Core i7-8700k
Motherboard: GA-Z370M Aorus Gaming
GPU: Radeon RX 560 - 4GB

AppleHDA Patcher v1.9

Post by Mirone » 17 Aug 2018, 18:02

@mahmoudtarek19,
Use the attached clover folder, the attached AppleHDA.kext you should install in: System / Library / Extensions.
Repair Permissions Rebuild caches.
Ps: delete, voodooHDA, HDADisable or similar kexts.
You do not have the required permissions to view the files attached to this post.
[External Link Removed for Guests]
mahmoudtarek19
Posts: 7
Joined: 15 Aug 2018, 12:05
CPU: Core i5
Motherboard: Laptop lenovo z51
GPU: Intel 5500

AppleHDA Patcher v1.9

Post by mahmoudtarek19 » 17 Aug 2018, 19:33

@Mirone,
thanks Mirone for replying.
I have put the attached applehda in the place by kext utility '
delete voodoo and old others except HDAEnabler
and use the clover attached and it is run fine
but no sound :(
what do you mean by repair Permissions Rebuild caches?

that is my new Info by runme app.
You do not have the required permissions to view the files attached to this post.
User avatar
Mirone
Olarila Staff
Olarila Staff
Posts: 1749
Joined: 15 Jun 2011, 14:22
CPU: Intel Core i7-8700k
Motherboard: GA-Z370M Aorus Gaming
GPU: Radeon RX 560 - 4GB

AppleHDA Patcher v1.9

Post by Mirone » 17 Aug 2018, 22:07

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests] except HDAEnabler
Delete HDAEnabler.
for repair permissions use this app: [Local Link Removed for Guests]
[External Link Removed for Guests]
kevinagnes
Posts: 45
Joined: 03 May 2018, 16:14
CPU: i7 8700
Motherboard: GA H370n wifi
GPU: RX580 Pulse

AppleHDA Patcher v1.9

Post by kevinagnes » 19 Aug 2018, 11:49

Oi @Mirone , eu estou tentando todos os metodos possíveis pra fazer funcionar o audio no meu sistema mas até agora nada.
meu sistema: 10.13.6, GB h370n-wifi (alc1220), i7 8700, rx580 pulse, 16gb ram, macbook air WLAN.
Eu usei o Pacifist para extrair o AppleHDA do instalador High Sierra 10.13.6, instalei com o KextBeast e reiniciei. Depois usei o AppleHDA Patcher.app e testei os tres metodos: aDummyHDA, Clover e DSDT. Em nenhum dos casos tive resultado ;/ já estou achando que essa placa mãe não vai rolar mesmo, já quebrei a cabeça com o @Mald0n antes e não conseguimos.
Anexei meu CLOVER e IOReg.

Segue o Javis:
No audio codecs found!
Be sure to have AppleHDA.kext installed and loaded.

SSDT-4.aml succesfully extracted!
SSDT-10.aml succesfully extracted!
DSDT.aml succesfully extracted!
SSDT-6.aml succesfully extracted!
SSDT-1.aml succesfully extracted!
SSDT.aml succesfully extracted!
SSDT-3.aml succesfully extracted!
SSDT-8.aml succesfully extracted!
SSDT-5.aml succesfully extracted!
SSDT-7.aml succesfully extracted!
SSDT-2.aml succesfully extracted!
SSDT-9.aml succesfully extracted!
Found "Device (HDEF)" in DSDT.aml
Found "Device (HDAU)" in DSDT.aml
No property "layout-id" was found inside your ACPI tables, maybe injected in other way, looking in ioreg..
Found supported "layout-id = 5" in ioreg: be sure that respect your audio connectors
Found more than one "Device (HDAU/B0D3)" inside your ACPI tables. Please remove those excessive!

AppleHDA Patcher.app only supports (if patched by Mirone):
layout-id 2 for laptop's,
layout-id 5 for Desktop's with 3 connectors (pink, green and blue),
layout-id 7 for Desktop's with 5/6 connectors (gray, black, orange, pink, green and blue),
layout-id 9 for Desktop's with 5/6 connectors (gray, black, orange, pink, green, blue, CodecAddress:2)

aDummyHDA.kext works only is /System/Library/Extensions.
Laptop's may be need the provided ACPI Patch such system_IRQ.txt to be functional.
HDAEnabler.kext maybe usefull if you don't want to edit your ACPI table or the Clover's config,
or the org.Chameleon.Boot.plist.
CodecCommander.kext is usefull in the case you have no sound after waking from sleep.

Generated kexts should be installed in a proper way, repairing its permissions and rebuilding the cache:
dragging kexts into Pandora's Box.app window will help you to do that!
You do not have the required permissions to view the files attached to this post.
Locked

Return to “Apps”