Ajuda HD 5450 - Dell Optiplex 780

Ajuda HD 5450 - Dell Optiplex 780

Postby mricce » 15 Nov 2016, 20:08

Olá estou há alguns dias tentando fazer funcionar corretamente uma AMD Radeon HD 5450 (id=68f9) produzida pela PCYES, em um Dell Optiplex 780, não obtive sucesso, já tentei injetando id nas kexts, clover e dsdt, mas não obtive sucesso, um pouco de uso travamento do desktop, cursor do mouse ocasionalmente se move mas sem nenhum efeito no desktop, ai tenho de desligar pelo Power.

OSX Yosemite e El Capitan

Se alguém puder me ajudar agradeço muito

segue algumas informações e anexos com config.plis e hardware.txt


Code: Select all
  kextstat | grep AMD
   69    2 0xffffff7f81ff9000 0x126000   0x126000   com.apple.kext.AMDSupport (1.3.2) <68 67 12 11 7 5 4 3 1>
   70    0 0xffffff7f82707000 0x4d1000   0x4d1000   com.apple.kext.AMD5000Controller (1.3.2) <69 67 12 11 5 4 3 1>
   99    0 0xffffff7f826d0000 0x24000    0x24000    com.apple.kext.AMDFramebuffer (1.3.2) <69 67 12 11 7 5 4 3 1>


Code: Select all
 ioreg | grep ATY
    | |   |   | +-o ATY,ATY,RadeonFramebuffer@0  <class AtiFbStub, id 0x10000028f, registered, matched, active, busy 0 (61 ms), retain 8>
    | |   |   | | +-o ATY_ATY,RadeonFramebuffer  <class AMDFramebuffer, id 0x100000292, registered, matched, active, busy 0 (60 ms), retain 18>
    | |   |   | +-o ATY,ATY,RadeonFramebuffer@1  <class AtiFbStub, id 0x100000290, registered, matched, active, busy 0 (0 ms), retain 8>
    | |   |   | | +-o ATY_ATY,RadeonFramebuffer  <class AMDFramebuffer, id 0x100000298, registered, matched, active, busy 0 (0 ms), retain 14>
    | |   |   | +-o ATY,ATY,RadeonFramebuffer@2  <class AtiFbStub, id 0x100000291, registered, matched, active, busy 0 (0 ms), retain 8>
    | |   |   | | +-o ATY_ATY,RadeonFramebuffer  <class AMDFramebuffer, id 0x10000029e, registered, matched, active, busy 0 (0 ms), retain 14>
You do not have the required permissions to view the files attached to this post.
mricce
 
Posts: 2
Joined: 15 Nov 2016, 19:19
CPU: Intel Core 2 Duo E8400
Motherboard: 03NVJ6
GPU: PCYES HD 5450 1gb DDR3

Re: Ajuda HD 5450 - Dell Optiplex 780

Postby artur-pt » 15 Nov 2016, 21:50

olá

n tens a aceleradora carregada .. dai o lag e os travamentos

no clover tenta injectar para a gráfica fakeid 0x068E01008 .. tens de usar as kext originais .. sem modificações

viewtopic.php?f=2&t=716

https://clover-wiki.zetam.org/Configura ... ces_fakeid

68E0 é a unica presente nas kext das 5xxx series

bom hack
PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI
Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000
My OS X Files - join me at irc.freenode.net/##olarila
User avatar
artur-pt
Staff
 
Posts: 4961
Joined: 24 May 2011, 12:04

Re: Ajuda HD 5450 - Dell Optiplex 780

Postby mricce » 15 Nov 2016, 23:32

Artur obrigado, eu já tentei usar o fakeid, por sinal usando ele agora por meio da dstd, realmetente a kext AMDRadeonX3000.kext não estava carregada, eu estava dando boot pelo pendrive devido a black screen de um framebuffer, agora carregada.

ATI Radeon HD 5000:
Modelo do Grupo de Circuitos Integrados: ATI Radeon HD 5000
Tipo: GPU
Barramento: PCIe
Slot: Slot-1
Largura Lane PCIe: x16
VRAM (Total): 1024 MB
Fornecedor: ATI (0x1002)
ID do Dispositivo: 0x68e0
ID da Revisão: 0x0000
Versão do Driver EFI: 01.00.3180
Monitores:
Acer X183H:
Resolução: 1366 x 768 @ 60 Hz
Profundidade em Pixels: Cor de 32 Bits (ARGB8888)
Número de Série do Monitor: LEG080059803
Monitor Principal: Sim
Espelho: Desligado
On-line: Sim
Rotação: Compatível

Code: Select all
  kextstat | grep AMD
   68    2 0xffffff7f8200e000 0x126000   0x126000   com.apple.kext.AMDSupport (1.3.2) <67 66 12 11 7 5 4 3 1>
   69    0 0xffffff7f8271c000 0x4d1000   0x4d1000   com.apple.kext.AMD5000Controller (1.3.2) <68 66 12 11 5 4 3 1>
   71    0 0xffffff7f821bf000 0x453000   0x453000   com.apple.AMDRadeonX3000 (1.3.2) <70 66 12 7 5 4 3 1>
  101    0 0xffffff7f826e5000 0x24000    0x24000    com.apple.kext.AMDFramebuffer (1.3.2) <68 66 12 11 7 5 4 3 1>


Code: Select all
   ioreg | grep ATY
    | |   |   | +-o ATY,ATY,RadeonFramebuffer@0  <class AtiFbStub, id 0x100000293, registered, matched, active, busy 0 (6 ms), retain 8>
    | |   |   | | +-o ATY_ATY,RadeonFramebuffer  <class AMDFramebuffer, id 0x100000296, registered, matched, active, busy 0 (5 ms), retain 19>
    | |   |   | +-o ATY,ATY,RadeonFramebuffer@1  <class AtiFbStub, id 0x100000294, registered, matched, active, busy 0 (0 ms), retain 8>
    | |   |   | | +-o ATY_ATY,RadeonFramebuffer  <class AMDFramebuffer, id 0x10000029c, registered, matched, active, busy 0 (0 ms), retain 15>
    | |   |   | +-o ATY,ATY,RadeonFramebuffer@2  <class AtiFbStub, id 0x100000295, registered, matched, active, busy 0 (0 ms), retain 8>
    | |   |   | | +-o ATY_ATY,RadeonFramebuffer  <class AMDFramebuffer, id 0x1000002a2, registered, matched, active, busy 0 (0 ms), retain 15>


Creio que seja problema com framebuffer, apesar que ja devo ter testado todos da lista compativel com esta placa :| , não ha lag ou lentidão, porem acaba travando ou ficando toda borrada o desktop quando algo precisa realmente da controladora

Vou dar uma lida nos links que me passou, mais uma vez obrigado pela ajuda
You do not have the required permissions to view the files attached to this post.
mricce
 
Posts: 2
Joined: 15 Nov 2016, 19:19
CPU: Intel Core 2 Duo E8400
Motherboard: 03NVJ6
GPU: PCYES HD 5450 1gb DDR3

Re: Ajuda HD 5450 - Dell Optiplex 780

Postby amaraleb » 29 Nov 2016, 17:57

Também estou com problemas com essa mesma placa, a minha é uma XFX HD5450 id 68f9
O MAC inicia com resolução menor que a suportada pelo meu monitor. Quando coloco as kexts compatíveis com minha placa o MAC não inicia mais, trava na tela da maçã, quando a barra de progresso chega na metade.
tentei com as kexts originais e fakeid, também trava, outra sugestão que tentei foi a FB Eulemur.
Até então não obtive sucesso

Anteriormente eu tinha uma Powercolor HD5450, eu instalava o MAC, colocava as kexts (AMD5000Controller e AMDRadeonX3000) e funcionava perfeito.

Mas não tive a mesma sorte com a XFX

Grato se puder ajudar!
amaraleb
 
Posts: 3
Joined: 10 Aug 2016, 16:55
CPU: C2D E7500
Motherboard: IPM31
GPU: HD5450


Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests