Atualização 10.6.8

Re: Atualização 10.6.8

Postby Bauer » 31 Mar 2014, 16:13

Olá pessoal.

É o seguinte, estou com uma placa "bomba" aqui que já ví em alguns tutoriais via internet que o pessoal tem muita dificuldade em subir OS X, uma AsRock X58 Extreme.

O grande problema pelo que pude perceber em relação a essa placa é que ela só sobe em 32 bits e usa apenas um núcleo do processador.

Não sobe usando os métodos mais comuns, só consigo subir ela usando o CD do nawcon + 10.6.3.

Até aí, ok, minha intenção em relação a ela é desenvolver algum metodo de instalação para conseguir o suporte para x64 de modo que se possa instalar as versões posteriores e passar isso aqui no fórum para consultas futuras... mesmo que eu precise fazer uma "patch bios".

No momento, fiz uma instalação de 10.6.3 e fiz o upgrade para 10.6.8, substituí as kexts IOPCI e AppleACPCI para as versões de 10.6.7. O boot entra na tela do OS X, mas o USB não funciona agora...a flag usbbusfix=yes no boot não resolve (estou usando o nawcon ainda, pois outros bootloaders não funcionaram)

Em 10.6.3 eu peguei as configurações de sucesso do boot antes de atualizar para 10.6.8:

msr(204): platform_info 00011402
msr(207): flex_ratio 00000000
CPU: Vendor/Model/ExtModel: 0x756e6547/0x1a/0x1
CPU: Family/ExtFamily: 0x6/0x0
CPU: MaxCoef/CurrCoef: 0x0/0x14
CPU: MaxDiv/CurrDiv: 0x0/0x0
CPU: TSCFreq: 2666MHz
CPU: FSBFreq: 133MHz
CPU: CPUFreq: 2666MHz
CPU: NoCores/NoThreads: 8/16
CPU: Features: 0x000002ff
Failed to find boot signature on BIOS device efh
Read HFS+ file: [en(15,0)/Extra/com.apple.Boot.plist] 369 bytes.
Read HFS+ file: [en(15,0)/Extra/Preboot.dmg] 73093120 bytes.

reading ramdisk image: bt(0,0)/Extra/Preboot.dmgAttempting to read GPT
Read GPT
Reading GPT partition 1, type 48465300-0000-11AA-AA11-00306543ECAC
Read HFS+ file: [rd(0,1)/RAMDisk.plist] 229 bytes.

mounting: done
Read HFS+ file: [en(15,0)/Extra/Themes/Default/theme.plist] 2701 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/background.png] 143539 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/logo.png] 37739 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/device_generic.png] 12713 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/device_hfsplus.png] 10950 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/device_ext3.png] 12591 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/device_fat16.png] 13605 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/device_fat32.png] 12713 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/device_ntfs.png] 14905 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/device_cdrom.png] 13605 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/device_selection.png] 899 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/device_scroll_prev.png] 271 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/device_scroll_next.png] 268 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/menu_boot.png] 1747 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/menu_verbose.png] 4116 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/menu_ignore_caches.png] 4051 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/menu_single_user.png] 4114 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/menu_memory_info.png] 1634 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/menu_video_info.png] 997 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/menu_help.png] 1677 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/menu_verbose_disabled.png] 1460 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/menu_ignore_caches_disabled.png] 1441 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/menu_single_user_disabled.png] 1444 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/menu_selection.png] 323 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/progress_bar.png] 372 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/progress_bar_background.png] 233 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/text_scroll_prev.png] 353 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/text_scroll_next.png] 355 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/font_console.png] 3499 bytes.
Read HFS+ file: [en(15,0)/Extra/Themes/Default/font_small.png] 6244 bytes.
Read HFS+ file: [rd(0,1)/Extra/com.apple.Boot.plist] 628 bytes.
Setting boot-uuid to: 1DA1FFB0-B518-30D8-B0A3-D20CFA01A947
Read HFS+ file: [hd(0,1)/System/Library/CoreServices/SystemVersion.plist] 479 bytes.
Loading Darwin 10.6
Loading kernel rd(0,0)/Extra/legacy_kernel
Read HFS+ file: [rd(0,1)/Extra/legacy_kernel] 4096 bytes.
Read HFS+ file: [rd(0,1)/Extra/legacy_kernel] 7437296 bytes.
LoadDrivers: Loading from [rd(0,0)/Extra/Extensions.mkext]
Read HFS+ file: [rd(0,1)/Extra/Extensions.mkext] 4096 bytes.
Read HFS+ file: [rd(0,1)/Extra/Extensions.mkext] 1041630 bytes.
LoadDrivers: Loading from [/Extra/Extensions.mkext]
Read HFS+ file: [hd(0,1)/Extra/Extensions.mkext] 4096 bytes.
Read HFS+ file: [hd(0,1)/Extra/Extensions.mkext] 292698 bytes.
LoadDrivers: Loading from [/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext]
Read HFS+ file: [hd(0,1)/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext] 4096 bytes.
Read HFS+ file: [hd(0,1)/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext] 4860863 bytes.
ACPI table not found: DSDT.aml
No DSDT found, using 0 as uid value.
Using PCI-Root-UID value: 0
Read HFS+ file: [rd(0,1)/Extra/smbios.plist] 421 bytes.
Intel NHM IMC DRAM Controller [8086:3405] at 00:00.0
Frequency detected: 666 MHz (1333) Triple Channel
CAS:9 tRC:9 tRP:9 RAS:24 (9-9-9-24)
Slot: 0 Type 24 2048MB (DDR3 SDRAM) 1333MHz Vendor=Kingston
PartNo=99P5458-001.A00LF SerialNo=7504B76D
Slot: 2 Type 24 2048MB (DDR3 SDRAM) 1333MHz Vendor=Kingston
PartNo=99P5458-001.A00LF SerialNo=913FBE7B
Slot: 4 Type 24 2048MB (DDR3 SDRAM) 1333MHz Vendor=Kingston
PartNo=99U5458-001.A00LF SerialNo=762A34B9
CPU is Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz, family 0x6, model 0x1a
Patched DMI Table
Found SMBIOS System Information Table 1
Customizing SystemID with : 00020003-0004-0005-0006-000700080009
efi_inject_get_devprop_string NULL trying stringdata
ACPI table not found: rd(0,0)/Extra/DSDT.aml
ACPI table not found: SSDT.aml
FADT: Restart Fix applied!
Starting Darwin x86
Press any key to continue...UHCI controller [8086:3a37] at 00:1a.0 base 520(a401)
UHCI controller [8086:3a38] at 00:1a.1 base 524(a481)
UHCI controller [8086:3a39] at 00:1a.2 base 540(a801)
EHCI controller [8086:3a3c] at 00:1a.7 DMA @f9cf8000
Setting Legacy USB Off on controller [8086:3a3c] at 00:1a.7
Legacy USB Off Done
UHCI controller [8086:3a34] at 00:1d.0 base 544(a881)
UHCI controller [8086:3a35] at 00:1d.1 base 560(ac01)
UHCI controller [8086:3a36] at 00:1d.2 base 580(b001)
EHCI controller [8086:3a3a] at 00:1d.7 DMA @f9cfa000
Setting Legacy USB Off on controller [8086:3a3a] at 00:1d.7
Legacy USB Off Done


A patch que está no forum corrige algo referente a esses bug de 32 bits e CPU com 01 core?

alguma outra opção que possa primeiramente fazer o USB funcionar?

obrigado pessoal.
ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE
X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA
User avatar
Bauer
Veteran
 
Posts: 547
Joined: 01 Feb 2012, 17:22
Location: S.P Brazil
CPU: i7-740QM Quad Core 6mb
Motherboard: Toshiba Satellite P500
GPU: GT330M GDDR3 1024GB 128bit

Re: Atualização 10.6.8

Postby pernacabeluda » 31 Mar 2014, 16:27

Seria interessante você postar fotos da tela no boot sem arch=i386 e sem cpus=1.

Aparentemente o boot do nawcom faz o USBLegacyOff por padrão, ou tem essa opção ativada em sua configuração

http://forge.voodooprojects.org/p/chameleon/source/tree/2261/trunk/doc/BootHelp.txt#L111

Legacy USB Off Done
User avatar
pernacabeluda
Senior
 
Posts: 4719
Joined: 22 Oct 2012, 02:35

Re: Atualização 10.6.8

Postby Bauer » 31 Mar 2014, 16:40

Olá Perna

Usando o chameleon ou clover comuns aqui do fórum, e até outras opções que testei fora como Unibeast ou MyHack no momento que se escolhe o S.O ocorre um reinicio, não chega a lugar nenhum exceto até a parte de ler as kexts do sistema usando por exemplo -x -v. Creio que isso se deva justamente ao boot em 64bits onde ocorre o problema.

Já usando o nawcon como opção, pós escolher o Snow instalado no HD, ele por sí só detecta essas configurações de funcionamento em 32bits e 01 core... daí a suspeita do problema ser algo relacionado ao modo de funcionamento em 64 bits. Realmente a questão do USB procede pois no 10.6.3 funciona normalmente... mas pós a atualização, a tela do Snow entra, porem sem suporte ao usb!
ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE
X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA
User avatar
Bauer
Veteran
 
Posts: 547
Joined: 01 Feb 2012, 17:22
Location: S.P Brazil
CPU: i7-740QM Quad Core 6mb
Motherboard: Toshiba Satellite P500
GPU: GT330M GDDR3 1024GB 128bit

Re: Atualização 10.6.8

Postby pernacabeluda » 31 Mar 2014, 17:02

Sobre o USB talvez seja o caso de fazer "rollback" das kexts IOUSBFamily e IOUSBMassStorageClass para a versão 10.6.3 até encontrar solução melhor.

O patch DSDT que você citou contém este para cpus=1, porém o sintoma relatado no tópico é outro, então o problema pode ser diferente

http://olarila.com/forum/viewtopic.php?f=7&t=55

Em alguns casos o problema é causado por erro de "TSC sync", o que pode ser resolvido com esta kext

http://forge.voodooprojects.org/p/voodootscsync/
User avatar
pernacabeluda
Senior
 
Posts: 4719
Joined: 22 Oct 2012, 02:35

Re: Atualização 10.6.8

Postby Bauer » 02 Apr 2014, 05:50

Opa, obrigado pela dica. Instalei essa kext.

Eu fiz progressos , fui para outros caminhos fora o Nawcon para conseguir ...

Primeiro : Coloquei o HD em outro computador, fiz as partições e já deixei o Mountain Lion 10.8.5 pré instalado numa delas, pois o meu objetivo é saber porque o boot não ocorre a partir de M.L pelo que é relatado nas minhas pesquisas com essa a placa, eu também nunca consegui fazer o bootloader pós 10.8 entrar... o máximo que havia conseguido até então era instalar o 10.6.3. Aproveitei para já instalar o Chameleon ultima versão R2377.

Depois, entrei na bios e desmarquei tudo que era possível de automático...as opções que tinham configurações fixadas ocultas foram marcadas, exemplo barramento correto do processador = 4.8 GT/s... em automático estava entrando como 6.4GT/s

Instalei o 10.6.3 na partição 01, fazendo boot dessa vez com o hackboot versão Lion e nativamente o boot ocorreu em 64bits...é quase um milagre rs

Nativamente pelo CD do hackboot sem nenhuma flag o boot entrou como Mac Mini 1.1

Aproveitei para criar a pasta Extra e configurar o chameleon.boot.Plist e o smbios.Plist ficou como Mac pro 4.1. Coloquei as kexts FakeSMC.kext e IOHCIBlockStorageinjector.Kext nela... usei as kexts da pasta Extra da época dos tópicos do Lion aqui do forum.

Por precaução, deixei com 1 core na bios de inicio para não ter surpresas e iniciei o processo como 32 bits através do .boot.plist.

Como VGA para o teste, GT8500 nvidia

Fiz o upgrade para 10.6.8, pós reinicio entrou normalmente ainda usando o hackboot (nem tentei usar o chameleon de inicio)

Depois disso , retirei a entrada de 32 bits do .boot.plist, reiniciei o computador , entrei na bios e ativei os cores que estavam ocultos, e entrou com todos os cores configurados.

Instalei então o pacote de drivers 10.6.8 Nvidia, e com graphics enabler a GT8500 foi ativada.

system.png


Demorei 2 dias para chegar nesse resultado, descrevendo parece que foram 10 minutos... para o pessoal ver que esse negócio é chato e requer paciência.

Bom, agora com o Snow Leopard instalado, vem a etapa que interessa , tentar fazer funcionar o Mountain Lion testando configurações baseadas no sucesso da instalação ou tentar outras alternativas...

Obrigado
You do not have the required permissions to view the files attached to this post.
ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE
X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA
User avatar
Bauer
Veteran
 
Posts: 547
Joined: 01 Feb 2012, 17:22
Location: S.P Brazil
CPU: i7-740QM Quad Core 6mb
Motherboard: Toshiba Satellite P500
GPU: GT330M GDDR3 1024GB 128bit

Re: Atualização 10.6.8

Postby Bauer » 04 Apr 2014, 06:13

Olá

Mistério resolvido, o grande vilão da instalação era isso:

DSCN0043.JPG


Não havia me atentado a esse detalhe, só quando fui olhar mais a fundo item por item da bios que , ao mudar essa opção o problema de reboot pós escolher o bootloader parou de ocorrer...

Depois de deixar como habilitado, instalei o Snow, M.L e Maverics sem qualquer problema.

Obrigado Perna!
You do not have the required permissions to view the files attached to this post.
ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE
X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA
User avatar
Bauer
Veteran
 
Posts: 547
Joined: 01 Feb 2012, 17:22
Location: S.P Brazil
CPU: i7-740QM Quad Core 6mb
Motherboard: Toshiba Satellite P500
GPU: GT330M GDDR3 1024GB 128bit

Re: Atualização 10.6.8

Postby pernacabeluda » 04 Apr 2014, 13:49

É apenas mais um nome para a opção citada neste tópico

http://olarila.com/forum/viewtopic.php?f=2&t=1804

Execute Disable Bit (NX bit, XD bit)


http://pt.wikipedia.org/wiki/Bit_NX
User avatar
pernacabeluda
Senior
 
Posts: 4719
Joined: 22 Oct 2012, 02:35

Re: Atualização 10.6.8

Postby Bauer » 04 Apr 2014, 14:43

Exato, eu lembrei desse tópico exatamente pelo "XD" citado se não fosse esse detalhe me passaria despercebido.
ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE
X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA
User avatar
Bauer
Veteran
 
Posts: 547
Joined: 01 Feb 2012, 17:22
Location: S.P Brazil
CPU: i7-740QM Quad Core 6mb
Motherboard: Toshiba Satellite P500
GPU: GT330M GDDR3 1024GB 128bit

Re: Atualização 10.6.8

Postby muricaum » 09 Apr 2015, 02:34

Galera,
seguinte
Eu tenho um toshiba nb305, intel atom n450 e a placa 3150.
Instalei 10.6 ok. Quando atualizo para 10.6.8 caia num boot loop. Achei esse topico de vcs, usei a patched kernel citada para atom e aí nao fico mais no boot loop, mas fico preso na tela de inicio (cinza com a maça mas sem a rodinha embaixo). Com esse aqui http://www.insanelymac.com/forum/topic/ ... y-meklort/ a resolução muda, mas ainda fico preso na mesma tela e no topo da tela aparecem tipo " " " " " " " ao longo da tela toda.
Alguem tem alguma ideia?

Obs: para fazer o boot e conseguir instalar o mac osx precisei utilizar esse método: http://www.macbreaker.com/2013/07/chame ... ndows.html, e é o mesmo boot que uso pra entrar no mac. já cheguei até instalar no mac (sem utilizar usb) mas como precisei re instalar varias vezes para as tentativas esotu deixando no usb mesmo por enquanto.
muricaum
 
Posts: 1
Joined: 09 Apr 2015, 01:53
CPU: dont know
Motherboard: d know
GPU: n sei

Re: Atualização 10.6.8

Postby Bauer » 09 Apr 2015, 03:51

Tente usar o clover usando o fake CPUID

http://www.insanelymac.com/forum/topic/ ... try2036384
ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE
X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA
User avatar
Bauer
Veteran
 
Posts: 547
Joined: 01 Feb 2012, 17:22
Location: S.P Brazil
CPU: i7-740QM Quad Core 6mb
Motherboard: Toshiba Satellite P500
GPU: GT330M GDDR3 1024GB 128bit

Previous

Return to Snow Leopard (10.6)

Who is online

Users browsing this forum: Bing [Bot] and 1 guest