Ajuda com GA B150M Gaming 3 - Kaby Lake-S

Ajuda com GA B150M Gaming 3 - Kaby Lake-S

Postby Neo0001 » 06 Aug 2017, 05:52

Olá pessoal!

Como montei meu hackintosh (acho que perfeitamente, funciona há quase 2 anos) na minha GA-Z97MX-Gaming 5, quis ajudar dois amigos fotógrafos a montar os seus. Porééééém não ta rolando, e pelo que li o problema esta no processador Kaby Lake.

Eu achei que extraindo o SSDT no windows e convertendo eu usaria no boot pra instalar, mas vi que também não é assim.

Então se puderem me ajudar com essa mobo, não só fico agradecido como quero fornecer DSDT da mesma e o que for preciso pq provavelmente terão outras pessoas com o mesmo problema.

Segue config e imagens com mais infos sobre a maquina.

• i5 7400 Kaby Lake-S LG 1151
• Gigabyte GA-B150M-Gaming 3 (chipset B150)
• Gigabyte GTX 1050 Ti
• 16Gb de RAM
• SSD 120Gb (Para o windows 10 pros games)
• SSD 250Gb (MacOS para trabalho)
• HD 500Gb para arquivos pessoais
• HD 500Gb para os jogos no windows

Sigo lendo sobre e desde já agradeço a ajuda.

cpuid.png

cachemem.png

gpgpu.png
You do not have the required permissions to view the files attached to this post.
Neo0001
 
Posts: 5
Joined: 06 Aug 2017, 05:24
CPU: Intel Core i5-4460 3.2GHz
Motherboard: GA-Z97MX-Gaming 5 LGA 1150
GPU: Zotac Geforce GTX970 4GB GDDR

Re: Ajuda com GA B150M Gaming 3 - Kaby Lake-S

Postby pernacabeluda » 06 Aug 2017, 20:35

Se a versão do instalador for anterior a 10.12.6 não tem suporte a Kaby Lake, você tem que usar a opção FakeCPUID do Clover (dentro de binaries patching) com o ID do Skylake (0x0506E3)
https://clover-wiki.zetam.org/Configura ... _fakecpuid
User avatar
pernacabeluda
Senior
 
Posts: 4687
Joined: 22 Oct 2012, 02:35

Re: Ajuda com GA B150M Gaming 3 - Kaby Lake-S

Postby Neo0001 » 07 Aug 2017, 13:44

pernacabeluda wrote:Se a versão do instalador for anterior a 10.12.6 não tem suporte a Kaby Lake, você tem que usar a opção FakeCPUID do Clover (dentro de binaries patching) com o ID do Skylake (0x0506E3)
https://clover-wiki.zetam.org/Configura ... _fakecpuid


Isso ja fez muita diferença hehehe

Vou refazer o download do Sierra aqui no meu hack, certamente vem atualizado, e vou recriar o pen.
Neo0001
 
Posts: 5
Joined: 06 Aug 2017, 05:24
CPU: Intel Core i5-4460 3.2GHz
Motherboard: GA-Z97MX-Gaming 5 LGA 1150
GPU: Zotac Geforce GTX970 4GB GDDR

Re: Ajuda com GA B150M Gaming 3 - Kaby Lake-S

Postby Neo0001 » 08 Aug 2017, 05:15

Consegui instalar! Que alívio. Mas ainda não ta 100%

[OK] Rede: Intel® GbE LAN - Usei a IntelMausiEthernet v2.2.1.d1
[OK] Memórias: ok
[OK] Processador: ok

[ X ] Realtek® ALC892 codec - Escolhi o mesmo no multibeast, nao reconheceu nada
[ X ] GTX 1050Ti - Apesar de instalar os drives, qdo reinicio nao fica no "nvidia web drive" e mostra "Display 7MB"
[ X ] O ssd do windows nao inicia pelo clover
Neo0001
 
Posts: 5
Joined: 06 Aug 2017, 05:24
CPU: Intel Core i5-4460 3.2GHz
Motherboard: GA-Z97MX-Gaming 5 LGA 1150
GPU: Zotac Geforce GTX970 4GB GDDR

Re: Ajuda com GA B150M Gaming 3 - Kaby Lake-S

Postby pernacabeluda » 08 Aug 2017, 14:27

Áudio tem suporte na AppleALC
https://github.com/vit9696/AppleALC

Pode injetar o layout ID pelo Clover
https://clover-wiki.zetam.org/Configura ... dio-inject

Usa um dos valores indicados na wiki
https://github.com/vit9696/AppleALC/wik ... ted-codecs

nVidia tem que ativar NvidiaWeb em SystemParameters
https://clover-wiki.zetam.org/Configura ... _nvidiaweb

O Windows pelo Clover acredito que só se for instalado no modo UEFI (GPT).
User avatar
pernacabeluda
Senior
 
Posts: 4687
Joined: 22 Oct 2012, 02:35

Re: Ajuda com GA B150M Gaming 3 - Kaby Lake-S

Postby Neo0001 » 12 Aug 2017, 06:29

pernacabeluda wrote:Áudio tem suporte na AppleALC
https://github.com/vit9696/AppleALC

Pode injetar o layout ID pelo Clover
https://clover-wiki.zetam.org/Configura ... dio-inject

Usa um dos valores indicados na wiki
https://github.com/vit9696/AppleALC/wik ... ted-codecs

nVidia tem que ativar NvidiaWeb em SystemParameters
https://clover-wiki.zetam.org/Configura ... _nvidiaweb

O Windows pelo Clover acredito que só se for instalado no modo UEFI (GPT).



Cara, tentei e nada deu certo, foi frustrante hehehe.

Eu peguei o kext do AppleALC na propria pagina, instalei, nada.

Fiz o inject e não apareceu, acho que fiz errado, os parâmetros eu não soube onde colocar. Pelo menos aprendi sobre o ResetHDA e consertei o meu audio hehehe

Apesar de ligar o NvidiaWeb, segue indo pro drive default.

Quanto ao windows, estranhei, pq instalei ele primeiro no meu hack, depois o macOS e tudo ok e identificado.

Vou anexar meu config pra ti dar uma olhada, pode ser? to usando o clover configurator.
config.plist.zip


[EDIT]

GA-GTX 1050Ti
Depois de tentar o procedimento 'problem 6' deste Link do Tonymac.

Resultou em tela preta e não resolveu e tive que tirar o EmuVariableUefi-64

Tentei os kext Lilu e NvidiaGraphicsFixup, sem resultado

Audio
Usei o ALC892 e fix 100/200 do multicast, nada pro audio tb

Ajudaria eu extrait o DSDT do hack?
You do not have the required permissions to view the files attached to this post.
Neo0001
 
Posts: 5
Joined: 06 Aug 2017, 05:24
CPU: Intel Core i5-4460 3.2GHz
Motherboard: GA-Z97MX-Gaming 5 LGA 1150
GPU: Zotac Geforce GTX970 4GB GDDR

Re: Ajuda com GA B150M Gaming 3 - Kaby Lake-S

Postby Neo0001 » 13 Aug 2017, 07:23

Gigabyte GTX 1050Ti e Áudio- SUCESSO [Edit]

1050Ti
O principal problema das falhas de instalação da GTX eram o cabo, use um cabo DVI, pq a porta DVI é a primária, senão não funciona.

Após instalar os drives da Nvidia, segui estas configurações:

Essencial opção multibeast do clover UEFI + Emulated NVRAM, isso instala o EmuVariableUefi-64 que auxilia no reconhecimento da placa
Se ja tiver com o clover instalado, so habilitar o EmuVariableUefi-64 pelo clover configurator
boot: uncheck nvda_drv=1 e nv_disable=1
System Parameters: check NvidiaWeb

Meu SMBIOS é 18,1

Áudio ALC892
Usei a opção 100/200 series audio + a ALC892
Não tinha dado certo antes, mas agora deu.
Neo0001
 
Posts: 5
Joined: 06 Aug 2017, 05:24
CPU: Intel Core i5-4460 3.2GHz
Motherboard: GA-Z97MX-Gaming 5 LGA 1150
GPU: Zotac Geforce GTX970 4GB GDDR


Return to Sierra (10.12)

Who is online

Users browsing this forum: No registered users and 1 guest