-->Donations via PayPal [External Link Removed for Guests] :guitar
-->Installation/Post Installation Tutorial [Local Link Removed for Guests]
-->Useful Links [Local Link Removed for Guests]
-->Olarila Images - Updated images [Local Link Removed for Guests]
-->Guides and Tutorials [Local Link Removed for Guests]
-->Clover Folder for All Chipsets [Local Link Removed for Guests]
-->DSDT Patch Requests [Local Link Removed for Guests]

VoodooHDA - problemas comuns

User avatar
Cassio
Olarila Staff
Olarila Staff
Posts: 3765
Joined: 26 Aug 2011, 22:53

Re: VoodooHDA - problemas comuns

Post by Cassio » 24 Jan 2012, 01:13

Em alguns casos é necessário editar as kexts de vídeo da ATI pro áudio HDMI funcionar
[External Link Removed for Guests]
ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: [External Link Removed for Guests] • Linux Mint 15 • Windows 8
Chancer
Posts: 53
Joined: 13 Jan 2012, 21:17

Re: VoodooHDA - problemas comuns

Post by Chancer » 24 Jan 2012, 03:34

Putz... eu comecei a ler as primeiras páginas, mas ler as 30 não rola no momento.
Entendi bastante coisa, mas ainda tenho dúvidas. Postei uma mensagem lá pra ver se descubro como resolver. Alguém daqui tem experiência nesse método?
Dell Optiplex 755 (BIOS A21) - Core2Quad Q6600 - 4 GB RAM - ATI 4850 HD
Audio Intel 82801I (ICH9) - Rede 82566DM-2 - Chipset Intel 82Q35 Express
failer
Posts: 37
Joined: 21 Jan 2012, 18:31

Re: VoodooHDA - problemas comuns

Post by failer » 24 Jan 2012, 19:41

Boas, já fiz tudo o que postaram, tanto no post principal como nos comments, e continuo com o som estranho, chiado . Como posso resolver ? :c Eu vi num forum qualquer ingles que usavam a AppleHDA, será que dá? E como a configuro?
Meu computador
Intel® Core™ i5-2410M , 6GB RAM, 500GB HD, NVIDIA® GeForce® GT 525M com Tecnologia CUDA™, resolução : 1,366 x 768
Chancer
Posts: 53
Joined: 13 Jan 2012, 21:17

Re: VoodooHDA - problemas comuns

Post by Chancer » 24 Jan 2012, 20:07

Tenta aqui: [Local Link Removed for Guests]
Dell Optiplex 755 (BIOS A21) - Core2Quad Q6600 - 4 GB RAM - ATI 4850 HD
Audio Intel 82801I (ICH9) - Rede 82566DM-2 - Chipset Intel 82Q35 Express
failer
Posts: 37
Joined: 21 Jan 2012, 18:31

Re: VoodooHDA - problemas comuns

Post by failer » 26 Jan 2012, 19:22

por enquanto tenho o snow leopard :c
Meu computador
Intel® Core™ i5-2410M , 6GB RAM, 500GB HD, NVIDIA® GeForce® GT 525M com Tecnologia CUDA™, resolução : 1,366 x 768
User avatar
Cassio
Olarila Staff
Olarila Staff
Posts: 3765
Joined: 26 Aug 2011, 22:53

Re: VoodooHDA - problemas comuns

Post by Cassio » 26 Jan 2012, 19:25

Procure uma AppleHDA editada pro seu codec.

Editar do zero é bem complicado
[External Link Removed for Guests]
ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: [External Link Removed for Guests] • Linux Mint 15 • Windows 8
failer
Posts: 37
Joined: 21 Jan 2012, 18:31

Re: VoodooHDA - problemas comuns

Post by failer » 26 Jan 2012, 19:34

Aonde posso arranjar? no kexts.com nao encontro, o id da minha é 1c20.
Meu computador
Intel® Core™ i5-2410M , 6GB RAM, 500GB HD, NVIDIA® GeForce® GT 525M com Tecnologia CUDA™, resolução : 1,366 x 768
User avatar
Cassio
Olarila Staff
Olarila Staff
Posts: 3765
Joined: 26 Aug 2011, 22:53

Re: VoodooHDA - problemas comuns

Post by Cassio » 26 Jan 2012, 19:37

Não procure pelo ID PCI, mas pelo codec de áudio. Se não sabe qual é, use o getDump da VoodooHDA pra descobrir, ou veja pelo Windows com o Aida.
ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: [External Link Removed for Guests] • Linux Mint 15 • Windows 8
buccan
Posts: 1
Joined: 10 Feb 2012, 04:41

Re: VoodooHDA - problemas comuns

Post by buccan » 11 Feb 2012, 03:27

hey, tenho um o slow leopard em meu portatil insys que têm a realteck high definition audio alc662 como placa de som, o portatil tem tambem hdmi, neste momento tenho o som a funcionar sem voodooHDA mas o mic nao funciona, gostaria de instalar voodooHDA para revolver esse problema, qe kexts tenho de remover para colocar o voodoo a funcionar com colunas e mic?

obrigado
User avatar
Cassio
Olarila Staff
Olarila Staff
Posts: 3765
Joined: 26 Aug 2011, 22:53

Re: VoodooHDA - problemas comuns

Post by Cassio » 11 Feb 2012, 03:41

Tem que ver qual kext de áudio tá usando, rode kextstat no terminal. Se não é VoodooHDA deve ser AppleHDA ou AppleAzaliaAudio.
ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: [External Link Removed for Guests] • Linux Mint 15 • Windows 8
Predatux
Posts: 38
Joined: 10 Feb 2012, 13:35

Re: VoodooHDA - problemas comuns

Post by Predatux » 27 Feb 2012, 16:52

Hola, tengo un problema con mi tarjeta de sonido ALC663.
Tengo instalada la ultima versión de VoodooHDA + DSDT
Tengo sonido por HDMI, auriculares y micrófono, pero no tengo sonido de los altavoces del portátil.
He modificado el kext con la ID y no hay cambios. Lo raro es que el sistema reconoce 2 ATAPI Speaker's. El primero de ellos no suena, pero es configurable. El último no es configurable.

Adjunto fotos, a ver si alguien arroja un poco de luz al problema.
Lo raro es que la salida HDMI funcione y no lo hagan los altavoces ;)
[External Link Removed for Guests]

Y como curiosidad, en el sobremesa me ha surgido un problema con el audio... he bajado en MIDI a 48000 para poder tener sonido. Lo que pasa es que cuando reinicio el ordenador, se pone de nuevo por defecto a 192000, quedándome sin sonido hasta que lo cambio de nuevo. Que archivo tengo que editar para dejarlo "fijo" a 48000 en Lion?

Un saludo
ASUS N71JQ
Intel Core i7 720QM
4GB Ram
Ati Mobility Radeon 5730 1 GB Vram.
ALC663
Atheros 8131
Atheros 9285

P5KPL/EPU
Intel Core2 Quad 2,40
Nvidia 9600GT 512
User avatar
Cassio
Olarila Staff
Olarila Staff
Posts: 3765
Joined: 26 Aug 2011, 22:53

Re: VoodooHDA - problemas comuns

Post by Cassio » 27 Feb 2012, 17:20

Poste a saída do getDump.

Para usar os speakers você tem que especificar o ID do áudio ALC no Info.plist, não o do HDMI.
ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: [External Link Removed for Guests] • Linux Mint 15 • Windows 8
Predatux
Posts: 38
Joined: 10 Feb 2012, 13:35

Re: VoodooHDA - problemas comuns

Post by Predatux » 27 Feb 2012, 18:04

[External Link Removed for Guests]

No se cual es el problema... adjunto también mi archivo VoodooHDA por si sirve de ayuda.

Mil gracias
ASUS N71JQ
Intel Core i7 720QM
4GB Ram
Ati Mobility Radeon 5730 1 GB Vram.
ALC663
Atheros 8131
Atheros 9285

P5KPL/EPU
Intel Core2 Quad 2,40
Nvidia 9600GT 512
User avatar
Cassio
Olarila Staff
Olarila Staff
Posts: 3765
Joined: 26 Aug 2011, 22:53

Re: VoodooHDA - problemas comuns

Post by Cassio » 27 Feb 2012, 18:48

O node 20 (speaker) deveria funcionar quando o 33 (headphones) não está conectado

Code: [Local Link Removed for Guests]

nid 20 0x99130110 as  1 seq  0       Speaker Fixed jack  3 loc 25 color Unknown misc 1
nid 23 0x99130150 as  5 seq  0       Speaker Fixed jack  3 loc 25 color Unknown misc 1
nid 24 0x99a30940 as  4 seq  0    Microphone Fixed jack  3 loc 25 color Unknown misc 9
nid 25 0x01a19c4f as  4 seq 15    Microphone  Jack jack  1 loc  1 color    Pink misc 12
nid 27 0x01214020 as  2 seq  0    Headphones  Jack jack  1 loc  1 color   Green misc 0
nid 30 0x99430130 as  3 seq  0     SPDIF-out Fixed jack  3 loc 25 color Unknown misc 1
nid 33 0x0121401f as  1 seq 15    Headphones  Jack jack  1 loc  1 color   Green misc 0
Tente botar todos os nodes com default association exclusivo

Code: [Local Link Removed for Guests]

nid 25 0x01a19c60
nid 33 0x01214070
Você tem que remover os NodesToPatch de exemplo e especificar o ID do áudio ALC no Info.plist (IOPCIClassMatch).
ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: [External Link Removed for Guests] • Linux Mint 15 • Windows 8
Predatux
Posts: 38
Joined: 10 Feb 2012, 13:35

Re: VoodooHDA - problemas comuns

Post by Predatux » 27 Feb 2012, 22:55

Gracias por la respuesta.
Veamos, he parcheado el archivo info.plist con lo siguiente:

<key>IOPCIPrimaryMatch</key>
<string>0x3b568086</string>

Pero la primera parte que me has dicho no la he entendido bien. Donde se supone que he de eliminar lo que me dices?
En info.plist no está esa información.

Esto no se como hacerlo:
Tente botar todos os nodes com default association exclusivo
Code:
nid 25 0x01a19c60
nid 33 0x01214070

Gracias de nuevo.
ASUS N71JQ
Intel Core i7 720QM
4GB Ram
Ati Mobility Radeon 5730 1 GB Vram.
ALC663
Atheros 8131
Atheros 9285

P5KPL/EPU
Intel Core2 Quad 2,40
Nvidia 9600GT 512
User avatar
Cassio
Olarila Staff
Olarila Staff
Posts: 3765
Joined: 26 Aug 2011, 22:53

Re: VoodooHDA - problemas comuns

Post by Cassio » 27 Feb 2012, 22:59

Code: [Local Link Removed for Guests]

<key>NodesToPatch</key>
<array>
   <dict>
      <key>Codec</key>
      <integer>0</integer>
      <key>Config</key>
      <string>0x01a19c60</string>
      <key>Node</key>
      <integer>25</integer>
   </dict>
   <dict>
      <key>Codec</key>
      <integer>0</integer>
      <key>Config</key>
      <string>0x01214070</string>
      <key>Node</key>
      <integer>33</integer>
   </dict>
</array>
ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: [External Link Removed for Guests] • Linux Mint 15 • Windows 8
Predatux
Posts: 38
Joined: 10 Feb 2012, 13:35

Re: VoodooHDA - problemas comuns

Post by Predatux » 27 Feb 2012, 23:32

He adjuntado lo que me has pasado al info.plist. Me ha quedado así:

Code: [Local Link Removed for Guests]

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>CFBundleDevelopmentRegion</key>
	<string>English</string>
	<key>CFBundleExecutable</key>
	<string>VoodooHDA</string>
	<key>CFBundleIdentifier</key>
	<string>org.voodoo.driver.VoodooHDA</string>
	<key>CFBundleInfoDictionaryVersion</key>
	<string>6.0</string>
	<key>CFBundleName</key>
	<string>VoodooHDA</string>
	<key>CFBundlePackageType</key>
	<string>KEXT</string>
	<key>CFBundleShortVersionString</key>
	<string>2.7.2</string>
	<key>CFBundleSignature</key>
	<string>????</string>
	<key>CFBundleVersion</key>
	<string>2.7.2</string>
	<key>IOKitPersonalities</key>
	<dict>
		<key>VoodooHDA</key>
		<dict>
			<key>CFBundleIdentifier</key>
			<string>org.voodoo.driver.VoodooHDA</string>
			<key>IOClass</key>
			<string>VoodooHDADevice</string>
			<key>IOMatchCategory</key>
			<string>VoodooHDADevice</string>
			<key>IOPCIPrimaryMatch</key>
			<string>0x3b568086</string>
			<key>IOProviderClass</key>
			<string>IOPCIDevice</string>
			<key>IOUserClientClass</key>
			<string>VoodooHDAUserClient</string>
			<key>InhibitCache</key>
			<true/>
			<key>MixerValues</key>
			<dict>
				<key>iGain</key>
				<string>90</string>
				<key>iMix</key>
				<string>0</string>
			</dict>
			<key>NodesToPatch</key>
			<array>
				<dict>
					<key>Codec</key>
					<integer>2</integer>
					<key>Config</key>
					<string>0x90a70120</string>
					<key>Node</key>
					<integer>12</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>2</integer>
					<key>Config</key>
					<string>0x02a1102f</string>
					<key>Node</key>
					<integer>14</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>2</integer>
					<key>Config</key>
					<string>0x90a6e140</string>
					<key>Node</key>
					<integer>19</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>2</integer>
					<key>Config</key>
					<string>0x02011030</string>
					<key>Node</key>
					<integer>15</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>2</integer>
					<key>Config</key>
					<string>0x02211050</string>
					<key>Node</key>
					<integer>10</integer>
					<key>DAC</key>
					<string>3</string>
				</dict>
			</array>
			<key>Noise</key>
			<integer>2</integer>
			<key>Vectorize</key>
			<false/>
			<key>VoodooHDAEnableHalfVolumeFix</key>
			<false/>
			<key>VoodooHDAEnableVolumeChangeFix</key>
			<false/>
			<key>VoodooHDAVerboseLevel</key>
			<integer>0</integer>
		</dict>
	</dict>
	<key>OSBundleLibraries</key>
	<dict>
		<key>com.apple.iokit.IOAudioFamily</key>
		<string>1.1fc9</string>
		<key>com.apple.iokit.IOPCIFamily</key>
		<string>2.1</string>
		<key>com.apple.kpi.iokit</key>
		<string>9.0.0</string>
		<key>com.apple.kpi.libkern</key>
		<string>9.0.0</string>
		<key>com.apple.kpi.mach</key>
		<string>9.0.0</string>
		<key>com.apple.kpi.unsupported</key>
		<string>9.0.0</string>
	</dict>
</dict>
<key>NodesToPatch</key>
<array>
   <dict>
      <key>Codec</key>
      <integer>0</integer>
      <key>Config</key>
      <string>0x01a19c60</string>
      <key>Node</key>
      <integer>25</integer>
   </dict>
   <dict>
      <key>Codec</key>
      <integer>0</integer>
      <key>Config</key>
      <string>0x01214070</string>
      <key>Node</key>
      <integer>33</integer>
   </dict>
</array>
</plist>

He realizado los cambios en una copia del plist que tenía en el escritorio y luego la he reemplazado por la original.
He reparado permisos en S/L/E con Kext Wizard.
He reiniciado y ha arrancado bien, pero ahora no hay ningún dispositivo de audio.

En Midi no marca nada.
En sonido tampoco.
En el panel de VoodooHDA marca 3 dispositivos, pero da error cada vez que se abre y cuando tocas cualquier cosa.

He hecho algo mal?
Perdona por la paliza... ;)

Saludos
ASUS N71JQ
Intel Core i7 720QM
4GB Ram
Ati Mobility Radeon 5730 1 GB Vram.
ALC663
Atheros 8131
Atheros 9285

P5KPL/EPU
Intel Core2 Quad 2,40
Nvidia 9600GT 512
User avatar
Cassio
Olarila Staff
Olarila Staff
Posts: 3765
Joined: 26 Aug 2011, 22:53

Re: VoodooHDA - problemas comuns

Post by Cassio » 27 Feb 2012, 23:45

Já existe uma chave NodesToPatch no plist, que você deve substituir pela que eu postei, e não incluir uma nova no final do arquivo.

Você tem que verificar no System Info se o ID do seu áudio é mesmo 3b56, esse valor é apenas um exemplo.
ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: [External Link Removed for Guests] • Linux Mint 15 • Windows 8
Predatux
Posts: 38
Joined: 10 Feb 2012, 13:35

Re: VoodooHDA - problemas comuns

Post by Predatux » 28 Feb 2012, 00:01

Ei, he conseguido audio ;)
Funcionan los altavoces del portátil...

Ahora estoy probando a editar de nuevo el plist y modificar lo que me has dicho, a ver si de una vez por todas ;)

Mil gracias, luego te cuento.
ASUS N71JQ
Intel Core i7 720QM
4GB Ram
Ati Mobility Radeon 5730 1 GB Vram.
ALC663
Atheros 8131
Atheros 9285

P5KPL/EPU
Intel Core2 Quad 2,40
Nvidia 9600GT 512
Predatux
Posts: 38
Joined: 10 Feb 2012, 13:35

Re: VoodooHDA - problemas comuns

Post by Predatux » 28 Feb 2012, 00:12

Todo funcionando correctamente...

Recuerda que debo invitarte a unas cervezas bien frías... ;) ;)

Mil gracias por todo... Nos vemos en el siguiente problema, jeje.

A todo esto, no sabrás el motivo por el cual la configuración MIDI se restaura en cada reinicio? Me tiene loco.
ASUS N71JQ
Intel Core i7 720QM
4GB Ram
Ati Mobility Radeon 5730 1 GB Vram.
ALC663
Atheros 8131
Atheros 9285

P5KPL/EPU
Intel Core2 Quad 2,40
Nvidia 9600GT 512
Post Reply

Return to “Guias e tutoriais”