-->Donations via PayPal [External Link Removed for Guests] :guitar
-->Installation/Post Installation Tutorial [Local Link Removed for Guests]
-->Useful Links [Local Link Removed for Guests]
-->Olarila Images - Updated images [Local Link Removed for Guests]
-->Guides and Tutorials [Local Link Removed for Guests]
-->Clover Folder for All Chipsets [Local Link Removed for Guests]
-->DSDT Patch Requests [Local Link Removed for Guests]

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore 0.5.3

User avatar
MaLd0n
Site Admin
Site Admin
Posts: 16254
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by MaLd0n » 27 Oct 2019, 14:15

acdindia, extract new send_me

Added in 4 minutes 3 seconds:
mgw_smy,
DSDT.aml.zip
You do not have the required permissions to view the files attached to this post.
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
SysAdminPgh
Posts: 8
Joined: 23 Oct 2019, 15:27
CPU: Intel i7-7770
Motherboard: z270
GPU: RX580

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by SysAdminPgh » 27 Oct 2019, 15:01

Hi... Thanks for the help but still won't work with the RX580. I did notice that in Graphics Injector it lists the video card as a RX480 rather than a RX580. Should I give up on this card and return it? Never had issues before like this. Nothing changes but the video card. I've taken another Send Me and a screen shot in case they might help. Again thanks!
You do not have the required permissions to view the files attached to this post.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 16254
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by MaLd0n » 27 Oct 2019, 15:04

SysAdminPgh, use weg kext and disable intelhdgraphics in bios/uefi, u need configure this IGPU
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
acdindia
Posts: 8
Joined: 15 Jul 2012, 13:06

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by acdindia » 27 Oct 2019, 15:22

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
27 Oct 2019, 14:19
acdindia, extract new send_me

Added in 4 minutes 3 seconds:
mgw_smy, DSDT.aml.zip
Ok. Here is the file.
Send me Adityas-MacBook-Pro.zip
Please note that I've extracted this from a system booted using your provided DSDT.
If you require, I'll try booting without DSDT and extract again.

Thanking you!
You do not have the required permissions to view the files attached to this post.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 16254
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by MaLd0n » 27 Oct 2019, 15:29

acdindia,
DSDT.aml.zip
UR TRACKPAD IS JUST A KEXT, I THINK UR DEVICE IS NOT I2C
You do not have the required permissions to view the files attached to this post.
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
acdindia
Posts: 8
Joined: 15 Jul 2012, 13:06

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by acdindia » 27 Oct 2019, 15:37

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
27 Oct 2019, 15:29
acdindia, DSDT.aml.zip
UR TRACKPAD IS JUST A KEXT, I THINK UR DEVICE IS NOT I2C
Thank you!
I'll give it a try. Maybe I'll have to hunt for other kexts.
Will report back with results.
Thanks again MaLd0n! :crazy:

Added in 21 minutes 42 seconds:
MaLd0n, Sorry but it didn’t work. :help

If I boot with my charger plugged in, it’ll keep showing me “Plugged in” even if I unplug it and if I boot unplugged, it’ll keep showing me “On battery” even if I plug it.
Bluetooth hardware not found.
Camera, not found.
Trackpad, same. Can’t even click and drag. Even the trackpad buttons are non-functional. :hammer
:help Please help.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 16254
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by MaLd0n » 27 Oct 2019, 22:32

acdindia, u need solve usb
use battery plugin from virtual smc project
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
MorenoAv
Posts: 18
Joined: 30 Jul 2017, 11:29
CPU: i5 9600K
Motherboard: GA Z390 - I Aorus Pro Wifi
GPU: Intel UHD 630

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by MorenoAv » 27 Oct 2019, 23:32

Hi good night to all,
MaLd0n, i booted with your EFI, but my sound is gone could you help me with that?
You do not have the required permissions to view the files attached to this post.
mgw_smy
Posts: 5
Joined: 27 Oct 2019, 09:33
CPU: i5-8400
Motherboard: z370-a
GPU: rx570

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by mgw_smy » 28 Oct 2019, 10:01

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
27 Oct 2019, 14:19
acdindia, extract new send_me

Added in 4 minutes 3 seconds:
mgw_smy, DSDT.aml.zip
Thank you!
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 16254
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by MaLd0n » 28 Oct 2019, 12:43

MorenoAv, full dump
--Run_Me
[Local Link Removed for Guests]
[External Link Removed for Guests]
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
MorenoAv
Posts: 18
Joined: 30 Jul 2017, 11:29
CPU: i5 9600K
Motherboard: GA Z390 - I Aorus Pro Wifi
GPU: Intel UHD 630

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by MorenoAv » 28 Oct 2019, 23:08

Hi MaLd0n,
Here it is this time I think is the right one...
Thanks in Advance
You do not have the required permissions to view the files attached to this post.
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 16254
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by MaLd0n » 28 Oct 2019, 23:44

MorenoAv,
Arquivo Comprimido.zip
You do not have the required permissions to view the files attached to this post.
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
SysAdminPgh
Posts: 8
Joined: 23 Oct 2019, 15:27
CPU: Intel i7-7770
Motherboard: z270
GPU: RX580

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by SysAdminPgh » 29 Oct 2019, 20:41

MaLdOn I added WEG. Not sure why I removed it. I only have two graphic choices in this BIOS. Initiate Graphic Adapter which I set to PEG and IGD Multi-Monitor which I set to Disabled. No IntelGraphics even in OC section. Can you point me in the right direction on how to configure the iGPU? I thought this video card was good to go without having to do anything. Does it matter that it is a XFX card?

Thanks!
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 16254
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by MaLd0n » 29 Oct 2019, 21:48

SysAdminPgh, Asus mobo is Multi Monitor option
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
anibalin
Posts: 16
Joined: 01 Nov 2011, 21:26

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by anibalin » 29 Oct 2019, 23:14

Hi MAldon!
Wondering Im not getting any list on PCI as you do?
Image
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 16254
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by MaLd0n » 30 Oct 2019, 00:35

anibalin, hey
is a full dsdt patch, cosmetics. essentials, removed unused devices, etc ;)
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
SysAdminPgh
Posts: 8
Joined: 23 Oct 2019, 15:27
CPU: Intel i7-7770
Motherboard: z270
GPU: RX580

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by SysAdminPgh » 30 Oct 2019, 02:07

MaLdOn - Did your suggestions and I end up with the following....

AMF: No Slide Values are usable! Falling back to 0 with 0x0D68A000 bytes!
Error Allocating 0x11BD6 pages at 0x00000000046C8000 alloc type 2
Couldn't allocate runtime area
Boot failed: Will sleep for 10 seconds before exiting

Never exits.

Any other suggestions before this card goes into the Mon river?

Thanks!
User avatar
MaLd0n
Site Admin
Site Admin
Posts: 16254
Joined: 05 Dec 2010, 19:35
CPU: i9-9900K
Motherboard: GA Z390 M GAMING
GPU: RX 590 8 GB
Location: Rio de Janeiro, Brazil
Contact:

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by MaLd0n » 30 Oct 2019, 02:10

SysAdminPgh, u have my full dsdt patch?
--Donations via PayPal [External Link Removed for Guests] :guitar

--Problems with Paypal? Check Here [Local Link Removed for Guests] :guitar

--Useful Links [Local Link Removed for Guests] :guitar

--Olarila Hackintosh Builds [Local Link Removed for Guests] :guitar

--Donated? Send me one Private Message
SysAdminPgh
Posts: 8
Joined: 23 Oct 2019, 15:27
CPU: Intel i7-7770
Motherboard: z270
GPU: RX580

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by SysAdminPgh » 30 Oct 2019, 03:04

It's in the ACPI/patched folder. When I downloaded the Read me file it was with the 1050 Ti video card installed. I get no where with the RX580. Does that matter? Want to see my EFI?
acdindia
Posts: 8
Joined: 15 Jul 2012, 13:06

Mojave / Catalina on Mobos Series 100/200/300 with OpenCore

Post by acdindia » 30 Oct 2019, 04:24

[Local Link Removed for Guests] wrote: [Local Link Removed for Guests]
27 Oct 2019, 22:32
acdindia, u need solve usb
use battery plugin from virtual smc project
Hey MaLd0N! :superman
Finally, I was able to solve my USB issues by using USBInjectAll.kext and a custom SSDT to disable any unused ports.
This brought my Bluetooth, camera and don't know how Trackpad in action!
But, sadly, battery seems to be an issue. :/
I'm using battery kext from the VirtualSMC project.
Anything else that I must try? :help
Also, the battery seems to drain really fast, I mean, really really fast..! :hammer
NVIDIA is disabled in DSDT as I can't see it in my system preferences. What might be an issue ?
How may I say if my Hacky is tuned and needs no more work ?

Apologies for too many questions!
Thank you for all your help! :frantics
Post Reply

Return to “Guides and tutorials”