-->Donations via PayPal [External Link Removed for Guests] :guitar
-->Installation/Post Installation Tutorial [Local Link Removed for Guests]
-->Useful Links [Local Link Removed for Guests]
-->Olarila Images - Updated images [Local Link Removed for Guests]
-->Guides and Tutorials [Local Link Removed for Guests]
-->Clover Folder for All Chipsets [Local Link Removed for Guests]
-->DSDT Patch Requests [Local Link Removed for Guests]

Still waiting for root device

User avatar
oldnapalm
Olarila Staff
Olarila Staff
Posts: 1225
Joined: 05 Dec 2010, 20:49

Still waiting for root device

Post by oldnapalm » 24 Dec 2010, 11:50

Se o boot no modo verbose parar nesta mensagem, é provável que você não tenha instalado o driver correto da controladora SATA/ATA. Estes drivers também são chamados de chipset drivers, e os mais comuns são Intel (AppleIntelPIIXATA.kext), VIA (AppleVIAATA.kext), ATI (AppleATIATA.kext) e nForce (AppleNForceATA.kext). Consulte o manual da sua placa mãe ou o site do fabricante, descubra qual a controladora onde o seu HD está ligado e instale o driver correspondente.

Se a sua controladora possui a opção AHCI na BIOS, utilize esta opção que ela deve funcionar sem drivers adicionais.

Veja [Local Link Removed for Guests] como editar a kext original para que a controladora Intel funcione no modo IDE.

Veja [Local Link Removed for Guests] como configurar o Windows Vista ou 7 para funcionar no modo AHCI, caso você tenha instalado com a controladora no modo IDE.
Wilson Moura
Posts: 73
Joined: 08 Dec 2011, 00:14

Re: Still waiting for root device

Post by Wilson Moura » 15 Dec 2011, 18:15

Se eu tiver a kext correta do chipset da placa mãe, eu deverei excluir as outras ? ou nao faz diferença ?
valews !!
Intel Core 2 Quad Q9650 .. Gigabyte Ga-G41mt-s2p...8Gb DDR3 Kingston ...Driver CD/DVD Bluray LG..Power Thermaltek 700W ....Card Firewire PCi Texas Instruments ...Card Firewire PCI-Express Texas Instruments ...
EVGA Ge-Force 9600GT 1Gb
User avatar
Cassio
Olarila Staff
Olarila Staff
Posts: 3765
Joined: 26 Aug 2011, 22:53

Re: Still waiting for root device

Post by Cassio » 15 Dec 2011, 18:18

Não faz diferença.
ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: [External Link Removed for Guests] • Linux Mint 15 • Windows 8
User avatar
rodrigo_tuim
Posts: 22
Joined: 20 Mar 2012, 00:02

Re: Still waiting for root device

Post by rodrigo_tuim » 20 Mar 2012, 20:59

Tô tendo este problema na instalação.
Ou melhor, nem consigo chegar na tela da maçã.
Faço o boot com o hackboot v7 (i5, 2500+asus p8p67), troco o disco para o snow leopard 10.6.7, e após listar alguns comandos aparece esta mensagem: still waiting for root device. E fica repetindo a mesma mensagem enquanto eu deixar rodando.

Tenho dois hds no pc. Os dois de 1tb cada, particionados com 500gb.
Devo desconectar o hd que não está com o windows?

Na minha bios já está enable hsci para controladora sata.

Valeu galera.!!
Asus P8P67-LE - I5 2500 sandy bridge - 8GB DDR3 1333 - ATI 5750 Saphire formula
1 HD Seagate 7200.12 1TB: Windows - 1HD Seagate 7200.12 1TB - Mac Os X
User avatar
Cassio
Olarila Staff
Olarila Staff
Posts: 3765
Joined: 26 Aug 2011, 22:53

Re: Still waiting for root device

Post by Cassio » 21 Mar 2012, 02:02

Veja se o DVD não tá ligado na controladora Marvell, se tiver, ligue na Intel.
ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: [External Link Removed for Guests] • Linux Mint 15 • Windows 8
User avatar
rodrigo_tuim
Posts: 22
Joined: 20 Mar 2012, 00:02

Re: Still waiting for root device

Post by rodrigo_tuim » 22 Mar 2012, 16:22

Valeu, Cássio.
Quando sobrar um tempo vou fazer novos testes!
Asus P8P67-LE - I5 2500 sandy bridge - 8GB DDR3 1333 - ATI 5750 Saphire formula
1 HD Seagate 7200.12 1TB: Windows - 1HD Seagate 7200.12 1TB - Mac Os X
vipzen
Posts: 9
Joined: 11 Jul 2012, 00:45

Re: Still waiting for root device

Post by vipzen » 15 Jul 2012, 06:14

Me deparei com este erro quando tentei fazer um clone do meu HDD para outro, para backup mesmo. Usei o CCC (Carbon Copy Cloner) e o SuperDuper, mas parece que ambos não copiam a sessão do disco referente ao bootloader... pesquisei, pesquisei, tentei reinstalar só o Chameleon no novo disco, nada. Tentei um tal de EFI alguma coisa, nada. Tentei bootar com -x, nada. Até que desisti e acabei por instalar o OS X no novo HDD... do zero.

Então cabe a pergunta: há como clonar o HDD inteiro incluindo o bootloader, de modo que em caso de pane de hardware, uma troca rápida de disco possa ser feita? Senão, qual a sugestão de backup mais prática?
User avatar
Cassio
Olarila Staff
Olarila Staff
Posts: 3765
Joined: 26 Aug 2011, 22:53

Re: Still waiting for root device

Post by Cassio » 15 Jul 2012, 14:21

Os 2 primeiros estágios do bootloader (boot0 e boot1h) não são clonados, mas reinstalando o Chameleon deveria funcionar.

O HD novo tá ligado na mesma controladora que o antigo?

Se houve mudança no UUID do disco, você pode tentar forçar com o parâmetro boot-uuid.
ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: [External Link Removed for Guests] • Linux Mint 15 • Windows 8
User avatar
bili.onario
Posts: 13
Joined: 10 May 2013, 23:41
CPU: Corei7
Motherboard: P8P67-PRO
GPU: GTX560Ti

Re: Still waiting for root device

Post by bili.onario » 22 Oct 2013, 17:42

Pergunta.. tenho este problema para instalação do Hackintosh, tem como editar essas kext que nosso amigo "oldnapalm" informa e depois instalar???
Sony VPCCW23FX - Core i3 330M - 4Gb - 500Gb - GT310M (Mavericks 90%)
PC ASUS P8P67 PRO - Corei7 - 16Gb - 500Gb - GTX560Ti (Mavericks Perfect)
User avatar
pernacabeluda
Olarila Staff
Olarila Staff
Posts: 4896
Joined: 22 Oct 2012, 01:35

Re: Still waiting for root device

Post by pernacabeluda » 22 Oct 2013, 22:30

De qual kext você está falando?

A instalação é por DVD ou USB? Se for por USB, verifica que o instalador possui kexts para USB 3.0 (se for o caso) e tenta ativar os "fixes" para USB do boot loader (USBBusFix=Yes no Chameleon ou menu USB no Clover).
User avatar
bili.onario
Posts: 13
Joined: 10 May 2013, 23:41
CPU: Corei7
Motherboard: P8P67-PRO
GPU: GTX560Ti

Re: Still waiting for root device

Post by bili.onario » 25 Oct 2013, 16:30

pernacabeluda wrote:De qual kext você está falando?

A instalação é por DVD ou USB? Se for por USB, verifica que o instalador possui kexts para USB 3.0 (se for o caso) e tenta ativar os "fixes" para USB do boot loader (USBBusFix=Yes no Chameleon ou menu USB no Clover).
Como meu problema é na instalação, e minha BIOS não tem a opção AHCI apenas SATA, acredito que seja referente aos "driver correto da controladora SATA/ATA"

oldnapalm comenta sobre a edição da kext "Para editar o Info.plist da AppleIntelPIIXATA você pode usar o comando.." minha dúvida é: em que momento e como faço?
Obrigado
Sony VPCCW23FX - Core i3 330M - 4Gb - 500Gb - GT310M (Mavericks 90%)
PC ASUS P8P67 PRO - Corei7 - 16Gb - 500Gb - GTX560Ti (Mavericks Perfect)
User avatar
pernacabeluda
Olarila Staff
Olarila Staff
Posts: 4896
Joined: 22 Oct 2012, 01:35

Re: Still waiting for root device

Post by pernacabeluda » 25 Oct 2013, 17:03

Você não respondeu se a instalação é por DVD ou USB.
User avatar
bili.onario
Posts: 13
Joined: 10 May 2013, 23:41
CPU: Corei7
Motherboard: P8P67-PRO
GPU: GTX560Ti

Re: Still waiting for root device

Post by bili.onario » 25 Oct 2013, 17:24

pernacabeluda wrote:Você não respondeu se a instalação é por DVD ou USB.
Perdão, a instalação é pelo DVD do iATKOS ML.
Também tenho o iATKOS SL.
Sony VPCCW23FX - Core i3 330M - 4Gb - 500Gb - GT310M (Mavericks 90%)
PC ASUS P8P67 PRO - Corei7 - 16Gb - 500Gb - GTX560Ti (Mavericks Perfect)
User avatar
pernacabeluda
Olarila Staff
Olarila Staff
Posts: 4896
Joined: 22 Oct 2012, 01:35

Re: Still waiting for root device

Post by pernacabeluda » 25 Oct 2013, 17:30

Recomendo que use um dos métodos explicados no fórum, não damos suporte a iatkos.

De qualquer maneira, não vejo como editar arquivos num DVD sem gravar novamente, melhor usar um pen drive.
gustavobgs
Posts: 12
Joined: 12 Dec 2013, 22:57
CPU: Core 2 Quad q6600
Motherboard: DG965WH
GPU: GTX 550TI

Re: Still waiting for root device

Post by gustavobgs » 14 Dec 2013, 13:19

Estou tentando instalar o ML e o Maverick

Ambas imagens baixadas daqui do site..

o método que estou utilizando para instalar é via usb bootavel..

Já mudei na bio da placa mãe para ahci e mesmo assim, quando vou dar o boot para instalar aparece a mensagem still waiting root device..

alguém poderia me ajudar?
User avatar
pernacabeluda
Olarila Staff
Olarila Staff
Posts: 4896
Joined: 22 Oct 2012, 01:35

Re: Still waiting for root device

Post by pernacabeluda » 14 Dec 2013, 14:22

Se o boot é por USB não tem nada a ver com SATA/AHCI.

Tenta ativar os fixes USB no menu de opções do Clover.
gustavobgs
Posts: 12
Joined: 12 Dec 2013, 22:57
CPU: Core 2 Quad q6600
Motherboard: DG965WH
GPU: GTX 550TI

Re: Still waiting for root device

Post by gustavobgs » 15 Dec 2013, 14:08

Engraçado que já ativei todas as opções usb lá do do cloover pelo boot usb :(

segue imagens
Image
Image
User avatar
pernacabeluda
Olarila Staff
Olarila Staff
Posts: 4896
Joined: 22 Oct 2012, 01:35

Re: Still waiting for root device

Post by pernacabeluda » 15 Dec 2013, 14:22

Tenta com o Chameleon.
gustavobgs
Posts: 12
Joined: 12 Dec 2013, 22:57
CPU: Core 2 Quad q6600
Motherboard: DG965WH
GPU: GTX 550TI

Re: Still waiting for root device

Post by gustavobgs » 15 Dec 2013, 15:06

Coloquei umas screen do que acontece qd booto pelo cloover.
Te mandei pm pernacabeluda..
User avatar
pernacabeluda
Olarila Staff
Olarila Staff
Posts: 4896
Joined: 22 Oct 2012, 01:35

Re: Still waiting for root device

Post by pernacabeluda » 15 Dec 2013, 15:10

Tenta com Chameleon. Se acontecer a mesma coisa, tenta mudar as configurações do BIOS relacionadas a USB.

Usa o fórum, PM é para assuntos pessoais, não para pedir ajuda.
Post Reply

Return to “Guias e tutoriais”